Modify

Opened 3 years ago

Closed 4 months ago

#12829 closed defect (duplicate)

Плагин ’Reverter’ завешается с ошибкой, при отмене этого пакета правок: http://www.openstreetmap.org/changeset/39143626

Reported by: luiswoo Owned by: Upliner
Priority: normal Milestone:
Component: Plugin reverter Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

GT: The plugin 'Reverter' hung with an error when canceling edits this package: http://www.openstreetmap.org/changeset/39143626

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-05-02 10:23:17 +0200 (Mon, 02 May 2016)
Build-Date:2016-05-03 01:31:45
Revision:10168
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10168 ru) Linux Fedora release 23 (Twenty Three)
Memory Usage: 471 MB / 875 MB (286 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
VM arguments: [-agentpath:/usr/lib/abrt-java-connector/libabrt-java-connector.so=abrt=on]
Dataset consistency test: No problems found

Plugins:
- CommandLine (31927)
- DxfImport (1006)
- FastDraw (31895)
- HouseNumberTaggingTool (31772)
- OpeningHoursEditor (31772)
- PicLayer (31895)
- SimplifyArea (31895)
- Tracer2 (32042)
- alignways (31895)
- apache-commons (31895)
- buildings_tools (31895)
- colorscheme (31772)
- contourmerge (1014)
- dataimport (31772)
- ejml (31895)
- ext_tools (31772)
- geotools (31895)
- imagery_offset_db (32046)
- importvec (31772)
- jts (31772)
- measurement (31895)
- opendata (32139)
- pdfimport (32019)
- reltoolbox (31895)
- reverter (32005)
- splinex (31895)
- undelete (31895)
- utilsplugin2 (32099)
- waydownloader (31772)

Tagging presets:
- https://josm.openstreetmap.de/josmfile?page=Presets/Addr2&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Towers&zip=1

Map paint styles:
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/NewHighwayColors&zip=1

Last errors/warnings:
- E: java.net.SocketException: Socket closed
- W: org.openstreetmap.josm.io.OsmTransferCanceledException: Operation canceled. Причина: org.openstreetmap.josm.io.OsmTransferException: Не удается соединиться с сервером OSM. Пожалуйста, проверьте Ваше интернет-соединение.. Причина: java.net.SocketException: Socket closed
- E: java.lang.IllegalStateException: Отсутствует результат объединения типа отношение с id 168 711
- E: java.lang.IllegalStateException: Отсутствует результат объединения типа отношение с id 168 711
- E: java.lang.IllegalStateException: Отсутствует результат объединения типа отношение с id 168 711

java.lang.IllegalStateException: Отсутствует результат объединения типа отношение с id 168 711
	at reverter.DataSetCommandMerger.getMergeTarget(DataSetCommandMerger.java:61)
	at reverter.DataSetCommandMerger.mergeRelation(DataSetCommandMerger.java:145)
	at reverter.DataSetCommandMerger.merge(DataSetCommandMerger.java:178)
	at reverter.DataSetCommandMerger.<init>(DataSetCommandMerger.java:45)
	at reverter.ChangesetReverter.getCommands(ChangesetReverter.java:344)
	at reverter.RevertChangesetTask.realRun(RevertChangesetTask.java:110)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:161)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by mdk

#12809, #12829, #13981, #13986 and #13987 are failing with same callstack.

comment:2 Changed 3 years ago by skyper

#11136 is similar

comment:3 Changed 4 months ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #11136.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Upliner.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.