Modify

Opened 7 years ago

Closed 7 years ago

#12715 closed defect (duplicate)

Leaving 'Keep outline way' de-selected causes crash

Reported by: alexkemp Owned by: team
Priority: normal Milestone:
Component: Plugin terracer Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Shift-T when Building selected
  2. In this case) choose numbers for 4 terraces + select relation
  3. Select Keep outline way + press OK

What is the expected result?

A set of 4 terraced houses

What happens instead?

JOSM crash

Any extra?

Always causes Warning on missing relation

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-03-13 01:17:21 +0100 (Sun, 13 Mar 2016)
Build-Date:2016-03-13 02:35:00
Revision:9979
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9979 en_GB) Linux Debian GNU/Linux 8.3 (jessie)
Memory Usage: 175 MB / 247 MB (81 MB allocated, but free)
Java version: 1.8.0_77-b03, Oracle Corporation, Java HotSpot(TM) Client VM
VM arguments: [-Djava.net.useSystemProxies=true]

Dataset consistency test:
[NO DATASET] {Way id=-8106 version=0 MVT nodes=[{Node id=-8103 version=0 MV lat=52.96370834969027,lon=-1.13222921689949}, {Node id=-8125 version=0 MV lat=52.963736419865626,lon=-1.1321755727191922}, {Node id=-8126 version=0 MV lat=52.96368526431585,lon=-1.1321017891324148}, {Node id=-8104 version=0 MV lat=52.96365719410726,lon=-1.1321554333127126}, {Node id=-8103 version=0 MV lat=52.96370834969027,lon=-1.13222921689949}]} is referenced by {Relation id=-8136 version=0 VT [way -8106, way -8133, way -8134, way -8135]} but not found in dataset


Plugins:
- DirectUpload (30762)
- HouseNumberTaggingTool (31772)
- buildings_tools (31895)
- continuosDownload (1446070193)
- imagery_offset_db (32046)
- imageryadjust (31772)
- terracer (31895)
- utilsplugin2 (32099)

Last errors/warnings:
- W: java.net.SocketException: Socket closed
- E: java.net.SocketException: Socket closed
- E: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Relation member must be part of the same dataset as relation(relation -8136, way -8106)

org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Relation member must be part of the same dataset as relation(relation -8136, way -8106)
	at org.openstreetmap.josm.data.osm.Relation.checkMembers(Relation.java:502)
	at org.openstreetmap.josm.data.osm.Relation.setDataset(Relation.java:492)
	at org.openstreetmap.josm.data.osm.DataSet.addPrimitive(DataSet.java:469)
	at org.openstreetmap.josm.command.AddCommand.executeCommand(AddCommand.java:61)
	at org.openstreetmap.josm.command.SequenceCommand.executeCommand(SequenceCommand.java:54)
	at terracer.TerracerAction$1.executeCommand(TerracerAction.java:470)
	at org.openstreetmap.josm.data.UndoRedoHandler.addNoRedraw(UndoRedoHandler.java:43)
	at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:69)
	at terracer.TerracerAction.terraceBuilding(TerracerAction.java:428)
	at terracer.HouseNumberInputHandler.actionPerformed(HouseNumberInputHandler.java:294)
	at terracer.HouseNumberInputDialog.buttonAction(HouseNumberInputDialog.java:235)
	at org.openstreetmap.josm.gui.ExtendedDialog$1.actionPerformed(ExtendedDialog.java:326)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2022)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2348)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:376)
	at javax.swing.plaf.basic.BasicRootPaneUI$Actions.actionPerformed(BasicRootPaneUI.java:208)
	at javax.swing.SwingUtilities.notifyAction(SwingUtilities.java:1663)
	at javax.swing.JComponent.processKeyBinding(JComponent.java:2882)
	at javax.swing.KeyboardManager.fireBinding(KeyboardManager.java:307)
	at javax.swing.KeyboardManager.fireKeyboardAction(KeyboardManager.java:250)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(JComponent.java:2974)
	at javax.swing.JComponent.processKeyBindings(JComponent.java:2966)
	at javax.swing.JComponent.processKeyEvent(JComponent.java:2845)
	at java.awt.Component.processEvent(Component.java:6312)
	at java.awt.Container.processEvent(Container.java:2236)
	at java.awt.Component.dispatchEventImpl(Component.java:4891)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Component.dispatchEvent(Component.java:4713)
	at java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1954)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(DefaultKeyboardFocusManager.java:806)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(DefaultKeyboardFocusManager.java:1074)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:945)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:771)
	at java.awt.Component.dispatchEventImpl(Component.java:4762)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Window.dispatchEventImpl(Window.java:2750)
	at java.awt.Component.dispatchEvent(Component.java:4713)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:86)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:109)
	at java.awt.WaitDispatchSupport$2.run(WaitDispatchSupport.java:184)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:229)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:227)
	at java.security.AccessController.doPrivileged(Native Method)
...<snip>...

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by Don-vip

Component: CorePlugin terracer

comment:2 Changed 7 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #12695.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.