Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12675 closed defect (fixed)

OSM server error: "Opening and ending tag mismatch"

Reported by: mikini Owned by: team
Priority: normal Milestone: 16.04
Component: Core Version: tested
Keywords: Cc:

Description (last modified by Don-vip)

Hi there.

After a short editing session I uploaded changes opening a new changeset and leaving it open. When trying to save changes afterwards I got a nice dialog with a message similar to the exception below ("Fatal error: Opening and ending tag mismatch: anonymous line 3 and changeset at :7").

I went to the Upload dialog's Changeset tab and tried to update my opened changeset list and toggled "Upload to a new changeset" and back to "Upload to an existing changeset" selecting the only open changeset. This made the upload succeed.

Shortly after I was inspecting the history of a way (137307317) and when clicking on a node in the Nodes list of the Nodes tab the exception below occured. Screenshot of this is attached.

Additionally I got this error when using the pre-filled form link in the exception dialog (this was before creating an account on Trac):
"Genshi UnicodeDecodeError error while rendering template '/usr/local/lib/python2.7/dist-packages/Trac-1.0.9-py2.7.egg/trac/ticket/templates/ticket.html', line 251, char -1"

Thanks


URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-03-13 01:17:21 +0100 (Sun, 13 Mar 2016)
Build-Date:2016-03-13 02:35:00
Revision:9979
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9979 en) Linux Ubuntu 15.10
Memory Usage: 305 MB / 1682 MB (100 MB allocated, but free)
Java version: 1.7.0_95-b00, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u95-2.6.4-0ubuntu0.15.10.1
Dataset consistency test: No problems found

Plugins:
- imagery_offset_db (32046)
- utilsplugin2 (32099)

Last errors/warnings:
- E: Error header: Cannot parse valid changeset from xml string <?xml version='1.0' encoding='UTF-8'?>,<osm version='0.6' generator='JOSM'>,<changeset  id='38038262' user='<anonymous>' uid='-1' open='true'>,<tag k='comment' v='Add some details around Guldager Mølledam.' />,<tag k='created_by' v='JOSM/1.5 (9979 en)' />,<tag k='source' v='survey; Geodatastyrelsen (Denmark)' />,</changeset>,</osm>,. Fatal error: Opening and ending tag mismatch: anonymous line 3 and changeset at :7.
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<Cannot parse valid changeset from xml string <?xml version=1.0 encoding=UTF-8?>,<osm version=0.6 generator=JOSM>,<changeset  id=38038262 user=<anonymous> uid=-1 open=true>,<tag k=comment v=Add some details around Guldager Mølledam. />,<tag k=created_by v=JOSM/1.5 (9979 en) />,<tag k=source v=survey; Geodatastyrelsen (Denmark) />,</changeset>,</osm>,. Fatal error: Opening and ending tag mismatch: anonymous line 3 and changeset at :7.>, Error Body=<Cannot parse valid changeset from xml string <?xml version=1.0 encoding=UTF-8?>
- E: Error header: Cannot parse valid changeset from xml string <?xml version='1.0' encoding='UTF-8'?>,<osm version='0.6' generator='JOSM'>,<changeset  id='38038262' user='<anonymous>' uid='-1' open='true'>,<tag k='comment' v='Add some details around Guldager Mølledam.' />,<tag k='created_by' v='JOSM/1.5 (9979 en)' />,<tag k='source' v='survey; Geodatastyrelsen (Denmark)' />,</changeset>,</osm>,. Fatal error: Opening and ending tag mismatch: anonymous line 3 and changeset at :7.
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<Cannot parse valid changeset from xml string <?xml version=1.0 encoding=UTF-8?>,<osm version=0.6 generator=JOSM>,<changeset  id=38038262 user=<anonymous> uid=-1 open=true>,<tag k=comment v=Add some details around Guldager Mølledam. />,<tag k=created_by v=JOSM/1.5 (9979 en) />,<tag k=source v=survey; Geodatastyrelsen (Denmark) />,</changeset>,</osm>,. Fatal error: Opening and ending tag mismatch: anonymous line 3 and changeset at :7.>, Error Body=<Cannot parse valid changeset from xml string <?xml version=1.0 encoding=UTF-8?>
- E: java.lang.NullPointerException

java.lang.NullPointerException
	at org.openstreetmap.josm.gui.history.NodeListTableCellRenderer.renderNode(NodeListTableCellRenderer.java:37)
	at org.openstreetmap.josm.gui.history.NodeListTableCellRenderer.getTableCellRendererComponent(NodeListTableCellRenderer.java:57)
	at javax.swing.JTable$AccessibleJTable.getAccessibleChild(JTable.java:7044)
	at javax.swing.JTable$AccessibleJTable.getAccessibleAt(JTable.java:7431)
	at javax.swing.JTable$AccessibleJTable.valueChanged(JTable.java:6946)
	at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:184)
	at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:164)
	at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:211)
	at javax.swing.DefaultListSelectionModel.changeSelection(DefaultListSelectionModel.java:405)
	at javax.swing.DefaultListSelectionModel.changeSelection(DefaultListSelectionModel.java:415)
	at javax.swing.DefaultListSelectionModel.setSelectionInterval(DefaultListSelectionModel.java:459)
	at javax.swing.JTable.changeSelectionModel(JTable.java:2389)
	at javax.swing.JTable.changeSelection(JTable.java:2458)
	at javax.swing.plaf.basic.BasicTableUI$Handler.adjustSelection(BasicTableUI.java:1109)
	at javax.swing.plaf.basic.BasicTableUI$Handler.mousePressed(BasicTableUI.java:1032)
	at java.awt.AWTEventMulticaster.mousePressed(AWTEventMulticaster.java:280)
	at java.awt.AWTEventMulticaster.mousePressed(AWTEventMulticaster.java:279)
	at java.awt.AWTEventMulticaster.mousePressed(AWTEventMulticaster.java:279)
	at java.awt.Component.processMouseEvent(Component.java:6513)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3312)
	at java.awt.Component.processEvent(Component.java:6281)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4872)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4489)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:747)
	at java.awt.EventQueue.access$300(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:706)
	at java.awt.EventQueue$3.run(EventQueue.java:704)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:77)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:720)
	at java.awt.EventQueue$4.run(EventQueue.java:718)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:77)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:717)
	at org.GNOME.Accessibility.AtkWrapper$5.dispatchEvent(AtkWrapper.java:697)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Attachments (1)

Screenshot from 2016-03-24 12-39-38.png (753.5 KB) - added by mikini 4 years ago.

Download all attachments as: .zip

Change History (6)

Changed 4 years ago by mikini

comment:1 Changed 4 years ago by Don-vip

Description: modified (diff)

comment:2 Changed 4 years ago by Don-vip

Milestone: 16.03

comment:3 Changed 4 years ago by Don-vip

NPE fixed in r10021 but root cause is bad xml encoding.

comment:4 Changed 4 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 10051/josm:

fix #12675 - fix XML encoding of user names in changeset requests

comment:5 Changed 4 years ago by Don-vip

Milestone: 16.0316.04

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.