Modify

Opened 5 years ago

Closed 5 years ago

#12618 closed defect (duplicate)

Changing a node's position sometimes doesn't to mark it as modified by JOSM

Reported by: sctrojan79 Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

Starting in version 9963, it appears that changing the latitude/longitude of a node doesn't always mark it as modified, resulting in inconsistent changes on upload.

What steps will reproduce the problem?

I have an example in changeset #37793301: specifically, some of the nodes for "Dempsey Indoor" (way #155180953) and "Edmundson Pavilion" (way #160544279) were not marked as modified when I adjusted their latitude/longitude. See the attached OSM XML file, which I saved prior to uploading this changeset.

What is the expected result?

Nodes are marked as modified when their position is changed.

What happens instead?

Some nodes are not marked as modified (unclear as to the exact cause)

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-03-11 21:05:43 +0100 (Fri, 11 Mar 2016)
Build-Date:2016-03-11 20:09:51
Revision:9963
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9963 en) Mac OS X 10.10.5
Memory Usage: 1032 MB / 3641 MB (827 MB allocated, but free)
Java version: 1.8.0_73-b02, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Djava.security.policy=file:/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/lib/security/javaws.policy, -DtrustProxy=true, -Djnlpx.home=<java.home>/bin, -Djava.security.manager, -Djnlpx.origFilenameArg=/Users/nick/Library/Application Support/Oracle/Java/Deployment/cache/6.0/56/1ee8cfb8-7f6a0555, -Djnlpx.remove=false, -Dsun.awt.warmup=true, -Djava.util.Arrays.useLegacyMergeSort=true, -Dmacosx.jnlpx.dock.name=JOSM, -Dmacosx.jnlpx.dock.icon=/Users/nick/Library/Application Support/Oracle/Java/Deployment/cache/6.0/16/47ee53d0-262d5426.icns, -Djnlp.application.href=https://josm.openstreetmap.de/download/josm.jnlp , -Djnlpx.jvm="/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java", -Djnlpx.vmargs=LURqYXZhLnV0aWwuQXJyYXlzLnVzZUxlZ2FjeU1lcmdlU29ydD10cnVlAC1Eam5scC5hcHBsaWNhdGlvbi5ocmVmPWh0dHBzOi8vam9zbS5vcGVuc3RyZWV0bWFwLmRlL2Rvd25sb2FkL2pvc20uam5scCAA]
Dataset consistency test: No problems found

Plugins:
- apache-commons (31895)
- ejml (31895)
- geotools (31895)
- jts (31772)
- opendata (32071)
- public_transport (31895)
- turnrestrictions (31895)
- utilsplugin2 (32099)

Last errors/warnings:
- W: Failed to add resource://data/validator/power.mapcss to tag checker
- W: java.io.IOException: Failed to open input stream for resource 'resource://data/validator/power.mapcss'

Attachments (1)

changeset_37793301.osm (133.6 KB) - added by sctrojan79 5 years ago.
Note that most nodes of way #155180953 are not marked as modified, despite locations being changed

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by sctrojan79

Attachment: changeset_37793301.osm added

Note that most nodes of way #155180953 are not marked as modified, despite locations being changed

comment:1 Changed 5 years ago by sctrojan79

My email is nick at meanfreepath.com if you need to contact me.

comment:2 Changed 5 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #12616.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.