Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#12570 closed enhancement (fixed)

Group similar tests

Reported by: naoliv Owned by: team
Priority: normal Milestone: 16.07
Component: Core validator Version:
Keywords: grouping Cc: Don-vip

Description

I am seeing a lot of similar tests giving ungrouped results.
For example:

http://i.imgur.com/xjGxous.png

What I could quickly see that are needing some grouping are:

In errors:

  • wrong collection_times
  • wrong opening_hours

In warnings:

  • 'email': E-mail address contains an invalid username
  • 'contact:email': E-mail address contains an invalid username
  • website: URL contains an invalid authority | URL contains an invalid path
  • lot of opening_hours tests
  • service_times tests
  • shop=something inside shop=something
  • leisure=something inside leisure=something
  • tourism=something inside tourism=something
  • amenity=something inside amenity=something

Basically everything that is using key and/or name in the warning message should be grouped, if possible (like it happened for the "Long segments" test)

JOSM:

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-02-25 01:51:43 +0100 (Thu, 25 Feb 2016)
Build-Date:2016-02-26 02:34:44
Revision:9881
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9881 en) Linux Debian GNU/Linux testing (stretch)
Memory Usage: 4065 MB / 9102 MB (1021 MB allocated, but free)
Java version: 1.8.0_72-internal-b05, Oracle Corporation, OpenJDK 64-Bit Server VM
VM arguments: [-Dawt.useSystemAAFontSettings=on]
Dataset consistency test: No problems found

Attachments (2)

12570-internet-tags.patch (2.8 KB) - added by simon04 3 years ago.
testgroup.png (5.4 KB) - added by Klumbumbus 3 years ago.

Download all attachments as: .zip

Change History (20)

comment:1 Changed 3 years ago by simon04

In 9886/josm:

see #12570 - Group opening hours tests

Changed 3 years ago by simon04

Attachment: 12570-internet-tags.patch added

comment:2 Changed 3 years ago by simon04

Cc: Don-vip added
Milestone: 16.03
Summary: Group similar tests[Patch] Group similar tests

Has to wait till 16.03 due to added I18n strings.

comment:3 Changed 3 years ago by Don-vip

didn't see the ticket until now, good patch :)

comment:4 Changed 3 years ago by simon04

In 9921/josm:

see #12570 - Group internet tags validator warnings

comment:5 Changed 3 years ago by simon04

Summary: [Patch] Group similar testsGroup similar tests

comment:6 Changed 3 years ago by Don-vip

it does not compile.

comment:7 Changed 3 years ago by simon04

In 9922/josm:

see #12570 - Group internet tags validator warnings

Fix build due to r9921.

comment:8 Changed 3 years ago by Don-vip

is this fixed?

comment:9 Changed 3 years ago by simon04

To be done in MapCSS validator:

  • shop=something inside shop=something
  • leisure=something inside leisure=something
  • tourism=something inside tourism=something
  • amenity=something inside amenity=something

comment:10 Changed 3 years ago by Don-vip

Milestone: 16.0316.04

Milestone renamed

comment:11 Changed 3 years ago by bastiK

Milestone: 16.0416.05

comment:12 Changed 3 years ago by Don-vip

Milestone: 16.0516.06

comment:13 Changed 3 years ago by Don-vip

Milestone: 16.0616.07

comment:14 Changed 3 years ago by simon04

Resolution: fixed
Status: newclosed

In 10710/josm:

fix #12570 - Group MapCSS tag checker tests

comment:15 Changed 3 years ago by Klumbumbus

If there is only one error then the group text is written at the end of the error text again. Is this the wanted behavior? It sounds a bit "doppelt gemoppelt" to me :)
amenity=driving_school innerhalb von amenity=driving_school - amenity innerhalb von amenity

Changed 3 years ago by Klumbumbus

Attachment: testgroup.png added

comment:16 Changed 3 years ago by simon04

This behaviour was not intended specifically, but it is the default behaviour when specifying a "message" and "description".

comment:17 Changed 3 years ago by Klumbumbus

Keywords: grouping added

comment:18 Changed 3 years ago by Klumbumbus

See #13798 for a regression of this feature and the fix.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.