Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12502 closed enhancement (fixed)

Warn about using leisure=park on nodes

Reported by: mdk Owned by: team
Priority: normal Milestone: 16.02
Component: Core validator Version: latest
Keywords: Cc:

Description (last modified by mdk)

According to the wiki, leisure=park should not be used on nodes (and ways, only on closed ways). JOSM shows (correctly) the "unknown" icon. But the validator shows no warning or info.
In fact it is used over 55'000 times on nodes. But if you take a closer look at these nodes, you will find typical patterns. I looked around Zürich and found (and fixed):
8 x leisure=park for mapping a single tree --> natural=tree (examples: node 3828157717, node 3927588215, node 3927588217, node 3927588213, node 3927588210, node 3927588211)
1 x leisure=park & name=Spielplatz --> create new area with leisure=playground (and without name)
8 x leisure=park & name=* inside an area (leisure=park or landuse=meadow) without name --> put tags on area

Special during #MapLesotho I found hundreds of single trees mapped with (simple to find with overpass)

  • leisure=park
  • leisure=park & natural=tree
  • and my favourite: leisure=park & name=tree

If the node has no other tags, I only saw it as mapping for a tree. All I saw are created with ID. I try ID and found the following (misleading) behaviour:

  • Start editing with ID.
  • Set a new node.
  • On the left side appears potential tags. The top key is park and the icon shows a tree.
  • this adds a node with leisure=park
  • Because these "trees" are not rendered, some mappers start to add additional tags like natural=tree or name=tree to get something shown on map.

We should at least warn about using leisure=park on a node.
We also could offer a fix for replacing the three most used cases (see above) with natural=tree

Last but not least ID shouldn’t offer leisure=park on nodes! (But instead natural=tree)

Attachments (0)

Change History (6)

comment:1 Changed 4 years ago by mdk

Description: modified (diff)
Summary: Warn about using leise=park on nodesWarn about using leisure=park on nodes

comment:2 Changed 4 years ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 9745/josm:

fix #12502 - warn about leisure=park on nodes

comment:3 in reply to:  description Changed 4 years ago by Klumbumbus

Replying to mdk:

If the node has no other tags, I only saw it as mapping for a tree. All I saw are created with ID. I try ID and found the following (misleading) behaviour:

  • Start editing with ID.
  • Set a new node.
  • On the left side appears potential tags. The top key is park and the icon shows a tree.
  • this adds a node with leisure=park
  • Because these "trees" are not rendered, some mappers start to add additional tags like natural=tree or name=tree to get something shown on map.

We should at least warn about using leisure=park on a node.
We also could offer a fix for replacing the three most used cases (see above) with natural=tree

Last but not least ID shouldn’t offer leisure=park on nodes! (But instead natural=tree)

You should report problems with ID there not here :)

comment:4 Changed 4 years ago by Klumbumbus

Milestone: 16.02

comment:5 Changed 4 years ago by mdk

I report this for ID on GitHub (https://github.com/openstreetmap/iD/issues/2974).

comment:6 Changed 4 years ago by mdk

The issue on GitHub was closed with the comment, that the wiki is wrong at this part. Even if leisure=park is allowed on nodes (which is reasonable for me) this don't solve the problem, that mappers are using ID in a wrong way. And this is in my oppinion caused by the misleading behavior of the editor.

Can anybody run a query to count

  • leisure=park as the only tag on a node
  • leisure=park only together with natural=tree on a node
  • leisure=park only together with name=tree on a node

and perhaps find out the used editors?

By the way, here is an Overpass query which find over 2000 trees mapped as park: http://overpass-turbo.eu/s/efR (see the 20kB XML data)

Last edited 4 years ago by mdk (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.