Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#12382 closed defect (fixed)

NPE when querying for history of deleted node

Reported by: malenki Owned by: team
Priority: major Milestone: 16.02
Component: Core Version:
Keywords: template_report undelete Cc:

Description (last modified by malenki)

What steps will reproduce the problem?

  1. undelete an object – it doesn't matter if with undelete or reverter plugin (example: node 2173268750)
  2. select it
  3. press ctrl-h

What is the expected result?

history window with versions pops up

What happens instead?

The NPE you see below. Additionally, JOSM then seems to be in a very unstable condition. Alt-F4 then closes layer after layer. Creating new layers and dragging around a deleted object results in additional NPEs

Please provide any additional information below. Attach a screenshot if possible.

Tested with JOSM latest on a blank ~/.josm with plugins reverter and undelete.
r9436 is fine, r9460 shows the error

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-01-16 03:00:56 +0100 (Sat, 16 Jan 2016)
Build-Date:2016-01-16 02:34:12
Revision:9480
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9480 de) Linux Debian GNU/Linux unstable (sid)
Memory Usage: 552 MB / 2222 MB (256 MB allocated, but free)
Java version: 1.8.0_72-internal-b05, Oracle Corporation, OpenJDK 64-Bit Server VM
VM arguments: [-Dsun.java2d.opengl=false]
Dataset consistency test: No problems found

Plugins:
- undelete (31895)

Last errors/warnings:
- E: java.lang.NullPointerException
- E: java.lang.reflect.InvocationTargetException. Ursache: java.lang.NullPointerException
- E: java.lang.NullPointerException

java.lang.NullPointerException
	at org.openstreetmap.josm.gui.history.CoordinateInfoViewer$MapViewer.update(CoordinateInfoViewer.java:341)
	at java.util.Observable.notifyObservers(Observable.java:159)
	at java.util.Observable.notifyObservers(Observable.java:115)
	at org.openstreetmap.josm.gui.history.HistoryBrowserModel.fireModelChange(HistoryBrowserModel.java:198)
	at org.openstreetmap.josm.gui.history.HistoryBrowserModel.setLatest(HistoryBrowserModel.java:640)
	at org.openstreetmap.josm.gui.history.HistoryBrowserModel.setHistory(HistoryBrowserModel.java:188)
	at org.openstreetmap.josm.gui.history.HistoryBrowser.populate(HistoryBrowser.java:127)
	at org.openstreetmap.josm.gui.history.HistoryBrowserDialog.setHistory(HistoryBrowserDialog.java:130)
	at org.openstreetmap.josm.gui.history.HistoryBrowserDialog.<init>(HistoryBrowserDialog.java:115)
	at org.openstreetmap.josm.gui.history.HistoryBrowserDialogManager.show(HistoryBrowserDialogManager.java:146)
	at org.openstreetmap.josm.gui.history.HistoryBrowserDialogManager$1$1.run(HistoryBrowserDialogManager.java:205)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (6)

comment:1 Changed 3 years ago by malenki

Description: modified (diff)

comment:2 Changed 3 years ago by malenki

Description: modified (diff)

comment:3 Changed 3 years ago by simon04

Resolution: fixed
Status: newclosed

In 9483/josm:

fix #12382 see #12364 - NPE when querying for history of deleted node

comment:4 Changed 3 years ago by simon04

Milestone: 16.02

comment:5 Changed 3 years ago by malenki

Thanks for the fix – this was quite speedy! :)

comment:6 Changed 3 years ago by Don-vip

Ticket #12414 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.