Modify

Opened 4 years ago

Closed 4 years ago

#12273 closed defect (fixed)

No GPS Upload of file

Reported by: bcmoore@… Owned by: bcmoore@…
Priority: normal Milestone:
Component: Plugin DirectUpload Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Load GPX file into JOSM then try to upload it via "Upload Traces"

What is the expected result?It should upload and you get a message to say successful upload.

What happens instead?On clicking "Upload Trace" PC screen flashes and upload button greys out, no upload. PC and JOSM do not lock up. Able to carry on working.

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2015-12-31 13:54:58 +0100 (Thu, 31 Dec 2015)
Build-Date:2015-12-31 12:57:00
Revision:9229
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9229 en) Windows 8.1 64-Bit
Memory Usage: 182 MB / 989 MB (59 MB allocated, but free)
Java version: 1.8.0_66, Oracle Corporation, Java HotSpot(TM) Client VM
Dataset consistency test: No problems found

Plugins:
- DirectUpload (31871)
- ImportImagePlugin (31772)
- OpeningHoursEditor (31772)
- alignways (31895)
- apache-commons (31895)
- buildings_tools (31895)
- editgpx (31772)
- ejml (31895)
- ext_tools (31772)
- fieldpapers (v0.4.0)
- geotools (31895)
- imagery_offset_db (31895)
- imageryadjust (31772)
- jts (31772)
- kendzi3d (1.0.189)
- kendzi3d-jogl (41)
- kendzi3d-resources (0.0.1)
- log4j (31895)
- merge-overlap (31772)
- osmarender (31772)
- photo_geotagging (31895)
- print (31895)
- reverter (31895)
- routing (31772)
- terracer (31895)
- turnrestrictions (31772)
- utilsplugin2 (31895)

Last errors/warnings:
- E: Failed to locate image 'vehicle/crossing_small.png'
- E: Failed to locate image 'vehicle/zebra_crossing.png'
- E: Failed to locate image 'vehicle/zebra_crossing.png'
- E: Failed to locate image 'vehicle/zebra_crossing.png'
- E: Failed to locate image 'vehicle/zebra_crossing.png'

Attachments (2)

ErrorUnderUploadofGPX.png (23.1 KB) - added by hjart 4 years ago.
GPX File Dialog upload error
Spor_2016-01-02_CykelTisetHede.gpx (10.2 KB) - added by hjart 4 years ago.
GPX file edited in JOSM-latest and attempted uploaded to OSM

Download all attachments as: .zip

Change History (13)

comment:1 Changed 4 years ago by simon04

Component: CorePlugin

This related to the plugin DirectUpload.

comment:2 Changed 4 years ago by simon04

Owner: changed from team to bcmoore@…
Status: newneedinfo

Are you trying to upload a GPX file containing only markers/waypoints?
If yes, this behaviour is intended. If no, please provide the GPX file.

comment:3 Changed 4 years ago by hjart

I have the same problem: When clicking [Upload] in the GPX upload dialog I get an "Upload error" GPX File Dialog upload error

In the console these lines appear:

org.openstreetmap.josm.gui.progress.ProgressException: Expected states are [INIT] but current state is IN_TASK
        at org.openstreetmap.josm.gui.progress.AbstractProgressMonitor.checkState(AbstractProgressMonitor.java:69)
        at org.openstreetmap.josm.gui.progress.AbstractProgressMonitor.beginTask(AbstractProgressMonitor.java:84)
        at org.openstreetmap.josm.tools.HttpClient.connect(HttpClient.java:97)
        at org.openstreetmap.josm.plugins.DirectUpload.UploadDataGui.upload(UploadDataGui.java:242)
        at org.openstreetmap.josm.plugins.DirectUpload.UploadDataGui.access$700(UploadDataGui.java:50)
        at org.openstreetmap.josm.plugins.DirectUpload.UploadDataGui$6.realRun(UploadDataGui.java:437)
        at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93)
        at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:161)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
        at java.lang.Thread.run(Thread.java:745)
Last edited 4 years ago by hjart (previous) (diff)

Changed 4 years ago by hjart

Attachment: ErrorUnderUploadofGPX.png added

GPX File Dialog upload error

Changed 4 years ago by hjart

GPX file edited in JOSM-latest and attempted uploaded to OSM

comment:4 in reply to:  3 Changed 4 years ago by simon04

Replying to hjart:

I have the same problem: When clicking [Upload] in the GPX upload dialog I get an "Upload error"

Thanks for reporting – this seems to be a different problem. And it should be fixed in [o31912:31914]. Would you please test again with the 31912 version of the plugin?

comment:5 Changed 4 years ago by simon04

Component: PluginPlugin directupload

comment:6 Changed 4 years ago by hjart

Works now. Thank you

comment:7 in reply to:  2 ; Changed 4 years ago by simon04

Thanks for testing.

To be done is the clarification from comment 2:

Are you trying to upload a GPX file containing only markers/waypoints?
If yes, this behaviour is intended. If no, please provide the GPX file.

comment:8 in reply to:  7 Changed 4 years ago by hjart

Replying to simon04:

Thanks for testing.

To be done is the clarification from comment 2:

Are you trying to upload a GPX file containing only markers/waypoints?
If yes, this behaviour is intended. If no, please provide the GPX file.

I'm not entirely sure what is meant, but I in fact did provide the GPX file? I used for testing.

comment:9 in reply to:  description ; Changed 4 years ago by simon04

Replying to hjart:

I'm not entirely sure what is meant, but I in fact did provide the GPX file? I used for testing.

The original error description

On clicking "Upload Trace" PC screen flashes and upload button greys out, no upload.

… indicates a different issue. This one need to be clarified, but its seems to be unrelated to yours.

comment:10 in reply to:  9 Changed 4 years ago by hjart

Replying to simon04:

The original error description

On clicking "Upload Trace" PC screen flashes and upload button greys out, no upload.

… indicates a different issue. This one need to be clarified, but its seems to be unrelated to yours.

Oh, I think it's entirely related. I didn't notice any flashing of "the screen", but otherwise my experience was the same. Please notice the grayed out button in the image of the dialog provided above.

comment:11 Changed 4 years ago by simon04

Resolution: fixed
Status: needinfoclosed

After – slowly – reading the text again, I agree. :)

@bcmoore: If the original issue wasn't resolved, feel free to reopen …

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain bcmoore@….
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.