Modify

Opened 4 years ago

Closed 4 years ago

#12244 closed defect (fixed)

Menu rework breaks shortcut preferences

Reported by: stoecker Owned by: team
Priority: normal Milestone: 15.12
Component: Core Version:
Keywords: regression menu shortcut Cc: simon04

Description (last modified by Don-vip)

The recent reworks of the menu handling break the shortcut preferences. All the menu entries have "menu: null" as name.


Build-Date:2015-12-28 19:14:46
Revision:9201
Is-Local-Build:true

Identification: JOSM/1.5 (9201 SVN en) Windows 7 64-Bit
Memory Usage: 688 MB / 2708 MB (176 MB allocated, but free)
Java version: 1.8.0_66, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Dfile.encoding=UTF-8]

Attachments (1)

menunull.PNG (39.3 KB) - added by Don-vip 4 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 in reply to:  description Changed 4 years ago by Don-vip

Replying to stoecker:

The recent reworks of the menu handling

Do you have something specific on your mind? I don't remember we changed anything in the menu handling recently.

comment:2 Changed 4 years ago by stoecker

There was something with trn() and tr() and argument changes for menus. Not in recent latest, but before.

comment:3 Changed 4 years ago by Don-vip

Description: modified (diff)
Keywords: menu shortcut added

Changed 4 years ago by Don-vip

Attachment: menunull.PNG added

comment:4 Changed 4 years ago by Don-vip

Description: modified (diff)

comment:5 Changed 4 years ago by Don-vip

Cc: simon04 added

OK looks like a regression from r8792.

comment:6 Changed 4 years ago by simon04

Resolution: fixed
Status: newclosed

In 9204/josm:

fix #12244 - Fix menu shortcut preferences

Regression from r8792.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.