Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#12187 closed defect (fixed)

Wrong icon for highway=turning_circle

Reported by: mdk Owned by: mdk
Priority: normal Milestone:
Component: External mappaint style Version: latest
Keywords: template_report Cc:

Description (last modified by mdk)

What steps will reproduce the problem?

  1. Draw a node with highway=turning_circle

What is the expected result?

A turning circle icon is drawn in edit map and in selection list.

What happens instead?

The dead end sign is drawn (same as noexit=yes)

Please provide any additional information below. Attach a screenshot if possible.

highway=turning_loop still shows the correct icon. Does highway=turning_circle now implicitly includes noexit=yes? But I think this is wrong. I saw turning circles in the middle of roads, not only at the end!

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2015-12-13 01:12:02 +0100 (Sun, 13 Dec 2015)
Build-Date:2015-12-13 02:33:51
Revision:9106
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9106 en) Linux Ubuntu 15.10
Memory Usage: 494 MB / 876 MB (292 MB allocated, but free)
Java version: 1.7.0_91, Oracle Corporation, OpenJDK Server VM
Java package: openjdk-7-jre:i386-7u91-2.6.3-0ubuntu0.15.10.1
VM arguments: [-Djosm.restart=true, -Djosm.home=/home/michael/.josm-latest, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
- ColumbusCSV (31772)
- FastDraw (31772)
- HouseNumberTaggingTool (31772)
- Mapillary (31802)
- OpeningHoursEditor (31772)
- RoadSigns (31772)
- SimplifyArea (31772)
- apache-commons (31772)
- apache-http (31772)
- buildings_tools (31772)
- contourmerge (1014)
- imagery-xml-bounds (31772)
- imagery_offset_db (31772)
- pbf (31772)
- poly (31772)
- public_transport (31772)
- reltoolbox (31772)
- reverter (31772)
- terracer (31772)
- turnrestrictions (31772)
- utilsplugin2 (31772)

Last errors/warnings:
- E: Failed to locate image 'maxspeed_icon.svg'
- W: Mappaint style "standard" (Maxspeed) icon "maxspeed_icon.svg" not found.

Attachments (0)

Change History (10)

comment:1 Changed 6 years ago by mdk

Description: modified (diff)

comment:2 Changed 6 years ago by Klumbumbus

Owner: changed from team to mdk
Status: newneedinfo

Please give us the list of mappaint styles you are using.

Does highway=turning_circle now implicitly includes noexit=yes?

No. (Even if both is tagged, the turning_circle icon is shown.)

Last edited 6 years ago by Klumbumbus (previous) (diff)

comment:3 Changed 6 years ago by mdk

You are right! I recently added "traffic_signs_" (https://josm.openstreetmap.de/josmfile?page=Styles/Traffic_signs&zip=1)
When I switch it of, the correct icon is shown again!

comment:4 Changed 6 years ago by Klumbumbus

Component: CoreExternal mappaint style
Resolution: fixed
Status: needinfoclosed

comment:5 Changed 6 years ago by Klumbumbus

Last errors/warnings:
- E: Failed to locate image 'maxspeed_icon.svg'
- W: Mappaint style "standard" (Maxspeed) icon "maxspeed_icon.svg" not found.

can you please check the URL and version of your maxspeed mappaint style?

mappaint style dialog -> rightclick on Maxspeed -> info -> URL:

and in "source" tab version: "...";

comment:6 Changed 6 years ago by mdk

URL: https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&style
I didn't find the version. I looked into View -> Map paint styles -> Map paint preferences. In the preference window I use edit of the active style to get the URL, but I didn't see any "source".
When I right-click in the menu (View -> Map paint styles -> Maxspeed) just the selection toggles (like with left mouse button). This is a bad behaviour of Ubuntu Unity menu handling. I get the same problem in Firefox menus :-/
Is there a possibility to add the source view also to the Map paint preferences?

But I notice that the Style was not detected in the style list (normally a checkmark Icon is shown for matching styles). Now I add the actual style
new URL: https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1

Also "Lane and road attributes" style has no checkmark:
old URL: http://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
new URL: https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1

Wouldn't it be useful to have an update automatims if the URL of a style change?

comment:7 Changed 6 years ago by mdk

Addition: I looked into the cache and found the mirror_https___josm.openstreetmap.de_josmfile_page_Styles_Maxspeed_style file:
version: "2.7.33_2015-11-05";

comment:8 Changed 6 years ago by mdk

BTW. in the past I got a similar problem with imagery preferences when the URL has changed.

comment:9 in reply to:  6 Changed 6 years ago by Klumbumbus

Replying to mdk:

When I right-click in the menu (View -> Map paint styles -> Maxspeed)

I meant the mappaint style dialog

comment:10 Changed 6 years ago by Klumbumbus

See new ticket #12189

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain mdk.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.