Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12168 closed defect (fixed)

Exception when using WMTS of www.ngi.be

Reported by: A_Pirard Owned by: team
Priority: normal Milestone: 15.12
Component: Core imagery Version: latest
Keywords: wmts Cc:

Description

(I am awfully sorry ;-))
They opened that new server in Brussels.

9060: java.xml.transform exception
9064: no parsing exception but another exception after selecting the layer.

I think that you will reproduce this without more info.
I think that this map deserves the investigation. They support 3857!
Yes I am, really (sorry).
BTW, is there a way to configure automatic layer selection?

Attachments (0)

Change History (5)

comment:1 Changed 4 years ago by wiktorn

Resolution: fixed
Status: newclosed

In 9095/josm:

Fix 12168.

  • added testcase for bug #12168. I removed all but one layers from the GetCapabilities document to avoid showing dialog
  • added case, that when ResourceURL is provided, but no OperationsMetadata information are present - to assume REST transfer mode
  • added ignore-case paramter for {style} replacement, as some servers use lowercase name, and some capitalized versions

Closes #12168

comment:2 Changed 4 years ago by wiktorn

And BTW: looks like for the second layer (overlay) the tiles are missing on the server.

comment:3 Changed 4 years ago by A_Pirard

Overlay layer missing: could it be an EPSG issue? (I can't see yet)
Their viewer works with 3812, see Page Info>Media.
Their product page. Their data page.
I'll report that to them as soon as I can snap a tile image.

Last edited 4 years ago by A_Pirard (previous) (diff)

comment:4 Changed 4 years ago by wiktorn

Their page works with 3812 projection. If you set the same projection in JOSM, you will get the overlay tiles (though they are available only at limited levels of zoom -> high zooom levels).

comment:5 Changed 4 years ago by Don-vip

Component: CoreCore imagery
Milestone: 15.12
Summary: WMTS http://www.ngi.be/cartoweb/1.0.0/WMTSCapabilities.xmlException when using WMTS of www.ngi.be

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.