Modify

Opened 5 years ago

Closed 5 years ago

#12139 closed defect (duplicate)

JOSM shows wrong field when clicking into a field to edit a tag

Reported by: GerdP Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc: GerdP

Description

(see also http://gis.19327.n5.nabble.com/Is-JOSM-responsible-for-tags-like-layer-Main-Street-tt5860983.html)

During the last days I've corrected many tags like
layer=Carrer de Rocabertí

where it is quite obvious that the mapper wanted to use
a different tag key.
There are still many more cases,
e.g.
layer="Dale Farm Road"
surface="Place de la Liberté"

I was sure that these errors were produced by the mapper by
clicking into the wrong field before editing, but yesterday I found
that JOSM really showed the wrong field. I was able to reproduce the
behaviour:
Click on name and the lanes field are shown, click on lanes and the name
fields are shown. I did that several times, made sure that I really hit the right
field, so the error is there.
It happened after an update of JOSM to version 9060, so I thought I should
report this ASAP. I thought best is to report everything I did, so I stopped JOSM,
started it again and tried to reproduce the problem, but it was gone and did not
appear again since then.

I hope the programmers can find the cause of the problem, if any of you
experiences the same behaviour, please report it.

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by Klumbumbus

Resolution: duplicate
Status: newclosed

Closed as duplicate of #12022.
Can you please attach your statusreport to #12022?

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.