Modify

Opened 6 years ago

Closed 6 years ago

#12080 closed defect (duplicate)

ImportImagePlugin - exception while opening geotiff's

Reported by: maps2xplane@… Owned by: team
Priority: normal Milestone:
Component: Plugin importimage Version:
Keywords: template_report geotools Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. open josm (current version, plug-ins up-to-date, see below)
  2. try to open geotiff's (.twf exists besides the .tif)
  3. results in an exception (see below)

happens via the menu-import-dialog
and via drag&drop

What is the expected result?

geotiff's should be loaded as new layers

What happens instead?

INFO: Open 2 files
org.geotools.data.DataSourceException: it/geosolutions/imageio/stream/input/FileImageInputStreamExtImpl
	at org.geotools.gce.geotiff.GeoTiffReader.<init>(GeoTiffReader.java:262)
	at org.openstreetmap.josm.plugins.ImportImagePlugin.PluginOperations.readGeoTiff(PluginOperations.java:347)
	at org.openstreetmap.josm.plugins.ImportImagePlugin.PluginOperations.createGridFromFile(PluginOperations.java:120)
	at org.openstreetmap.josm.plugins.ImportImagePlugin.ImageLayer.createImage(ImageLayer.java:92)
	at org.openstreetmap.josm.plugins.ImportImagePlugin.ImageLayer.<init>(ImageLayer.java:76)
	at org.openstreetmap.josm.plugins.ImportImagePlugin.ImportImageFileImporter.importData(ImportImageFileImporter.java:48)
	at org.openstreetmap.josm.io.FileImporter.importDataHandleExceptions(FileImporter.java:126)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.importData(OpenFileAction.java:327)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.realRun(OpenFileAction.java:292)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:161)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)
Caused by: org.geotools.data.DataSourceException: it/geosolutions/imageio/stream/input/FileImageInputStreamExtImpl
	at org.geotools.gce.geotiff.GeoTiffReader.getHRInfo(GeoTiffReader.java:487)
	at org.geotools.gce.geotiff.GeoTiffReader.<init>(GeoTiffReader.java:249)
	... 15 more
Caused by: java.lang.NoClassDefFoundError: it/geosolutions/imageio/stream/input/FileImageInputStreamExtImpl
	at it.geosolutions.imageioimpl.plugins.tiff.TIFFImageReader.setInput(TIFFImageReader.java:405)
	at javax.imageio.ImageReader.setInput(ImageReader.java:380)
	at org.geotools.gce.geotiff.GeoTiffReader.getHRInfo(GeoTiffReader.java:301)
	... 16 more
Caused by: java.lang.ClassNotFoundException: it.geosolutions.imageio.stream.input.FileImageInputStreamExtImpl
	at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	... 19 more
org.geotools.data.DataSourceException: it/geosolutions/imageio/stream/input/FileImageInputStreamExtImpl
	at org.geotools.gce.geotiff.GeoTiffReader.<init>(GeoTiffReader.java:262)
	at org.openstreetmap.josm.plugins.ImportImagePlugin.PluginOperations.readGeoTiff(PluginOperations.java:347)
	at org.openstreetmap.josm.plugins.ImportImagePlugin.PluginOperations.createGridFromFile(PluginOperations.java:120)
	at org.openstreetmap.josm.plugins.ImportImagePlugin.ImageLayer.createImage(ImageLayer.java:124)
	at org.openstreetmap.josm.plugins.ImportImagePlugin.ImageLayer.<init>(ImageLayer.java:76)
	at org.openstreetmap.josm.plugins.ImportImagePlugin.ImportImageFileImporter.importData(ImportImageFileImporter.java:48)
	at org.openstreetmap.josm.io.FileImporter.importDataHandleExceptions(FileImporter.java:126)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.importData(OpenFileAction.java:327)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.realRun(OpenFileAction.java:292)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:161)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)
Caused by: org.geotools.data.DataSourceException: it/geosolutions/imageio/stream/input/FileImageInputStreamExtImpl
	at org.geotools.gce.geotiff.GeoTiffReader.getHRInfo(GeoTiffReader.java:487)
	at org.geotools.gce.geotiff.GeoTiffReader.<init>(GeoTiffReader.java:249)
	... 15 more
Caused by: java.lang.NoClassDefFoundError: it/geosolutions/imageio/stream/input/FileImageInputStreamExtImpl
	at it.geosolutions.imageioimpl.plugins.tiff.TIFFImageReader.setInput(TIFFImageReader.java:405)
	at javax.imageio.ImageReader.setInput(ImageReader.java:380)
	at org.geotools.gce.geotiff.GeoTiffReader.getHRInfo(GeoTiffReader.java:301)
	... 16 more
22:50:26.417 [main-worker-0] ERROR org.openstreetmap.josm.plugins.ImportImagePlugin.ImageLayer - Error while creating GridCoverage:
java.lang.NullPointerException
	at org.openstreetmap.josm.plugins.ImportImagePlugin.PluginOperations.createGridFromFile(PluginOperations.java:158) ~[ImportImagePlugin.jar:?]
	at org.openstreetmap.josm.plugins.ImportImagePlugin.ImageLayer.createImage(ImageLayer.java:124) [ImportImagePlugin.jar:?]
	at org.openstreetmap.josm.plugins.ImportImagePlugin.ImageLayer.<init>(ImageLayer.java:76) [ImportImagePlugin.jar:?]
	at org.openstreetmap.josm.plugins.ImportImagePlugin.ImportImageFileImporter.importData(ImportImageFileImporter.java:48) [ImportImagePlugin.jar:?]
	at org.openstreetmap.josm.io.FileImporter.importDataHandleExceptions(FileImporter.java:126) [josm-tested.jar:?]
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.importData(OpenFileAction.java:327) [josm-tested.jar:?]
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.realRun(OpenFileAction.java:292) [josm-tested.jar:?]
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93) [josm-tested.jar:?]
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:161) [josm-tested.jar:?]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_45]
	at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_45]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [?:1.8.0_45]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [?:1.8.0_45]
	at java.lang.Thread.run(Thread.java:745) [?:1.8.0_45]
22:50:26.422 [main-worker-0] ERROR org.openstreetmap.josm.plugins.ImportImagePlugin.LoadImageAction - Error while creating image layer: 
java.lang.NullPointerException
org.geotools.data.DataSourceException: it/geosolutions/imageio/stream/input/FileImageInputStreamExtImpl
	at org.geotools.gce.geotiff.GeoTiffReader.<init>(GeoTiffReader.java:262)
	at org.openstreetmap.josm.plugins.ImportImagePlugin.PluginOperations.readGeoTiff(PluginOperations.java:347)
	at org.openstreetmap.josm.plugins.ImportImagePlugin.PluginOperations.createGridFromFile(PluginOperations.java:120)
	at org.openstreetmap.josm.plugins.ImportImagePlugin.ImageLayer.createImage(ImageLayer.java:92)
	at org.openstreetmap.josm.plugins.ImportImagePlugin.ImageLayer.<init>(ImageLayer.java:76)
	at org.openstreetmap.josm.plugins.ImportImagePlugin.ImportImageFileImporter.importData(ImportImageFileImporter.java:48)
	at org.openstreetmap.josm.io.FileImporter.importDataHandleExceptions(FileImporter.java:126)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.importData(OpenFileAction.java:327)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.realRun(OpenFileAction.java:292)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:161)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)
Caused by: org.geotools.data.DataSourceException: it/geosolutions/imageio/stream/input/FileImageInputStreamExtImpl
	at org.geotools.gce.geotiff.GeoTiffReader.getHRInfo(GeoTiffReader.java:487)
	at org.geotools.gce.geotiff.GeoTiffReader.<init>(GeoTiffReader.java:249)
	... 15 more
Caused by: java.lang.NoClassDefFoundError: it/geosolutions/imageio/stream/input/FileImageInputStreamExtImpl
	at it.geosolutions.imageioimpl.plugins.tiff.TIFFImageReader.setInput(TIFFImageReader.java:405)
	at javax.imageio.ImageReader.setInput(ImageReader.java:380)
	at org.geotools.gce.geotiff.GeoTiffReader.getHRInfo(GeoTiffReader.java:301)
	... 16 more
org.geotools.data.DataSourceException: it/geosolutions/imageio/stream/input/FileImageInputStreamExtImpl
	at org.geotools.gce.geotiff.GeoTiffReader.<init>(GeoTiffReader.java:262)
	at org.openstreetmap.josm.plugins.ImportImagePlugin.PluginOperations.readGeoTiff(PluginOperations.java:347)
	at org.openstreetmap.josm.plugins.ImportImagePlugin.PluginOperations.createGridFromFile(PluginOperations.java:120)
	at org.openstreetmap.josm.plugins.ImportImagePlugin.ImageLayer.createImage(ImageLayer.java:124)
	at org.openstreetmap.josm.plugins.ImportImagePlugin.ImageLayer.<init>(ImageLayer.java:76)
	at org.openstreetmap.josm.plugins.ImportImagePlugin.ImportImageFileImporter.importData(ImportImageFileImporter.java:48)
	at org.openstreetmap.josm.io.FileImporter.importDataHandleExceptions(FileImporter.java:126)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.importData(OpenFileAction.java:327)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.realRun(OpenFileAction.java:292)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:161)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)
Caused by: org.geotools.data.DataSourceException: it/geosolutions/imageio/stream/input/FileImageInputStreamExtImpl
	at org.geotools.gce.geotiff.GeoTiffReader.getHRInfo(GeoTiffReader.java:487)
	at org.geotools.gce.geotiff.GeoTiffReader.<init>(GeoTiffReader.java:249)
	... 15 more
Caused by: java.lang.NoClassDefFoundError: it/geosolutions/imageio/stream/input/FileImageInputStreamExtImpl
	at it.geosolutions.imageioimpl.plugins.tiff.TIFFImageReader.setInput(TIFFImageReader.java:405)
	at javax.imageio.ImageReader.setInput(ImageReader.java:380)
	at org.geotools.gce.geotiff.GeoTiffReader.getHRInfo(GeoTiffReader.java:301)
	... 16 more
22:50:28.644 [main-worker-0] ERROR org.openstreetmap.josm.plugins.ImportImagePlugin.ImageLayer - Error while creating GridCoverage:
java.lang.NullPointerException
	at org.openstreetmap.josm.plugins.ImportImagePlugin.PluginOperations.createGridFromFile(PluginOperations.java:158) ~[ImportImagePlugin.jar:?]
	at org.openstreetmap.josm.plugins.ImportImagePlugin.ImageLayer.createImage(ImageLayer.java:124) [ImportImagePlugin.jar:?]
	at org.openstreetmap.josm.plugins.ImportImagePlugin.ImageLayer.<init>(ImageLayer.java:76) [ImportImagePlugin.jar:?]
	at org.openstreetmap.josm.plugins.ImportImagePlugin.ImportImageFileImporter.importData(ImportImageFileImporter.java:48) [ImportImagePlugin.jar:?]
	at org.openstreetmap.josm.io.FileImporter.importDataHandleExceptions(FileImporter.java:126) [josm-tested.jar:?]
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.importData(OpenFileAction.java:327) [josm-tested.jar:?]
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.realRun(OpenFileAction.java:292) [josm-tested.jar:?]
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93) [josm-tested.jar:?]
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:161) [josm-tested.jar:?]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_45]
	at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_45]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [?:1.8.0_45]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [?:1.8.0_45]
	at java.lang.Thread.run(Thread.java:745) [?:1.8.0_45]
22:50:28.645 [main-worker-0] ERROR org.openstreetmap.josm.plugins.ImportImagePlugin.LoadImageAction - Error while creating image layer: 
java.lang.NullPointerException

Please provide any additional information below. Attach a screenshot if possible.

Revision: 8969
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: Don-vip
Last Changed Date: 2015-10-29 22:15:23 +0100 (Thu, 29 Oct 2015)
Build-Date: 2015-10-30 02:32:24
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8969

Identification: JOSM/1.5 (8969 de) Mac OS X 10.11.1
Memory Usage: 718 MB / 2731 MB (572 MB allocated, but free)
Java version: 1.8.0_45, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- ImportImagePlugin (31603)
- ShapeTools (1000)
- apache-commons (31718)
- geotools (31603)
- jts (31603)
- log4j (31603)
- opendata (31695)
- undelete (31603)
- utilsplugin2 (31694)

Attachments (4)

brabant-1.tiff (3.2 MB) - added by anonymous 6 years ago.
brabant-1.tfw (107 bytes) - added by anonymous 6 years ago.
brabant-2.tiff (3.2 MB) - added by anonymous 6 years ago.
brabant-2.tfw (107 bytes) - added by anonymous 6 years ago.

Change History (8)

Changed 6 years ago by anonymous

Attachment: brabant-1.tiff added

Changed 6 years ago by anonymous

Attachment: brabant-1.tfw added

Changed 6 years ago by anonymous

Attachment: brabant-2.tiff added

Changed 6 years ago by anonymous

Attachment: brabant-2.tfw added

comment:1 Changed 6 years ago by maps2xplane@…

Component: CorePlugin importimage

comment:2 Changed 6 years ago by morgy.wahl@…

I have the same problem; a quick search of all the plugin .jar files (including geotools) doesn't turn anything with FileImageInputStreamExtImpl in the name.

I notice the ~/.josm/plugins/ImportImagePlugin/lib/ directory is empty. Perhaps something's supposed to be there?

comment:3 Changed 6 years ago by Don-vip

Description: modified (diff)
Keywords: geotools added

comment:4 Changed 6 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #12097.
Fixed in the course of #12097

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.