Modify

Opened 3 years ago

#12067 new defect

Problems moving items the Layers window/panel

Reported by: metalfreak Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Run josm or josm-latest with or without the --skip-plugins option
  2. download an area of the map and open some gpx tracks (the order you open things in doesn't matter)
  3. Try to drag Data Layer 1 (or any layer) to the bottom of the Layers list instead of being able to move it you will just select the layers below it
  4. Then try selecting all of the layers below Data Layer 1
  5. Click the up arrow and instead of moving the selected items up above Data Layer 1 the selection highlighting is moved up so that now Data Layer 1 is selected/highlighted but the bottom layer isn't

What is the expected result?

That I will be able either drag the layer I've selected up or down on the layers list
or that I will be able to move all the layers I've selected up or down by clicking on the arrows

What happens instead?

The select highlighting moves

Please provide any additional information below. Attach a screenshot if possible.

you still can select Data Layer 1 by itself and then click on the up or down arrow to move it up or down but if you have 50 other layers it's going to take a few minutes to movie it to the bottom of the layers list which is needed if the data layers is covering up something you need to be able to see when you are editing the data layer

I tried the fallowing but it didn't help
Removing all of the plugins
Resetting the settings from Advanced Preferences
Completely uninstalling josm-latest so that all the settings were removed by running sudo apt-get purge josm-latest
Then reinstalling josm-latest
I tried all of those things after I started writing this so you will still see the list of plugins I had installed when I started even though I had used the command josm-latest --skip-plugins to test if the plugins were the problem when I sent in the bug report. So I'm about as sure as I can be that I didn't make a mistake on my end that is causing this problem. However, I'm willing to try something if I'm wrong about that.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-11-05 02:34:01
Last Changed Author: Don-vip
Revision: 8993
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-11-05 03:05:19 +0100 (Thu, 05 Nov 2015)
Last Changed Rev: 8993

Identification: JOSM/1.5 (8993 en) Linux Ubuntu 14.04.3 LTS
Memory Usage: 345 MB / 1749 MB (108 MB allocated, but free)
Java version: 1.7.0_85, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u85-2.6.1-5ubuntu0.14.04.1
VM arguments: [-Djosm.restart=true, -Djosm.home=/home/daniel/.josm-latest, -Djava.net.useSystemProxies=true]
Program arguments: [--skip-plugins]
Dataset consistency test: No problems found

Plugins:
- ColorPlugin
- ElevationProfile
- FixAddresses
- HouseNumberTaggingTool
- InfoMode
- Mapillary
- OpeningHoursEditor
- apache-commons
- apache-http
- buildings_tools
- colorscheme
- contourmerge
- dataimport
- download_along
- editgpx
- geotools
- gpsblam
- gpxfilter
- graphview
- imagery-xml-bounds
- jts
- log4j
- matsim
- namemanager
- pbf
- photo_geotagging
- photoadjust
- reltoolbox
- reverter
- tag2link
- terracer
- trafficFlowDirection
- turnrestrictions
- undelete
- utilsplugin2
- waydownloader
- waypoint_search

Last errors/warnings:
- W: Failed to parse Mappaint styles from '/media/daniel/1c871952-bad9-4dcd-ab7e-9d92e543204b/home/daniel/Documents/OpenStreetMap/Test_roads_NoName.mapcss'. Error was: Encountered " "}" "} "" at line 28, column 1.
- E: org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.ParseException: Encountered " "}" "} "" at line 28, column 1.
- W: Initializing map style /media/daniel/1c871952-bad9-4dcd-ab7e-9d92e543204b/home/daniel/Documents/OpenStreetMap/Test_roads_NoName.mapcss completed in 5 ms (2 errors)
- E: Failed to locate image 'error_small.png'
- W: Mappaint style "standard" (TigerNotReviewed) icon "error_small.png" not found.

Attachments (1)

Screenshot_josm-latest_layers.png (358.2 KB) - added by metalfreak 3 years ago.
Screen shot of what happens when I select all of the layers below Data Layer 1 and click the up arrow

Download all attachments as: .zip

Change History (1)

Changed 3 years ago by metalfreak

Screen shot of what happens when I select all of the layers below Data Layer 1 and click the up arrow

Modify Ticket

Change Properties
Set your email in Preferences
Action
as new The owner will remain team.
as The resolution will be set.
to The owner will be changed from team to the specified user.
The owner will change to metalfreak
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket
The owner will be changed from team to anonymous.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.