Modify

Opened 4 years ago

Closed 4 years ago

#12054 closed defect (fixed)

IllegalArgumentException in JCS log handler

Reported by: Don-vip Owned by: team
Priority: normal Milestone: 15.11
Component: Core imagery Version:
Keywords: template_report jcs cache log Cc:

Description

Exception happened while zooming quite fast with '+' key.
Only one data layer + one imagery (OSM Mapnik) with opacity 50%.

Revision: 8983
Is-Local-Build: true
Build-Date: 2015-11-03 01:16:00

Identification: JOSM/1.5 (8983 SVN en) Windows 7 64-Bit
Memory Usage: 1039 MB / 2708 MB (528 MB allocated, but free)
Java version: 1.8.0_66, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Dfile.encoding=UTF-8]
Dataset consistency test: No problems found

Plugins:
- apache-commons (31718)
- geotools (31603)
- imagery-xml-bounds (31694)
- jts (31603)
- opendata (31695)
- utilsplugin2 (31694)

Last errors/warnings:
- E: Region [TMS] IO Exception, Problem reading object from file
- E: java.lang.IllegalArgumentException: cant parse argument number: switch:a
- E: Region [TMS] IO Exception, Problem reading object from file
- E: java.lang.IllegalArgumentException: cant parse argument number: switch:a
- E: java.lang.IllegalArgumentException: can't parse argument number: switch:a. Cause: java.lang.NumberFormatException: For input string: "switch:a"

java.lang.IllegalArgumentException: can't parse argument number: switch:a
	at java.text.MessageFormat.makeFormat(MessageFormat.java:1429)
	at java.text.MessageFormat.applyPattern(MessageFormat.java:479)
	at java.text.MessageFormat.<init>(MessageFormat.java:362)
	at java.text.MessageFormat.format(MessageFormat.java:840)
	at org.openstreetmap.josm.data.cache.JCSCacheManager$1.publish(JCSCacheManager.java:80)
	at java.util.logging.Logger.log(Logger.java:738)
	at java.util.logging.Logger.doLog(Logger.java:765)
	at java.util.logging.Logger.logp(Logger.java:1041)
	at org.apache.commons.logging.impl.Jdk14Logger.log(Jdk14Logger.java:89)
	at org.apache.commons.logging.impl.Jdk14Logger.error(Jdk14Logger.java:135)
	at org.apache.commons.jcs.auxiliary.disk.indexed.IndexedDiskCache.processUpdate(IndexedDiskCache.java:602)
	at org.apache.commons.jcs.auxiliary.AbstractAuxiliaryCacheEventLogging.updateWithEventLogging(AbstractAuxiliaryCacheEventLogging.java:65)
	at org.apache.commons.jcs.auxiliary.disk.AbstractDiskCache.doUpdate(AbstractDiskCache.java:804)
	at org.apache.commons.jcs.auxiliary.disk.AbstractDiskCache$MyCacheListener.handlePut(AbstractDiskCache.java:662)
	at org.apache.commons.jcs.engine.AbstractCacheEventQueue$PutEvent.doRun(AbstractCacheEventQueue.java:350)
	at org.apache.commons.jcs.engine.AbstractCacheEventQueue$AbstractCacheEvent.run(AbstractCacheEventQueue.java:269)
	at org.apache.commons.jcs.engine.CacheEventQueue$QProcessor.run(CacheEventQueue.java:304)
Caused by: java.lang.NumberFormatException: For input string: "switch:a"
	at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
	at java.lang.Integer.parseInt(Integer.java:580)
	at java.lang.Integer.parseInt(Integer.java:615)
	at java.text.MessageFormat.makeFormat(MessageFormat.java:1427)
	... 16 more

Console output (extract)

WARNING: Interrupted while waiting for another event to come in before we die.
WARNING: 
 The file is corrupt: 
 Record [DED:  pos = 82461032 len = 10307] does not match data length on disk (-387922471)
ERROR: Region [TMS] IO Exception, Problem reading object from file
ERROR: java.lang.IllegalArgumentException: cant parse argument number: switch:a
WARNING: 
 The file is corrupt: 
 Record [DED:  pos = 81344711 len = 15905] does not match data length on disk (-639448869)
ERROR: Region [TMS] IO Exception, Problem reading object from file
ERROR: java.lang.IllegalArgumentException: cant parse argument number: switch:a
WARNING: 
 The file is corrupt: 
 Record [DED:  pos = 81316715 len = 10744] does not match data length on disk (-522328090)
ERROR: Region [TMS] IO Exception, Problem reading object from file
ERROR: java.lang.IllegalArgumentException: cant parse argument number: switch:a
WARNING: 
 The file is corrupt: 
 Record [DED:  pos = 96723288 len = 9442] does not match data length on disk (1667789423)
ERROR: Region [TMS] IO Exception, Problem reading object from file
ERROR: java.lang.IllegalArgumentException: cant parse argument number: switch:a
WARNING: 
 The file is corrupt: 
 Record [DED:  pos = 82270956 len = 15388] does not match data length on disk (-522393883)
ERROR: Region [TMS] IO Exception, Problem reading object from file
ERROR: java.lang.IllegalArgumentException: cant parse argument number: switch:a
WARNING: 
 The file is corrupt: 
 Record [DED:  pos = 82435130 len = 3566] does not match data length on disk (64519642)
ERROR: Region [TMS] IO Exception, Problem reading object from file
ERROR: java.lang.IllegalArgumentException: cant parse argument number: switch:a
WARNING: 
 The file is corrupt: 
 Record [DED:  pos = 82248104 len = 8938] does not match data length on disk (-505551648)
ERROR: Region [TMS] IO Exception, Problem reading object from file
ERROR: java.lang.IllegalArgumentException: cant parse argument number: switch:a
WARNING: 
 The file is corrupt: 
 Record [DED:  pos = 81327463 len = 6679] does not match data length on disk (-235538700)
ERROR: Region [TMS] IO Exception, Problem reading object from file
ERROR: java.lang.IllegalArgumentException: cant parse argument number: switch:a
INFO: GET https://c.tile.openstreetmap.org/3/3/3.png -> 200
INFO: GET https://b.tile.openstreetmap.org/3/4/4.png -> 200
INFO: GET https://c.tile.openstreetmap.org/3/2/2.png -> 200
INFO: GET https://c.tile.openstreetmap.org/3/2/4.png -> 200
INFO: GET https://a.tile.openstreetmap.org/3/2/3.png -> 200
INFO: GET https://a.tile.openstreetmap.org/3/3/2.png -> 200
INFO: GET https://c.tile.openstreetmap.org/3/4/2.png -> 200
INFO: GET https://c.tile.openstreetmap.org/3/4/3.png -> 200
INFO: GET https://c.tile.openstreetmap.org/3/3/4.png -> 200
WARNING: 
 The file is corrupt: 
 Record [DED:  pos = 82263649 len = 7303] does not match data length on disk (-489168415)
ERROR: Region [TMS] IO Exception, Problem reading object from file
ERROR: java.lang.IllegalArgumentException: cant parse argument number: switch:a
WARNING: 
 The file is corrupt: 
 Record [DED:  pos = 133598058 len = 2267] does not match data length on disk (-908270644)
ERROR: Region [TMS] IO Exception, Problem reading object from file
ERROR: java.lang.IllegalArgumentException: cant parse argument number: switch:a
WARNING: 
 The file is corrupt: 
 Record [DED:  pos = 81360620 len = 5338] does not match data length on disk (-826599918)
ERROR: Region [TMS] IO Exception, Problem reading object from file
ERROR: java.lang.IllegalArgumentException: cant parse argument number: switch:a
INFO: GET https://a.tile.openstreetmap.org/3/1/3.png -> 200
INFO: GET https://c.tile.openstreetmap.org/3/1/4.png -> 200
INFO: GET https://b.tile.openstreetmap.org/3/1/2.png -> 200
WARNING: 
 The file is corrupt: 
 Record [DED:  pos = 104179451 len = 10156] does not match data length on disk (529401812)
ERROR: Region [TMS] IO Exception, Problem reading object from file
ERROR: java.lang.IllegalArgumentException: cant parse argument number: switch:a
WARNING: Interrupted while waiting for another event to come in before we die.
INFO: GET https://a.tile.openstreetmap.org/4/5/7.png -> 200
WARNING: 
 The file is corrupt: 
 Record [DED:  pos = 101789916 len = 12124] does not match data length on disk (-795885403)
ERROR: Region [TMS] IO Exception, Problem reading object from file
ERROR: java.lang.IllegalArgumentException: cant parse argument number: switch:a
WARNING: 
 The file is corrupt: 
 Record [DED:  pos = 102359202 len = 2320] does not match data length on disk (1852912636)
ERROR: Region [TMS] IO Exception, Problem reading object from file
ERROR: java.lang.IllegalArgumentException: cant parse argument number: switch:a
INFO: GET https://b.tile.openstreetmap.org/4/3/8.png -> 200
INFO: GET https://c.tile.openstreetmap.org/4/4/7.png -> 200
INFO: GET https://a.tile.openstreetmap.org/4/3/6.png -> 200
INFO: GET https://a.tile.openstreetmap.org/4/4/6.png -> 200
INFO: GET https://c.tile.openstreetmap.org/4/4/8.png -> 200
INFO: GET https://b.tile.openstreetmap.org/4/3/7.png -> 200
INFO: GET https://b.tile.openstreetmap.org/4/5/6.png -> 200
INFO: GET https://c.tile.openstreetmap.org/4/5/8.png -> 200
WARNING: 
 The file is corrupt: 
 Record [DED:  pos = 168950818 len = 7711] does not match data length on disk (499363737)
ERROR: Region [TMS] IO Exception, Problem reading object from file
ERROR: java.lang.IllegalArgumentException: cant parse argument number: switch:a
WARNING: Interrupted while waiting for another event to come in before we die.
WARNING: 
 The file is corrupt: 
 Record [DED:  pos = 103285806 len = 8123] does not match data length on disk (1918987892)
ERROR: Region [TMS] IO Exception, Problem reading object from file
ERROR: java.lang.IllegalArgumentException: cant parse argument number: switch:a
WARNING: 
 The file is corrupt: 
 Record [DED:  pos = 161406677 len = 7446] does not match data length on disk (819138120)
ERROR: Region [TMS] IO Exception, Problem reading object from file
ERROR: java.lang.IllegalArgumentException: cant parse argument number: switch:a
WARNING: 
 The file is corrupt: 
 Record [DED:  pos = 133608687 len = 2075] does not match data length on disk (2065532460)
ERROR: Region [TMS] IO Exception, Problem reading object from file
ERROR: java.lang.IllegalArgumentException: cant parse argument number: switch:a
WARNING: 
 The file is corrupt: 
 Record [DED:  pos = 180803492 len = 2075] does not match data length on disk (55594068)
ERROR: Region [TMS] IO Exception, Problem reading object from file
ERROR: java.lang.IllegalArgumentException: cant parse argument number: switch:a
WARNING: 
 The file is corrupt: 
 Record [DED:  pos = 168936507 len = 14307] does not match data length on disk (540186800)
ERROR: Region [TMS] IO Exception, Problem reading object from file
ERROR: java.lang.IllegalArgumentException: cant parse argument number: switch:a
INFO: GET https://a.tile.openstreetmap.org/5/10/14.png -> 200
INFO: GET https://c.tile.openstreetmap.org/5/8/15.png -> 200
WARNING: 
 The file is corrupt: 
 Record [DED:  pos = 140194818 len = 2075] does not match data length on disk (87848674)
ERROR: Region [TMS] IO Exception, Problem reading object from file
ERROR: java.lang.IllegalArgumentException: cant parse argument number: switch:a
INFO: GET https://c.tile.openstreetmap.org/5/11/13.png -> 200
INFO: GET https://a.tile.openstreetmap.org/5/11/15.png -> 200
INFO: GET https://b.tile.openstreetmap.org/5/8/14.png -> 200
INFO: GET https://c.tile.openstreetmap.org/5/10/15.png -> 200
INFO: GET https://a.tile.openstreetmap.org/5/10/13.png -> 200
INFO: GET https://c.tile.openstreetmap.org/5/9/14.png -> 200
INFO: GET https://a.tile.openstreetmap.org/5/9/13.png -> 200
INFO: GET https://a.tile.openstreetmap.org/5/11/14.png -> 200
INFO: GET https://a.tile.openstreetmap.org/5/8/13.png -> 200
INFO: GET https://a.tile.openstreetmap.org/5/9/15.png -> 200
WARNING: 
 The file is corrupt: 
 Record [DED:  pos = 180246644 len = 5118] does not match data length on disk (-2121885801)
ERROR: Region [TMS] IO Exception, Problem reading object from file
ERROR: java.lang.IllegalArgumentException: cant parse argument number: switch:a
WARNING: Interrupted while waiting for another event to come in before we die.
INFO: GET https://b.tile.openstreetmap.org/6/20/29.png -> 200
INFO: GET https://c.tile.openstreetmap.org/6/19/27.png -> 200
WARNING: 
 The file is corrupt: 
 Record [DED:  pos = 165291871 len = 17762] does not match data length on disk (-1777742345)
ERROR: Region [TMS] IO Exception, Problem reading object from file
ERROR: java.lang.IllegalArgumentException: cant parse argument number: switch:a
INFO: GET https://b.tile.openstreetmap.org/6/18/27.png -> 200
WARNING: 
 The file is corrupt: 
 Record [DED:  pos = 165309637 len = 13581] does not match data length on disk (-1515620901)
ERROR: Region [TMS] IO Exception, Problem reading object from file
ERROR: java.lang.IllegalArgumentException: cant parse argument number: switch:a
ERROR: java.lang.IllegalArgumentException: can't parse argument number: switch:a. Cause: java.lang.NumberFormatException: For input string: "switch:a"
java.lang.IllegalArgumentException: can't parse argument number: switch:a
	at java.text.MessageFormat.makeFormat(MessageFormat.java:1429)
	at java.text.MessageFormat.applyPattern(MessageFormat.java:479)
	at java.text.MessageFormat.<init>(MessageFormat.java:362)
	at java.text.MessageFormat.format(MessageFormat.java:840)
	at org.openstreetmap.josm.data.cache.JCSCacheManager$1.publish(JCSCacheManager.java:80)
	at java.util.logging.Logger.log(Logger.java:738)
	at java.util.logging.Logger.doLog(Logger.java:765)
	at java.util.logging.Logger.logp(Logger.java:1041)
	at org.apache.commons.logging.impl.Jdk14Logger.log(Jdk14Logger.java:89)
	at org.apache.commons.logging.impl.Jdk14Logger.error(Jdk14Logger.java:135)
	at org.apache.commons.jcs.auxiliary.disk.indexed.IndexedDiskCache.processUpdate(IndexedDiskCache.java:602)
	at org.apache.commons.jcs.auxiliary.AbstractAuxiliaryCacheEventLogging.updateWithEventLogging(AbstractAuxiliaryCacheEventLogging.java:65)
	at org.apache.commons.jcs.auxiliary.disk.AbstractDiskCache.doUpdate(AbstractDiskCache.java:804)
	at org.apache.commons.jcs.auxiliary.disk.AbstractDiskCache$MyCacheListener.handlePut(AbstractDiskCache.java:662)
	at org.apache.commons.jcs.engine.AbstractCacheEventQueue$PutEvent.doRun(AbstractCacheEventQueue.java:350)
	at org.apache.commons.jcs.engine.AbstractCacheEventQueue$AbstractCacheEvent.run(AbstractCacheEventQueue.java:269)
	at org.apache.commons.jcs.engine.CacheEventQueue$QProcessor.run(CacheEventQueue.java:304)
Caused by: java.lang.NumberFormatException: For input string: "switch:a"
	at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
	at java.lang.Integer.parseInt(Integer.java:580)
	at java.lang.Integer.parseInt(Integer.java:615)
	at java.text.MessageFormat.makeFormat(MessageFormat.java:1427)
	... 16 more

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by simon04

Resolution: fixed
Status: newclosed

In 8991/josm:

fix #12054 - IllegalArgumentException in JCS log handler

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.