Modify

Opened 4 years ago

Closed 4 years ago

#12046 closed defect (fixed)

Crashes when select Import PDF

Reported by: Glassman Owned by: team
Priority: normal Milestone:
Component: Plugin pdfimport Version:
Keywords: template_report Cc: Glassman

Description

What steps will reproduce the problem?

  1. From Imagary menu select Import PDF
  2. From Import PDF dialog box, select pdf file to import
  3. Get crash message

What is the expected result?

PDF is shown in JOSM

What happens instead?

Get crash message and notice to file a bug report

Same problem on Mac OSX and Ubuntu

Please provide any additional information below. Attach a screenshot if possible.

Revision: 8972
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: Don-vip
Last Changed Date: 2015-10-31 17:07:51 +0100 (Sat, 31 Oct 2015)
Build-Date: 2015-11-01 02:32:51
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8972

Identification: JOSM/1.5 (8972 en) Mac OS X 10.10.5
Memory Usage: 667 MB / 1820 MB (207 MB allocated, but free)
Java version: 1.8.0_60, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Djava.library.path=/Applications/JOSM.app/Contents/MacOS, -DLibraryDirectory=/Users/cliffordsnow/Library, -DDocumentsDirectory=/Users/cliffordsnow/Documents, -DApplicationSupportDirectory=/Users/cliffordsnow/Library/Application Support, -DCachesDirectory=/Users/cliffordsnow/Library/Caches, -DSandboxEnabled=false, -Djosm.home=/Users/cliffordsnow/.josm_glassman, -Dapple.laf.useScreenMenuBar=true, -Dcom.apple.macos.use-file-dialog-packages=true, -Dcom.apple.macos.useScreenMenuBar=true, -Dcom.apple.mrj.application.apple.menu.about.name=JOSM, -Dcom.apple.smallTabs=true]

Plugins:
- ColorPlugin (1414145445)
- DxfImport (UNKNOWN)
- ImportImagePlugin (31603)
- Mapillary (31694)
- OpeningHoursEditor (31696)
- PicLayer (31694)
- apache-commons (31718)
- apache-http (31687)
- areaselector (263)
- buildings_tools (31694)
- geochat (31694)
- geotools (31603)
- jts (31603)
- lakewalker (31694)
- log4j (31603)
- measurement (31694)
- merge-overlap (31655)
- missingRoads (31)
- pbf (31694)
- pdfimport (31694)
- public_transport (31646)
- public_transport_layer (31694)
- reverter (31694)
- splinex (31694)
- trafficFlowDirection (13)
- turnlanes (31603)
- turnrestrictions (31694)
- utilsplugin2 (31694)
- wikipedia (31694)

Last errors/warnings:
- E: Failed to locate image 'icons/research.png'
- W:  Research: Could not get presets icon icons/research.png
- E: Failed to locate image 'icons/travel_agent.png'
- W:  Travel Agent: Could not get presets icon icons/travel_agent.png
- E: java.lang.NoClassDefFoundError: org/apache/fontbox/afm/AFMParser. Cause: java.lang.ClassNotFoundException: org.apache.fontbox.afm.AFMParser

java.lang.NoClassDefFoundError: org/apache/fontbox/afm/AFMParser
	at org.apache.pdfbox.pdmodel.font.PDFont.addAdobeFontMetric(PDFont.java:165)
	at org.apache.pdfbox.pdmodel.font.PDFont.addAdobeFontMetric(PDFont.java:152)
	at org.apache.pdfbox.pdmodel.font.PDFont.getAdobeFontMetrics(PDFont.java:122)
	at org.apache.pdfbox.pdmodel.font.PDFont.<clinit>(PDFont.java:114)
	at org.apache.pdfbox.pdmodel.font.PDFontFactory.createFont(PDFontFactory.java:100)
	at org.apache.pdfbox.pdmodel.PDResources.getFonts(PDResources.java:213)
	at org.apache.pdfbox.util.PDFStreamEngine.getFonts(PDFStreamEngine.java:607)
	at org.apache.pdfbox.util.operator.SetTextFont.process(SetTextFont.java:59)
	at org.apache.pdfbox.util.PDFStreamEngine.processOperator(PDFStreamEngine.java:557)
	at org.apache.pdfbox.util.PDFStreamEngine.processSubStream(PDFStreamEngine.java:268)
	at org.apache.pdfbox.util.PDFStreamEngine.processSubStream(PDFStreamEngine.java:235)
	at org.apache.pdfbox.util.PDFStreamEngine.processStream(PDFStreamEngine.java:215)
	at pdfimport.pdfbox.PageDrawer.drawPage(PageDrawer.java:87)
	at pdfimport.pdfbox.PdfBoxParser.parse(PdfBoxParser.java:50)
	at pdfimport.LoadPdfDialog.loadPDF(LoadPdfDialog.java:861)
	at pdfimport.LoadPdfDialog.access$1300(LoadPdfDialog.java:65)
	at pdfimport.LoadPdfDialog$11.run(LoadPdfDialog.java:563)
	at pdfimport.LoadPdfDialog$19.run(LoadPdfDialog.java:789)
	at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.ClassNotFoundException: org.apache.fontbox.afm.AFMParser
	at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	... 19 more

Attachments (0)

Change History (5)

comment:1 Changed 4 years ago by Don-vip

Component: CorePlugin pdfimport

comment:2 Changed 4 years ago by anonymous

Ticket #12176 has been marked as a duplicate of this ticket.

comment:3 Changed 4 years ago by Nzara

I could fix the problem for me by adding fontbox-1.8.10.jar (avalable at http://archive.apache.org/dist/pdfbox/1.8.10/fontbox-1.8.10.jar) to pdfimport/lib. Seems that pdfbox-1.8.10.jar depends on that.

Someone more familiar with updating plugins may publish a new version.

comment:4 Changed 4 years ago by Don-vip

thanks for the tip, I fix the plugin right now

comment:5 Changed 4 years ago by Don-vip

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.