Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12023 closed defect (fixed)

[PATCH] When RemoteControl option disabled - freeze

Reported by: freeExec Owned by: team
Priority: normal Milestone: 15.10
Component: Core remotecontrol Version: latest
Keywords: Cc:

Description

Endless cycle in RemoteControlHttpServer.Run()

  1. Open Settings — RemoteControl tab
  2. Disable RemoteControl
  3. 100% CPU load

Attachments (1)

CorrectServerStop.patch (873 bytes) - added by akks 4 years ago.
fix for the server stop problem

Download all attachments as: .zip

Change History (15)

comment:1 Changed 4 years ago by Don-vip

Owner: changed from team to freeExec
Status: newneedinfo

That is a very incomplete ticket please read again instructions on newticket. The yellow square is not there for nothing.

comment:2 Changed 4 years ago by freeExec

Revision: 8964
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: simon04
Last Changed Date: 2015-10-27 23:40:20 +0100 (Tue, 27 Oct 2015)
Build-Date: 2015-10-28 02:32:10
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8964

Identification: JOSM/1.5 (8964 ru) Windows 7 64-Bit
Memory Usage: 487 MB / 1067 MB (362 MB allocated, but free)
Java version: 1.8.0_45, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Dfile.encoding=Cp866]

Plugins:
- CommandLine (31694)
- FastDraw (31694)
- HouseNumberTaggingTool (31603)
- ImageWayPoint (31603)
- OpeningHoursEditor (31696)
- PicLayer (31694)
- SeaMapEditor (31603)
- buildings_tools (31694)
- editgpx (31603)
- geochat (31694)
- imagery_offset_db (31694)
- josm-plugin-opengl (1440156917)
- log4j (31603)
- measurement (31694)
- poly (31694)
- reltoolbox (31694)
- reverter (31694)
- scripting (30722)
- tageditor (31615)
- turnrestrictions (31694)
- utilsplugin2 (31694)

Last errors/warnings:
- W: Сбой загрузки http://ekatyshev.ru/osm/style/area-fill2.mapcss, используйте кэшированный файл и повторите попытку позже: java.io.IOException: Ошибка чтения с 'http://ekatyshev.ru/osm/style/area-fill2.mapcss'. Сервер ответил с кодом состояния 404.
- W: Сбой загрузки http://ekatyshev.ru/osm/style/area-fill2.mapcss, используйте кэшированный файл и повторите попытку позже: java.io.IOException: Ошибка чтения с 'http://ekatyshev.ru/osm/style/area-fill2.mapcss'. Сервер ответил с кодом состояния 404.
- W: Предупреждение: Заготовка тегов "leaf_type-Type": Игнорируем атрибут 'values' в элементах 'list_entry'.

comment:3 Changed 4 years ago by Don-vip

OK thanks. Can you please first update your version of Java? You're several updates behind.

comment:4 Changed 4 years ago by freeExec

That is, you have the latest update on the Java bug does not play?

comment:5 Changed 4 years ago by akks

Reproduced on Windows (Java 1.8 60), people with 65 reported this too. Will debug.

comment:6 Changed 4 years ago by Don-vip

Milestone: 15.10

Ok we'll release a new tested anyway.

comment:7 Changed 4 years ago by akks

It happens only once after unchecking the tick, after all. Will attach a patch, not committing immediately.

Last edited 4 years ago by akks (previous) (diff)

Changed 4 years ago by akks

Attachment: CorrectServerStop.patch added

fix for the server stop problem

comment:8 Changed 4 years ago by akks

Summary: When RemoteControl option disabled - freeze[PATCH] When RemoteControl option disabled - freeze

Here it is, simple and easy. May I commit it?

comment:9 Changed 4 years ago by Don-vip

of course, go ahead :) however I don't get what caused the regression?

comment:10 Changed 4 years ago by Don-vip

Owner: changed from freeExec to team
Status: needinfonew

comment:11 Changed 4 years ago by akks

Seems it was already here 5 years ago:
https://josm.openstreetmap.de/browser/josm/trunk/src/org/openstreetmap/josm/io/remotecontrol/RemoteControlHttpServer.java?rev=3707
Just no one noticed it because it does not affect the main thread.

comment:12 Changed 4 years ago by akks

Usually people turn on remote control one time and forget about it :)

comment:13 Changed 4 years ago by akks

Resolution: fixed
Status: newclosed

In 8966/josm:

fix #12023: 100% cpu load after turning off remote control

comment:14 Changed 4 years ago by Zverikk

Parukhin in the russian forum says, this problem was solved only by half: processor load is only 50% now :)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.