Modify

Opened 5 years ago

Closed 5 years ago

#12003 closed defect (duplicate)

Merging two connected polygons causes crash

Reported by: Glassman Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc: Glassman

Description

What steps will reproduce the problem?

  1. Select two overlapping areas
  2. Join using the "Join Overlapping Areas" (Shift J) command

What is the expected result?

The two polygons are combined into one

What happens instead?

JOSM gives an error report

Please provide any additional information below. Attach a screenshot if possible.

Revision: 8931
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: Don-vip
Last Changed Date: 2015-10-23 01:17:45 +0200 (Fri, 23 Oct 2015)
Build-Date: 2015-10-23 01:32:17
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8931

Identification: JOSM/1.5 (8931 en) Mac OS X 10.10.5
Memory Usage: 511 MB / 1820 MB (239 MB allocated, but free)
Java version: 1.8.0_60, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Djava.library.path=/Applications/JOSM.app/Contents/MacOS, -DLibraryDirectory=/Users/cliffordsnow/Library, -DDocumentsDirectory=/Users/cliffordsnow/Documents, -DApplicationSupportDirectory=/Users/cliffordsnow/Library/Application Support, -DCachesDirectory=/Users/cliffordsnow/Library/Caches, -DSandboxEnabled=false, -Djosm.home=/Users/cliffordsnow/.josm_glassman, -Dapple.laf.useScreenMenuBar=true, -Dcom.apple.macos.use-file-dialog-packages=true, -Dcom.apple.macos.useScreenMenuBar=true, -Dcom.apple.mrj.application.apple.menu.about.name=JOSM, -Dcom.apple.smallTabs=true]
Dataset consistency test: No problems found

Plugins:
- ColorPlugin (1414145445)
- DxfImport (UNKNOWN)
- ImportImagePlugin (31603)
- Mapillary (31612)
- OpeningHoursEditor (31603)
- PicLayer (31603)
- areaselector (257)
- buildings_tools (31640)
- commons-imaging (31603)
- geochat (31603)
- geotools (31603)
- jts (31603)
- lakewalker (31603)
- log4j (31603)
- measurement (31648)
- merge-overlap (31655)
- missingRoads (31)
- pbf (31603)
- pdfimport (31603)
- public_transport (31646)
- public_transport_layer (31603)
- reverter (31625)
- splinex (31644)
- turnlanes (31603)
- turnrestrictions (31638)
- utilsplugin2 (31655)
- wikipedia (31603)

Last errors/warnings:
- E: Failed to locate image 'icons/research.png'
- W: Could not get presets icon icons/research.png
- E: Failed to locate image 'icons/travel_agent.png'
- W: Could not get presets icon icons/travel_agent.png
- E: java.lang.RuntimeException: Way not circular

java.lang.RuntimeException: Way not circular
	at org.openstreetmap.josm.actions.JoinAreasAction.markWayInsideSide(JoinAreasAction.java:778)
	at org.openstreetmap.josm.actions.JoinAreasAction.joinAreas(JoinAreasAction.java:581)
	at org.openstreetmap.josm.actions.JoinAreasAction.join(JoinAreasAction.java:475)
	at org.openstreetmap.josm.actions.JoinAreasAction.actionPerformed(JoinAreasAction.java:405)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2022)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2348)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:376)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:833)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:877)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6535)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
	at java.awt.Component.processEvent(Component.java:6300)
	at java.awt.Container.processEvent(Container.java:2236)
	at java.awt.Component.dispatchEventImpl(Component.java:4891)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Component.dispatchEvent(Component.java:4713)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4888)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4525)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4466)
	at java.awt.Container.dispatchEventImpl(Container.java:2280)
	at java.awt.Window.dispatchEventImpl(Window.java:2750)
	at java.awt.Component.dispatchEvent(Component.java:4713)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:86)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by Klumbumbus

duplicate of #11992?

comment:2 Changed 5 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #11992.
Yes. I don't know how to fix it, I'm waiting for Simon's return :) That's why the jenkins build is failing, too.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.