Modify

Opened 4 years ago

Closed 4 years ago

#11998 closed defect (fixed)

Continous download plugin crashes as rememberErrorMessage is final

Reported by: mkoniecz Owned by: team
Priority: normal Milestone: 15.10
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Enable ContinousDownload plugin
  2. Start JOSM

What is the expected result?

Plugin works, as it was happening

What happens instead?

Plugin is unable to load

INFO: loading plugin 'continuosDownload' (version 1413902943)
ERROR: org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin continuosDownload. Cause: java.lang.reflect.InvocationTargetException. Cause: java.lang.VerifyError: class org.openstreetmap.josm.plugins.continuosDownload.DownloadOsmTask2 overrides final method rememberErrorMessage.(Ljava/lang/String;)V
org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin continuosDownload
	at org.openstreetmap.josm.plugins.PluginInformation.load(PluginInformation.java:336)
	at org.openstreetmap.josm.plugins.PluginHandler.loadPlugin(PluginHandler.java:698)
	at org.openstreetmap.josm.plugins.PluginHandler.loadPlugins(PluginHandler.java:758)
	at org.openstreetmap.josm.plugins.PluginHandler.loadLatePlugins(PluginHandler.java:797)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:463)
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:422)
	at org.openstreetmap.josm.plugins.PluginInformation.load(PluginInformation.java:333)
	... 4 more
Caused by: java.lang.VerifyError: class org.openstreetmap.josm.plugins.continuosDownload.DownloadOsmTask2 overrides final method rememberErrorMessage.(Ljava/lang/String;)V
	at java.lang.ClassLoader.defineClass1(Native Method)
	at java.lang.ClassLoader.defineClass(ClassLoader.java:760)
	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
	at java.net.URLClassLoader.defineClass(URLClassLoader.java:467)
	at java.net.URLClassLoader.access$100(URLClassLoader.java:73)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:368)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:362)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:361)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	at org.openstreetmap.josm.plugins.continuosDownload.DownloadPlugin.<init>(DownloadPlugin.java:54)

Please provide any additional information below. Attach a screenshot if possible.

Reported also as https://github.com/Gnonthgol/JOSM-continuos-download/issues/16 - I have no idea is it JOSM bug or a plugin bug.

Revision: 8926
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: Don-vip
Last Changed Date: 2015-10-22 02:01:00 +0200 (Thu, 22 Oct 2015)
Build-Date: 2015-10-22 01:32:36
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8926

Identification: JOSM/1.5 (8926 en) Linux Ubuntu 14.04.3 LTS
Memory Usage: 272 MB / 889 MB (177 MB allocated, but free)
Java version: 1.8.0_60, Oracle Corporation, Java HotSpot(TM) Server VM

Plugins:
- OpeningHoursEditor (31603)
- RoadSigns (31603)
- continuosDownload
- measurement (31648)

Last errors/warnings:
- E: org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin continuosDownload. Cause: java.lang.reflect.InvocationTargetException. Cause: java.lang.VerifyError: class org.openstreetmap.josm.plugins.continuosDownload.DownloadOsmTask2 overrides final method rememberErrorMessage.(Ljava/lang/String;)V

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by Don-vip

Milestone: 15.10

comment:2 Changed 4 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 8927/josm:

fix #11998 - add two new protected boolean members to simplify customization of OSM download task for plugins + fix some javadoc/sonar issues

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.