Modify

Opened 4 years ago

Closed 4 years ago

#11957 closed defect (fixed)

Merging ways fails

Reported by: hjart Owned by: Don-vip
Priority: major Milestone: 15.10
Component: Core Version: latest
Keywords: template_report, regression Cc:

Description (last modified by hjart)

What steps will reproduce the problem?

  1. Having 2 ways each sharing an endnode with one another and then trying to merge them

Ways before merging

What is the expected result?

1 way merged by the shared node

What happens instead?

As above, but new way ends with the second-to-last node and first and last node is connected

Way after merging

Please provide any additional information below. Attach a screenshot if possible.

Revision: 8855
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: Don-vip
Last Changed Date: 2015-10-10 21:01:42 +0200 (Sat, 10 Oct 2015)
Build-Date: 2015-10-11 01:32:21
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8855

Identification: JOSM/1.5 (8855 da) Linux openSUSE 13.2 (Harlequin) (x86_64)
Memory Usage: 291 MB / 1328 MB (66 MB allocated, but free)
Java version: 1.8.0_60, Oracle Corporation, OpenJDK 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- DirectUpload (31603)
- InfoMode (31603)
- Mapillary (31603)
- Remove.redundant.points (1000)
- SimplifyArea (31603)
- buildings_tools (31603)
- commons-imaging (31603)
- missingRoads (31)
- rasterfilters (31603)
- reverter (31603)
- scoutsigns (67)
- todo (29154)
- undelete (31603)
- utilsplugin2 (31603)
- wikipedia (31603)

Last errors/warnings:
- E: Kunne ikke finde billedet "maxspeed_icon.svg"
- W: Mappaint style "standard" (Maxspeed) icon "maxspeed_icon.svg" not found.

Attachments (2)

Ulvevej-after.png (403.5 KB) - added by hjart 4 years ago.
Way after merging
Ulvevej-before.png (419.3 KB) - added by hjart 4 years ago.
Ways before merging

Download all attachments as: .zip

Change History (11)

Changed 4 years ago by hjart

Attachment: Ulvevej-after.png added

Way after merging

Changed 4 years ago by hjart

Attachment: Ulvevej-before.png added

Ways before merging

comment:1 Changed 4 years ago by hjart

Description: modified (diff)

comment:2 Changed 4 years ago by Klumbumbus

Can you please link to the location or add an osm file with the data?

comment:3 Changed 4 years ago by hjart

@Klumbumbus I unfortunately already connected those ways using josm-tested, so I'm afraid that location isn't much use for this anymore, but just in case: http://www.openstreetmap.org/way/89147550#map=19/55.50750/8.44695

comment:4 Changed 4 years ago by hjart

@Klumbumbus Found another case: Same thing happens when trying to merge http://www.openstreetmap.org/way/148830403 with the unclassified on the other side of Krebsestien.

comment:5 Changed 4 years ago by Klumbumbus

Keywords: regression added
Milestone: 15.10

Works fine in r8800 but not in r8855.

comment:6 Changed 4 years ago by Don-vip

Owner: changed from team to Don-vip
Status: newassigned

comment:7 Changed 4 years ago by Don-vip

unexpected regression of r8851

comment:8 Changed 4 years ago by anonymous

Ticket #11958 has been marked as a duplicate of this ticket.

comment:9 Changed 4 years ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 8856/josm:

fix #11957 - partial revert of r8851 - do not replace Stack by ArrayDeque because of different iteration behaviour + add unit test

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.