Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11897 closed enhancement (fixed)

Merge LayerListDialog.MergeAction and MergeLayerAction

Reported by: simon04 Owned by: team
Priority: normal Milestone: 15.10
Component: Core Version:
Keywords: Cc: Don-vip, malenki

Description

See ticket:11891#comment:9

Merging layers is placed in the Edit menu as well as in the context menu of the layer list dialog.

Attachments (0)

Change History (12)

comment:1 Changed 4 years ago by simon04

Cc: Don-vip malenki added

Personally, I would vote for removing the merge operation from the Edit menu. Analogously, neither duplicating nor deleting layers is placed in the Edit menu.

comment:2 Changed 4 years ago by Don-vip

I have no objection to remove the entry from Edit menu. Can we preserve the shortcut Ctrl-M?

comment:3 Changed 4 years ago by malenki

Maybe also the "mark layer as active"-button could be removed from the layer window since this action is more obvious by the green hook already displayed in the window.¹
Then the "merge layers"-button could be re-applied.

¹ IMHO the workflow to just select a layer by clicking on the place where the green hook will be placed is more straightforward to selecting a layer, go down and press "make layer active".
(I never once used this button).

comment:4 Changed 4 years ago by mcpicoli

Not sure if this is the correct place, and not wanting to open an unneeded new ticket, I ask (version is 8800):

"Where is the Merge Down button that used to be where the (useless - for me) "adjust gamma" button is now, in the "Layers" dialog?"
"How can the same result of the old button be achieved without it?"

I use JOSM to manage a large collection of GPX files (secondarily, to contribute data to OSM) and always used the "Merge Down" button to add a new GPS trace to a pre-existing collection (in which all of them share some key characteristic).

Tried using "Edit" -> "Merge Layer" (<ctrl>+<M>, <ctrl>+<shift>+<M>), to no avail, both with one or both GPX layers selected.

I hope JOSM is not going down the Microsoft/Apple way of removing "unneeded" features just to add some eye candy...

Going back to 8677 for now.

comment:5 in reply to:  4 Changed 4 years ago by malenki

Replying to mcpicoli:

Not sure if this is the correct place, and not wanting to open an unneeded new ticket, I ask (version is 8800):

IMHO this would be worth another ticket.

"Where is the Merge Down button that used to be where the (useless - for me) "adjust gamma" button is now, in the "Layers" dialog?"

Obviously the Merge Layers button is gone. The "Adjust Gamme" you will learn to like when you have some quite bad imagery you need to tune. This feature was asked for since some years.

"How can the same result of the old button be achieved without it?"

I use JOSM to manage a large collection of GPX files (secondarily, to contribute data to OSM) and always used the "Merge Down" button to add a new GPS trace to a pre-existing collection (in which all of them share some key characteristic).

Tried using "Edit" -> "Merge Layer" (<ctrl>+<M>, <ctrl>+<shift>+<M>), to no avail, both with one or both GPX layers selected.

Since I never used "merge layers" for GPX files I did not realize that the merge button merged not only OSM layers but also GPX layers. It seems there were two different calls for merging layers, now maybe even three (context menu, ctrl-m, the one of the dropped merge-button).

I hope JOSM is not going down the Microsoft/Apple way of removing "unneeded" features just to add some eye candy...

LOL – JOSM and "eyecandy" in one breath.
Seriously: If your issue isn't picked up here you should open a new ticket – and skip useless ranting or accusations.

comment:6 Changed 4 years ago by richlv

merging gpx layers often is the first thing in my mapping sessions - with 8800 that didn't work that well ;)

as that is indeed a separate issue from this low level task (even if it might eventually solve it), created a new ticket at #11925

comment:7 Changed 4 years ago by simon04

In 8818/josm:

fix #11925, see #11897 - Re-enable merging of gpx, marker, geoimage layers

Regression of r8728.

comment:8 Changed 4 years ago by simon04

In 8819/josm:

see #11897 - MergeLayerAction: merge active layer instead of edit layer

This allows merging of gpx/marker/geoimage layers using [CTRL]+[M].

comment:9 Changed 4 years ago by simon04

Resolution: fixed
Status: newclosed

Since "Merge layers" is also present in the "Edit" menu, I'd refrain from the original proposal (LayerListDialog.MergeAction and MergeLayerAction) and close this ticket.

comment:10 Changed 4 years ago by malenki

Maybe I don't understand you correct but it seems to me that you want to keep both "Merge layers" actions different in behaviour (one merges only one layer, the other also several) and location (one in Edit –> Merge Layer and hotkey CTRL-M, the other only in the layers context menu).
Is this correct?

comment:11 Changed 4 years ago by simon04

Yes. The main difference is that the merge operation from the Edit menu operates on the active layer. In contrary, in the layer list dialog you may select arbitrary layers (concerning activeness and number) to be merged.

comment:12 Changed 4 years ago by richlv

normally operations in the edit menu operate on the selection still - wouldn't it be better for the menu entry to operate on the selected layers, too ?
at least personally i would expect for it to work that way and would never guess it would only affect the active layer...

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.