Modify

Opened 5 years ago

Closed 5 years ago

#11892 closed defect (duplicate)

Can't download map data - OverlappingFileLockException

Reported by: Hb--- Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report java9 javabug Cc:

Description

What steps will reproduce the problem?

  1. Start JOSM
  2. Click Download from OSM

What is the expected result?

See a map.

What happens instead?

See an error dialog.

Please provide any additional information below. Attach a screenshot if possible.

Revision: 8791
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: simon04
Last Changed Date: 2015-09-23 21:37:04 +0200 (Wed, 23 Sep 2015)
Build-Date: 2015-09-24 01:32:31
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8791

Identification: JOSM/1.5 (8791 de) Windows 7 64-Bit
Memory Usage: 70 MB / 247 MB (26 MB allocated, but free)
Java version: 1.9.0-ea, Oracle Corporation, Java HotSpot(TM) Client VM


Last errors/warnings:
- E: java.lang.NoClassDefFoundError: com/sun/management/internal/GarbageCollectorExtImpl

java.lang.NoClassDefFoundError: com/sun/management/internal/GarbageCollectorExtImpl
	at sun.management.MemoryImpl.getMemoryManagers0(Native Method)
	at sun.management.MemoryImpl.getMemoryManagers(MemoryImpl.java:98)
	at sun.management.ManagementFactoryHelper.getGarbageCollectorMXBeans(ManagementFactoryHelper.java:130)
	at java.lang.management.DefaultPlatformMBeanProvider$4.nameToMBeanMap(DefaultPlatformMBeanProvider.java:185)
	at java.lang.management.ManagementFactory.lambda$getPlatformMBeanServer$0(ManagementFactory.java:478)
	at java.util.stream.ReferencePipeline$7$1.accept(ReferencePipeline.java:269)
	at java.util.stream.ReferencePipeline$2$1.accept(ReferencePipeline.java:177)
	at java.util.HashMap$ValueSpliterator.forEachRemaining(HashMap.java:1664)
	at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:482)
	at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:472)
	at java.util.stream.ForEachOps$ForEachOp.evaluateSequential(ForEachOps.java:151)
	at java.util.stream.ForEachOps$ForEachOp$OfRef.evaluateSequential(ForEachOps.java:174)
	at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234)
	at java.util.stream.ReferencePipeline.forEach(ReferencePipeline.java:430)
	at java.lang.management.ManagementFactory.getPlatformMBeanServer(ManagementFactory.java:479)
	at org.apache.commons.jcs.engine.control.CompositeCacheManager.initialize(CompositeCacheManager.java:262)
	at org.apache.commons.jcs.engine.control.CompositeCacheManager.getUnconfiguredInstance(CompositeCacheManager.java:214)
	at org.openstreetmap.josm.data.cache.JCSCacheManager.initialize(JCSCacheManager.java:117)
	at org.openstreetmap.josm.data.cache.JCSCacheManager.getCache(JCSCacheManager.java:148)
	at org.openstreetmap.josm.gui.layer.AbstractCachedTileSourceLayer.getCache(AbstractCachedTileSourceLayer.java:122)
	at org.openstreetmap.josm.gui.layer.AbstractCachedTileSourceLayer.getTileLoaderFactory(AbstractCachedTileSourceLayer.java:113)
	at org.openstreetmap.josm.gui.bbox.SlippyMapBBoxChooser.<init>(SlippyMapBBoxChooser.java:143)
	at org.openstreetmap.josm.gui.download.SlippyMapChooser.<init>(SlippyMapChooser.java:34)
	at org.openstreetmap.josm.gui.download.DownloadDialog.buildMainPanel(DownloadDialog.java:122)
	at org.openstreetmap.josm.gui.download.DownloadDialog.<init>(DownloadDialog.java:234)
	at org.openstreetmap.josm.gui.download.DownloadDialog.<init>(DownloadDialog.java:222)
	at org.openstreetmap.josm.gui.download.DownloadDialog.getInstance(DownloadDialog.java:66)
	at org.openstreetmap.josm.actions.DownloadAction.actionPerformed(DownloadAction.java:43)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2026)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2366)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:404)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:261)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:266)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:297)
	at java.awt.Component.processMouseEvent(Component.java:6607)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3349)
	at java.awt.Component.processEvent(Component.java:6372)
	at java.awt.Container.processEvent(Container.java:2259)
	at java.awt.Component.dispatchEventImpl(Component.java:4991)
	at java.awt.Container.dispatchEventImpl(Container.java:2317)
	at java.awt.Component.dispatchEvent(Component.java:4823)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4906)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4543)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4484)
	at java.awt.Container.dispatchEventImpl(Container.java:2303)
	at java.awt.Window.dispatchEventImpl(Window.java:2759)
	at java.awt.Component.dispatchEvent(Component.java:4823)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:761)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:712)
	at java.awt.EventQueue$3.run(EventQueue.java:706)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:77)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:734)
	at java.awt.EventQueue$4.run(EventQueue.java:732)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:77)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:731)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:192)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:117)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:1

Attachments (0)

Change History (4)

comment:1 Changed 5 years ago by Don-vip

Keywords: java9 javabug added
Resolution: othersoftware
Status: newclosed

Java 9 isn't supported yet, please downgrade to Java 8.

comment:2 Changed 5 years ago by Hb---

Under Java 8 JOSM indeed works fine.

comment:3 Changed 5 years ago by Don-vip

Resolution: othersoftware
Status: closedreopened

comment:4 Changed 5 years ago by Don-vip

Resolution: duplicate
Status: reopenedclosed

Closed as duplicate of #11577.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.