Modify

Opened 6 years ago

Closed 5 years ago

#11865 closed enhancement (duplicate)

snap zoom to native resolution of background map

Reported by: Klumbumbus Owned by: wiktorn
Priority: normal Milestone:
Component: Core mappaint Version:
Keywords: Cc:

Description (last modified by Klumbumbus)

It would be nice if there is an option that the zoom snaps to the native resoultion of the used background imagery. In the context menu of e.g. mapnik tms layer in the layer list there is the option "Zoom to native resolution", but this is just a onetime fix. After the next scroll with the mouse wheel the zoom is "broken" again and the text of a map background unreadable.


Attachments (1)

mapnik zoom.png (95.1 KB) - added by Klumbumbus 6 years ago.

Download all attachments as: .zip

Change History (9)

Changed 6 years ago by Klumbumbus

Attachment: mapnik zoom.png added

comment:1 Changed 6 years ago by Klumbumbus

Description: modified (diff)

comment:2 Changed 6 years ago by wiktorn

Owner: changed from team to wiktorn
Status: newassigned

As far as I'm checking the zoom levels, when you zoom with mouse, after you've snaped to native resolution of map, you're always moving through "native" zoom levels.

Only when you download new area and mapview is resized, then you loose your zoom levels fix.

Should it be a toggle, that background imagery fixes zoom level to zoom levels of imagery (modulo integral multipliers?)

comment:3 Changed 6 years ago by Klumbumbus

I double checked it. You are right that after snap you cycle through the native zoom levels. However there is always one non native zoomlevel between two native zoom levels, which looks bad (like in the picure above).

Only when you download new area and mapview is resized, then you loose your zoom levels fix.

Also when you zoom far in or far out.

comment:4 in reply to:  3 Changed 6 years ago by wiktorn

Replying to Klumbumbus:

I double checked it. You are right that after snap you cycle through the native zoom levels. However there is always one non native zoomlevel between two native zoom levels, which looks bad (like in the picure above).

That's what we always had. I'm not sure, if we should disregard this zoom levels.

Remember please, that also WMTS layer may provide zoom levels from totally different scales, as there - there is a lot of flexibility, how do you want to define them.

comment:5 Changed 6 years ago by Klumbumbus

Hmm, for my special use case (tour planning with mapnik backgound) it would be good if the non native zoom levels were skipped to see only sharp tiles. However there are maybe other use cases, where this would not be good, so maybe we should just keep it as is.

comment:6 Changed 6 years ago by wiktorn

I'd wait for #11637 before continuing work on this. As I understand - smooth zooming might be interesting for other use cases.

Maybe we should just disallow shrinking tiles in default mode (as I guess, was the case in the image you've presented).

comment:7 Changed 6 years ago by Klumbumbus

see also #12350

comment:8 Changed 5 years ago by Klumbumbus

Resolution: duplicate
Status: assignedclosed

Closed as duplicate of #12350.
From my point of view this is fixed with #12350

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain wiktorn.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.