Modify

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#11852 closed defect (fixed)

RuntimeException while validating data

Reported by: naoliv Owned by: team
Priority: normal Milestone: 16.08
Component: Core validator Version:
Keywords: Cc:

Description

Solved 2 conflicts and then clicked to validate the data.
Got this:

Build-Date: 2015-09-10 21:31:06
Revision: 8747
Is-Local-Build: true

Identification: JOSM/1.5 (8747 SVN pt_BR) Linux Debian GNU/Linux unstable (sid)
Memory Usage: 685 MB / 5461 MB (281 MB allocated, but free)
Java version: 1.7.0_85, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u85-2.6.1-3
VM arguments: [-Dawt.useSystemAAFontSettings=on, -Dsun.java2d.opengl=true]

Dataset consistency test:
[COMPLETE WITHOUT COORDINATES] {Node id=1428141557 version=1 V } is not incomplete but has null coordinates
[COMPLETE WITHOUT COORDINATES] {Node id=1512430991 version=1 V } is not incomplete but has null coordinates


Plugins:
- AddrInterpolation (31241)
- Create_grid_of_ways (31241)
- FastDraw (31265)
- FixAddresses (31241)
- OpeningHoursEditor (31241)
- PicLayer (31241)
- SimplifyArea (31241)
- buildings_tools (31361)
- download_along (31241)
- editgpx (31241)
- geotools (31126)
- graphview (31241)
- jts (31126)
- measurement (31289)
- merge-overlap (31241)
- opendata (31241)
- pdfimport (31241)
- poly (31241)
- reverter (31241)
- tagging-preset-tester (31241)
- todo (29154)
- turnrestrictions (31241)
- undelete (31241)
- utilsplugin2 (31463)

Last errors/warnings:
- W: New conflict: Conflict [my={Node id=1428141557 version=1 MVD lat=-22.224768,lon=-49.9291671}, their={Node id=1428141557 version=0 IV }]
- W: Unable to remove primitives from TestError [tester=org.openstreetmap.josm.data.validation.tests.CrossingWays$Ways@3a00343e, code=601, message=Vias que se cruzam]
- W: Unable to remove primitives from TestError [tester=org.openstreetmap.josm.data.validation.tests.CrossingWays$Ways@3a00343e, code=601, message=Vias que se cruzam]
- W: Unable to remove primitives from TestError [tester=org.openstreetmap.josm.data.validation.tests.CrossingWays$Ways@3a00343e, code=601, message=Vias que se cruzam]
- E: java.lang.RuntimeException: java.lang.reflect.InvocationTargetException. Causa: java.lang.reflect.InvocationTargetException. Causa: java.lang.NullPointerException

java.lang.RuntimeException: java.lang.reflect.InvocationTargetException
	at org.openstreetmap.josm.gui.mappaint.mapcss.Condition$PseudoClassCondition.applies(Condition.java:625)
	at org.openstreetmap.josm.gui.mappaint.mapcss.Selector$AbstractSelector.matches(Selector.java:466)
	at org.openstreetmap.josm.gui.mappaint.mapcss.Selector$GeneralSelector.matches(Selector.java:537)
	at org.openstreetmap.josm.data.validation.tests.MapCSSTagChecker$TagCheck.whichSelectorMatchesEnvironment(MapCSSTagChecker.java:382)
	at org.openstreetmap.josm.data.validation.tests.MapCSSTagChecker.getErrorsForPrimitive(MapCSSTagChecker.java:644)
	at org.openstreetmap.josm.data.validation.tests.MapCSSTagChecker.getErrorsForPrimitive(MapCSSTagChecker.java:632)
	at org.openstreetmap.josm.data.validation.tests.MapCSSTagChecker.check(MapCSSTagChecker.java:665)
	at org.openstreetmap.josm.data.validation.Test$TagTest.visit(Test.java:118)
	at org.openstreetmap.josm.data.osm.Node.accept(Node.java:212)
	at org.openstreetmap.josm.data.validation.Test.visit(Test.java:203)
	at org.openstreetmap.josm.actions.ValidateAction$ValidationTask.realRun(ValidateAction.java:170)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:161)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.GeneratedMethodAccessor82.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.openstreetmap.josm.gui.mappaint.mapcss.Condition$PseudoClassCondition.applies(Condition.java:623)
	... 17 more
Caused by: java.lang.NullPointerException
	at org.openstreetmap.josm.data.Bounds.contains(Bounds.java:343)
	at org.openstreetmap.josm.actions.search.SearchCompiler$InArea.match(SearchCompiler.java:1324)
	at org.openstreetmap.josm.actions.search.SearchCompiler$InDataSourceArea.match(SearchCompiler.java:1339)
	at org.openstreetmap.josm.actions.search.SearchCompiler$Match.evaluate(SearchCompiler.java:251)
	at org.openstreetmap.josm.actions.search.SearchCompiler$Match.evaluate(SearchCompiler.java:223)
	at org.openstreetmap.josm.gui.mappaint.mapcss.Condition$PseudoClasses.inDownloadedArea(Condition.java:582)
	... 21 more

The attached data is what I had after the exception.

Attachments (4)

data.osm.bz2 (234.4 KB) - added by naoliv 4 years ago.
before.osm.bz2 (268.7 KB) - added by naoliv 4 years ago.
I had to fix the previous errors and uploaded it to OSM. But with this new file it's still possible to see the same problem. Open it in JOSM and revert 33193046. You will hit 52 conflicts. Just fix the first one (1512430991), selecting "Their version". Validate and there is an error.
resolving-their-null-coordinate-was-possible.png (20.2 KB) - added by simon04 4 years ago.
resolving-their-null-coordinate-is-no-longer-possible.png (20.0 KB) - added by simon04 4 years ago.

Download all attachments as: .zip

Change History (12)

Changed 4 years ago by naoliv

Attachment: data.osm.bz2 added

comment:1 Changed 4 years ago by simon04

I cannot reproduce the problem. The issue seems to be that in your running instance, two nodes do not have coordinates attached (see "Dataset consistency test" of the report). It's hard to tell how it came to this state (due to the applied conflict resolution?). I would rather close this issue …

comment:2 Changed 4 years ago by naoliv

I will see if I can reproduce it and get back to you later.

comment:3 Changed 4 years ago by naoliv

Right, I can reproduce it (and I hope you can too):
Download the new attachment (before.osm.bz2) and fully revert the changeset 33193046 with the reverter plugin.
Wait a little (sorry for the size of the changeset). You will see 2 conflicts.
Choose "Their version" for both.
Now run the validator and the exception happens.

Changed 4 years ago by naoliv

Attachment: before.osm.bz2 added

I had to fix the previous errors and uploaded it to OSM. But with this new file it's still possible to see the same problem. Open it in JOSM and revert 33193046. You will hit 52 conflicts. Just fix the first one (1512430991), selecting "Their version". Validate and there is an error.

comment:4 Changed 4 years ago by simon04

In 8785/josm:

see #11852 - Disallow resolving null coordinate in conflict dialog

comment:5 Changed 4 years ago by simon04

But I don't get, why node 1512430991 needs a conflict resolution …

comment:6 Changed 3 years ago by skyper

Ticket #13499 has been marked as a duplicate of this ticket.

comment:7 Changed 3 years ago by simon04

Resolution: fixed
Status: newclosed

In 10919/josm:

fix #11852 - NPE in SearchCompiler

comment:8 Changed 3 years ago by simon04

Milestone: 16.08

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.