Modify

Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#11841 closed defect (fixed)

RejectedExecutionException in MapillarySquareDownloadManagerThread

Reported by: baditaflorin Owned by: Don-vip
Priority: major Milestone:
Component: Plugin mapillary Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

Revision: 8677
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: Don-vip
Last Changed Date: 2015-08-21 22:18:03 +0200 (Fri, 21 Aug 2015)
Build-Date: 2015-08-21 23:32:08
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8677

Identification: JOSM/1.5 (8677 en) Windows 7 64-Bit
Memory Usage: 834 MB / 910 MB (440 MB allocated, but free)
Java version: 1.8.0_60, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- Mapillary (31525)
- buildings_tools (31361)
- commons-imaging (31241)
- geojson (388047)
- mirrored_download (31294)
- routes (31241)
- traffic (388047)
- utilsplugin2 (31463)

Last errors/warnings:
- E: Failed to locate image 'images/geojson.png'
- E: Failed to locate image 'images/graph.png'
- E: Failed to locate image 'images/traffic.png'
- E: java.lang.NullPointerException
- E: java.util.concurrent.RejectedExecutionException: Task Thread[Thread-3326,5,main] rejected from java.util.concurrent.ThreadPoolExecutor@6982915b[Shutting down, pool size = 3, active threads = 3, queued tasks = 2, completed tasks = 19]

java.util.concurrent.RejectedExecutionException: Task Thread[Thread-3326,5,main] rejected from java.util.concurrent.ThreadPoolExecutor@6982915b[Shutting down, pool size = 3, active threads = 3, queued tasks = 2, completed tasks = 19]
	at java.util.concurrent.ThreadPoolExecutor$AbortPolicy.rejectedExecution(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.reject(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.execute(Unknown Source)
	at org.openstreetmap.josm.plugins.mapillary.io.download.MapillarySquareDownloadManagerThread.completeImages(MapillarySquareDownloadManagerThread.java:126)
	at org.openstreetmap.josm.plugins.mapillary.io.download.MapillarySquareDownloadManagerThread.run(MapillarySquareDownloadManagerThread.java:83)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (11)

comment:1 Changed 6 years ago by simon04

Component: CorePlugin mapillary
Owner: changed from team to nokutu

comment:2 Changed 5 years ago by Don-vip

Summary: mapillary errorRejectedExecutionException in MapillarySquareDownloadManagerThread

comment:3 Changed 5 years ago by Don-vip

Ticket #13393 has been marked as a duplicate of this ticket.

comment:4 Changed 5 years ago by Don-vip

Ticket #13917 has been marked as a duplicate of this ticket.

comment:5 Changed 5 years ago by Don-vip

Priority: normalmajor

comment:6 Changed 5 years ago by wiktorn

Interesting is, that the pool is shutting down and that's why it's rejecting new jobs.

At first I thought that just setting ThreadPoolExecutor.DiscardOldestPolicy might do the job, but this might need a more thorough investigation.

comment:7 Changed 5 years ago by Don-vip

Owner: changed from nokutu to floscher

comment:8 Changed 5 years ago by Don-vip

I have created a PR to fix this issue: https://github.com/JOSM/Mapillary/pull/39

I have opted for ThreadPoolExecutor.DiscardPolicy.

comment:9 Changed 5 years ago by Don-vip

Owner: changed from floscher to Don-vip
Status: newassigned

PR merged.

comment:10 Changed 5 years ago by Don-vip

Resolution: fixed
Status: assignedclosed

comment:11 Changed 5 years ago by Don-vip

Ticket #14491 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.