Modify

Opened 6 years ago

Closed 2 years ago

#11763 closed defect (duplicate)

Changeset upload says Placeholder node not found for reference in way

Reported by: A_Pirard Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: upload-api-response Cc:

Description

While trying to upload changeset 33193763, I met this message:
Error message(untranslated): Placeholder node not found for reference -13644 in way 48378769
As it's difficult to debug this from within JOSM, I saved the *.osm file and looked for that -13644.
I found it twice in updates to two landuse=forest ways.
I swear I did not update landuses, but I can't tell if one was attached to something like a way I touched up as it is their pesting habit.
Anyway, it's not a reason for a dangling ref.
I edited out those 2 ways updates, I attached them to this ticket, I reloaded the purged *.osm file and then the changeset uploaded correctly.

I'm keeping that osm file on my system for some time should you want it.

Hoping this can help.

André.

I'm sorry I couldn't include the "Status report" because of repeated "The connection to the server was reset while the page was loading." I don't think it's important but I can try again if you ask.
This is 8491 with my usual plugins.

Attachments (1)

removed ways.txt (26.3 KB) - added by A_Pirard 6 years ago.

Download all attachments as: .zip

Change History (3)

Changed 6 years ago by A_Pirard

Attachment: removed ways.txt added

comment:1 Changed 6 years ago by simon04

Keywords: upload-api-response added

comment:2 Changed 2 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #17217.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.