Modify

Opened 7 years ago

Closed 13 months ago

Last modified 12 months ago

#11710 closed enhancement (fixed)

[Patch] Re-geotagging hides pictures that are not covered by gpx track

Reported by: skorbut Owned by: Bjoeni
Priority: normal Milestone: 21.05
Component: Core image mapping Version:
Keywords: Cc:

Description

There is a somewhat special condition where JOSM/the photo geotagging plugin doesn't behave ideally:

  • Load some geotagged images in JOSM
  • Try to correlate those images using a gpx track which only covers some, but not all of the images (use the option 'Override position for images with geo location in exif data', otherwise the images wont be repositioned)
  • Images that were not covered by the gpx track disappear, although they still have the original geotagging.
  • (Writing the coordinates to the files that are covered by the gpx track and reloading all images into JOSM displays everything again in correct fashion. So the situation is not too bad...)

This happened to me in the following situation: I have a camera with an integrated, rather low-quality GPS. To improve the accuracy I also have an external logger whose gpx track is of better quality and that I want to use as a primary source of geotagging. When the battery of the external logger was exhausted, the camera still recorded the (low-quality) position that I would prefer to use if the alternative was to discard the image completely.

Attachments (2)

11710-V2.patch (7.9 KB) - added by Bjoeni 13 months ago.
11710-V3.patch (22.1 KB) - added by Bjoeni 13 months ago.

Download all attachments as: .zip

Change History (16)

comment:1 Changed 4 years ago by Don-vip

Owner: changed from bastiK to team

comment:2 Changed 13 months ago by Bjoeni

Component: Plugin photo_geotaggingCore image mapping
Owner: changed from team to Bjoeni

comment:3 Changed 13 months ago by Bjoeni

Summary: Re-geotagging hides pictures that are not covered by gpx track[Patch] Re-geotagging hides pictures that are not covered by gpx track

Prevent removal of geotags from files that weren't matched to the track:

-- see new patch below --

See also the changes from #16681 allowing the user to determine what images should be matched.

Last edited 13 months ago by Bjoeni (previous) (diff)

comment:4 Changed 13 months ago by simon04

Milestone: 21.05

comment:5 Changed 13 months ago by Bjoeni

Ticket #11015 has been marked as a duplicate of this ticket.

comment:6 Changed 13 months ago by Bjoeni

@Simon (or someone else)
could you please commit this patch in the near future? #20795 depends on it (or it would at least conflict, so it's easier when this one is committed before I provide a patch for the other one)

comment:7 Changed 13 months ago by simon04

This patch breaks the unit test org.openstreetmap.josm.data.gpx.GpxImageCorrelationTest#testMatchGpxTrack

comment:8 Changed 13 months ago by Bjoeni

That's interesting, I thought I checked that. I'll have a look.

comment:9 Changed 13 months ago by Bjoeni

Fixed that (note to self: shouldn't change a patch after running the tests...). Sorry about that.

I also added another ImageEntry i7 to testMatchGpxTrack (testing the changes of this ticket).

Changed 13 months ago by Bjoeni

Attachment: 11710-V2.patch added

comment:10 Changed 13 months ago by Bjoeni

Btw. I just noticed that checkstyle complains that the testMatchGpxTrack() method is now too long (157 executable statements). I'll change that.

Changed 13 months ago by Bjoeni

Attachment: 11710-V3.patch added

comment:11 Changed 13 months ago by Bjoeni

Restructured GpxImageCorrelationTest into separate methods

comment:12 Changed 13 months ago by simon04

Resolution: fixed
Status: newclosed

In 17878/josm:

fix #11710 - Re-geotagging hides pictures that are not covered by GPX track (patch by Bjoeni)

comment:13 Changed 13 months ago by simon04

Thank you!

comment:14 Changed 12 months ago by simon04

In 17882/josm:

see #11710 - Fix MethodOrderer deprecation

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Bjoeni.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.