Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11681 closed defect (fixed)

josm bleibt beim starten hängen (Bildeinstellungen werden geladen)

Reported by: lutz Owned by: team
Priority: normal Milestone: 15.08
Component: Core Version:
Keywords: template_report npe Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-07-10 01:32:05
Last Changed Author: Don-vip
Revision: 8590
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-07-10 00:05:33 +0200 (Fri, 10 Jul 2015)
Last Changed Rev: 8590

Identification: JOSM/1.5 (8590 de) Linux openSUSE 13.1 (Bottle) (x86_64)
Memory Usage: 480 MB / 2311 MB (263 MB allocated, but free)
Java version: 1.7.0_55, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: java-1_7_0-openjdk:x86_64-1.7.0.55

Plugins:
- AddrInterpolation
- CommandLine
- DirectDownload
- FastDraw
- FixAddresses
- HouseNumberTaggingTool
- ImageWayPoint
- ImageryCache
- ImportImagePlugin
- InfoMode
- OpeningHoursEditor
- PicLayer
- RoadSigns
- SimplifyArea
- TombPlugin
- buildings_tools
- colorscheme
- commons-imaging
- contourmerge
- dataimport
- download_along
- editgpx
- ext_tools
- geochat
- geotools
- gpxfilter
- graphview
- imagery-xml-bounds
- importvec
- jts
- junctionchecking
- lakewalker
- log4j (31231)
- measurement
- merge-overlap
- mirrored_download
- namemanager
- openvisible
- pbf
- pdfimport
- photo_geotagging
- photoadjust
- poly
- print
- proj4j (31353)
- public_transport
- reltoolbox
- reverter
- surveyor2
- tag2link
- tageditor
- tagging-preset-tester
- terracer
- todo
- turnlanes
- utilsplugin2
- walkingpapers
- waydownloader
- wikipedia

Last errors/warnings:
- E: Fehler beim Laden des Bildes 'presets/recycling.png'
- W: Could not get presets icon presets/recycling.png
- E: Fehler beim Laden des Bildes 'presets/water_tower.png'
- W: Could not get presets icon presets/water_tower.png
- E: java.lang.RuntimeException: java.util.concurrent.ExecutionException: java.lang.NullPointerException. Ursache: java.util.concurrent.ExecutionException: java.lang.NullPointerException. Ursache: java.lang.NullPointerException

java.lang.RuntimeException: java.util.concurrent.ExecutionException: java.lang.NullPointerException
	at org.openstreetmap.josm.Main.<init>(Main.java:632)
	at org.openstreetmap.josm.gui.MainApplication.<init>(MainApplication.java:91)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:456)
Caused by: java.util.concurrent.ExecutionException: java.lang.NullPointerException
	at java.util.concurrent.FutureTask.report(FutureTask.java:122)
	at java.util.concurrent.FutureTask.get(FutureTask.java:188)
	at org.openstreetmap.josm.Main.<init>(Main.java:629)
	... 2 more
Caused by: java.lang.NullPointerException
	at org.openstreetmap.josm.gui.tagging.TaggingPresets.initialize(TaggingPresets.java:64)
	at org.openstreetmap.josm.Main$5.initialize(Main.java:606)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:707)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:691)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:745)

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by Don-vip

Keywords: npe added
Milestone: 15.07

comment:2 Changed 6 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 8595/josm:

fix #11681 - NPE in tagging presets initialization

comment:3 Changed 6 years ago by Don-vip

Milestone: 15.0715.08

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.