Modify

Opened 9 years ago

Closed 8 months ago

#11670 closed enhancement (duplicate)

Warn on moving objects by over 1km

Reported by: planemad Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Select a node on a way or a small way
  2. Zoom out and move the object

What is the expected result?

Have a popup confirmation warning "You have moved an object by more than 1km and this is often an error. Really move them?"

What happens instead?

No warning is triggered causing an accidental change

Please provide any additional information below. Attach a screenshot if possible.

When is moving nodes by a large distance ok?

  • When the node is isolated and not connected to anything else
  • Ways not connected to any other objects, like moving a lake or building

In both cases it is still desirable to have a warning. I an't think of a legitimate reason to move objects by such a large distance except to undo such a change by someone else.

Revision: 8491
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: Don-vip
Last Changed Date: 2015-06-16 23:27:08 +0200 (Tue, 16 Jun 2015)
Build-Date: 2015-06-16 21:45:58
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8491

Identification: JOSM/1.5 (8491 en) Mac OS X 10.10.3
Memory Usage: 759 MB / 1820 MB (121 MB allocated, but free)
Java version: 1.8.0_45, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Djava.security.policy=file:/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/lib/security/javaws.policy, -DtrustProxy=true, -Djnlpx.home=<java.home>/bin, -Djava.security.manager, -Djnlpx.origFilenameArg=/Users/arun/Library/Application Support/Oracle/Java/Deployment/cache/6.0/56/1ee8cfb8-1b8e9edd, -Djnlpx.remove=false, -Dsun.awt.warmup=true, -Djava.util.Arrays.useLegacyMergeSort=true, -Dmacosx.jnlpx.dock.name=JOSM, -Dmacosx.jnlpx.dock.icon=/Users/arun/Library/Application Support/Oracle/Java/Deployment/cache/6.0/16/47ee53d0-70f4e903.icns, -Djnlp.application.href=https://josm.openstreetmap.de/download/josm.jnlp , -Djnlpx.jvm="/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java", -Djnlpx.vmargs=LURqYXZhLnV0aWwuQXJyYXlzLnVzZUxlZ2FjeU1lcmdlU29ydD10cnVlAC1Eam5scC5hcHBsaWNhdGlvbi5ocmVmPWh0dHBzOi8vam9zbS5vcGVuc3RyZWV0bWFwLmRlL2Rvd25sb2FkL2pvc20uam5scCAA]
Dataset consistency test: No problems found

Plugins:
- FastDraw (31265)
- PicLayer (31241)
- ShapeTools (1000)
- buildings_tools (31241)
- dataimport (31241)
- ext_tools (31241)
- geochat (31241)
- geotools (31126)
- jts (31126)
- lakewalker (31241)
- log4j (31231)
- opendata (31241)
- public_transport (31241)
- reltoolbox (31241)
- reverter (31241)
- scripting (30710)
- tofix (1435963699)
- undelete (31241)
- utilsplugin2 (31241)
- wikipedia (31241)

Last errors/warnings:
- W: PluginException: Invalid jar file '/Users/arun/Library/JOSM/plugins/imagery_offset_db.jar.new'
- W: Failed to scan file 'imagery_offset_db.jar.new' for plugin information. Skipping.
- W: Failed to install plugin '/Users/arun/Library/JOSM/plugins/imagery_offset_db.jar' from temporary download file '/Users/arun/Library/JOSM/plugins/imagery_offset_db.jar.new'. error in opening zip file

Attachments (0)

Change History (1)

comment:1 by taylor.smock, 8 months ago

Resolution: duplicate
Status: newclosed

Closed as duplicate of #20899.
r18274 (#20899) didn't just affect Improve Way Accuracy; it also affected accidental drags.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.