Modify

Opened 6 years ago

Closed 6 years ago

#11661 closed defect (duplicate)

Exception occurs while trying to save relation

Reported by: onehalf3544@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

Steps to reproduce:
edit relation 5340850
add any key=value
press 'Ok'

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-07-05 01:33:16
Last Changed Author: Don-vip
Revision: 8571
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-07-05 02:55:10 +0200 (Sun, 05 Jul 2015)
Last Changed Rev: 8571

Identification: JOSM/1.5 (8571 en) Linux Debian GNU/Linux testing (wheezy)
Memory Usage: 305 MB / 882 MB (80 MB allocated, but free)
Java version: 1.7.0_75, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u75-2.5.4-2
VM arguments: [-Djava.net.preferIPv4Stack=true, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
- CommandLine (31241)
- FastDraw (31265)
- InfoMode (31241)
- PicLayer (31241)
- buildings_tools (31241)
- editgpx (31241)
- log4j (31231)
- reverter (31241)
- routing (31241)
- tageditor (31241)
- undelete (31241)

Last errors/warnings:
- E: java.lang.UnsupportedOperationException

java.lang.UnsupportedOperationException
	at java.util.Collections$1.remove(Collections.java:3313)
	at java.util.AbstractCollection.clear(AbstractCollection.java:432)
	at java.util.AbstractMap.clear(AbstractMap.java:288)
	at org.openstreetmap.josm.gui.tagging.TagEditorModel.applyToTags(TagEditorModel.java:421)
	at org.openstreetmap.josm.gui.tagging.TagEditorModel.applyToPrimitive(TagEditorModel.java:410)
	at org.openstreetmap.josm.gui.dialogs.relation.GenericRelationEditor$SavingAction.applyExistingNonConflictingRelation(GenericRelationEditor.java:1310)
	at org.openstreetmap.josm.gui.dialogs.relation.GenericRelationEditor$OKAction.run(GenericRelationEditor.java:1425)
	at org.openstreetmap.josm.gui.dialogs.relation.GenericRelationEditor$OKAction.actionPerformed(GenericRelationEditor.java:1433)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2018)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2341)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:252)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6516)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3312)
	at java.awt.Component.processEvent(Component.java:6281)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4872)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4492)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:740)
	at java.awt.EventQueue.access$300(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:699)
	at java.awt.EventQueue$3.run(EventQueue.java:697)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:713)
	at java.awt.EventQueue$4.run(EventQueue.java:711)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:710)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #11664.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.