Modify

Opened 6 years ago

Closed 6 years ago

#11659 closed defect (duplicate)

adding members to relation in the relation editor fails

Reported by: Polyglot Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

I tried to be thorough explaining, but the 4 first buttons to add members always produce an error.

I work with data downloaded form Overpass API (all PT related objects for Belgium)

  1. https://www.openstreetmap.org/relation/3902147 (it fails with all other relations as well)
  2. open it in relation editor
  3. select all the stops, which are now after the ways, the way I liked it before
  4. Press Select objects for selected relation members button
  5. Remove currently selected members from relation (not necessary to produce the bug)
  6. Add all objects selected in the current dataset before first member (same difference with other buttons to add members)

I can still use "Move the selected members down" Alt-down

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-07-05 01:33:16
Last Changed Author: Don-vip
Revision: 8571
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-07-05 02:55:10 +0200 (Sun, 05 Jul 2015)
Last Changed Rev: 8571

Identification: JOSM/1.5 (8571 en) Windows 7 64-Bit
Memory Usage: 758 MB / 1111 MB (293 MB allocated, but free)
Java version: 1.7.0_40, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- AddrInterpolation (31241)
- ImportImagePlugin (31241)
- Mapillary (31326)
- OpeningHoursEditor (31241)
- PicLayer (31241)
- RoadSigns (31241)
- TombPlugin (44)
- alignways (31241)
- buildings_tools (31241)
- commons-imaging (31241)
- contourmerge (1013)
- dataimport (31241)
- fieldpapers (v0.3.0)
- geochat (31241)
- geotools (31126)
- importvec (31241)
- jna (31126)
- jts (31126)
- livegps (31241)
- log4j (31231)
- mapdust (31241)
- measurement (31289)
- mirrored_download (31294)
- opendata (31241)
- pdfimport (31241)
- photo_geotagging (31241)
- photoadjust (31241)
- public_transport (31241)
- reverter (31241)
- scripting (30710)
- tag2link (31241)
- terracer (31241)
- todo (29154)
- turnrestrictions (31241)
- undelete (31241)
- utilsplugin2 (31241)
- walkingpapers (31241)
- wikipedia (31241)

Last errors/warnings:
- W: Could not get presets icon presets/crossing.png
- E: Failed to locate image 'presets/crossing.png'
- W: Could not get presets icon presets/crossing.png
- E: Unable to load module icon: images/be24.png
- E: java.lang.UnsupportedOperationException

java.lang.UnsupportedOperationException
	at java.util.AbstractMap.put(Unknown Source)
	at org.openstreetmap.josm.gui.tagging.TagEditorModel.applyToTags(TagEditorModel.java:434)
	at org.openstreetmap.josm.gui.tagging.TagEditorModel.applyToPrimitive(TagEditorModel.java:410)
	at org.openstreetmap.josm.gui.dialogs.relation.GenericRelationEditor$1.getSelection(GenericRelationEditor.java:149)
	at org.openstreetmap.josm.gui.dialogs.relation.MemberTableModel.addMembersAtIndex(MemberTableModel.java:413)
	at org.openstreetmap.josm.gui.dialogs.relation.MemberTableModel.addMembersAtBeginning(MemberTableModel.java:438)
	at org.openstreetmap.josm.gui.dialogs.relation.GenericRelationEditor$AddSelectedAtStartAction.actionPerformed(GenericRelationEditor.java:844)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$200(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (6)

comment:1 Changed 6 years ago by Polyglot

When removing a member from a relation from the Tags pane, then performing undo still works. Also the Python script I use can still add ways to the relations

comment:2 Changed 6 years ago by Polyglot

paste relations from utilsplugin2 also still works, but it doesn't add ways twice.

comment:3 Changed 6 years ago by Polyglot

8574 has the same problem.

comment:4 Changed 6 years ago by Polyglot

Oddly adding ways to a brand new relation does work. But then the error occurs when pressing OK.

comment:5 Changed 6 years ago by Polyglot

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-07-07 01:32:22
Last Changed Author: wiktorn
Revision: 8576
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-07-06 20:12:05 +0200 (Mon, 06 Jul 2015)
Last Changed Rev: 8576

Identification: JOSM/1.5 (8576 en) Windows 7 64-Bit
Memory Usage: 781 MB / 1111 MB (398 MB allocated, but free)
Java version: 1.7.0_40, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- AddrInterpolation (31241)
- ImportImagePlugin (31241)
- Mapillary (31326)
- OpeningHoursEditor (31241)
- PicLayer (31241)
- RoadSigns (31241)
- TombPlugin (44)
- alignways (31241)
- buildings_tools (31241)
- commons-imaging (31241)
- contourmerge (1013)
- dataimport (31241)
- fieldpapers (v0.3.0)
- geochat (31241)
- geotools (31126)
- importvec (31241)
- jna (31126)
- jts (31126)
- livegps (31241)
- log4j (31231)
- mapdust (31241)
- measurement (31289)
- mirrored_download (31294)
- opendata (31241)
- pdfimport (31241)
- photo_geotagging (31241)
- photoadjust (31241)
- public_transport (31241)
- reverter (31241)
- scripting (30710)
- tag2link (31241)
- terracer (31241)
- todo (29154)
- turnrestrictions (31241)
- undelete (31241)
- utilsplugin2 (31241)
- walkingpapers (31241)
- wikipedia (31241)

Last errors/warnings:
- E: Failed to locate image 'presets/crossing.png'
- W: Could not get presets icon presets/crossing.png
- E: Unable to load module icon: images/be24.png
- E: java.lang.UnsupportedOperationException
- E: java.lang.UnsupportedOperationException

java.lang.UnsupportedOperationException
	at java.util.AbstractMap.put(Unknown Source)
	at org.openstreetmap.josm.gui.tagging.TagEditorModel.applyToTags(TagEditorModel.java:434)
	at org.openstreetmap.josm.gui.tagging.TagEditorModel.applyToPrimitive(TagEditorModel.java:410)
	at org.openstreetmap.josm.gui.dialogs.relation.GenericRelationEditor$1.getSelection(GenericRelationEditor.java:149)
	at org.openstreetmap.josm.gui.dialogs.relation.MemberTableModel.addMembersAtIndex(MemberTableModel.java:413)
	at org.openstreetmap.josm.gui.dialogs.relation.MemberTableModel.addMembersBeforeIdx(MemberTableModel.java:446)
	at org.openstreetmap.josm.gui.dialogs.relation.GenericRelationEditor$AddSelectedBeforeSelection.actionPerformed(GenericRelationEditor.java:909)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$200(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

comment:6 Changed 6 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #11664.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.