Modify

Opened 11 years ago

Closed 11 years ago

#1163 closed defect (wontfix)

Exception on startup

Reported by: arj@… Owned by: framm
Priority: major Milestone:
Component: Core Version:
Keywords: Cc:

Description

This happens when attempting to run the version of josm currently in the Ubuntu universe repositories. apt-cache states that the version is 0.0.0.20080330-1 (/var/lib/apt/lists/no.archive.ubuntu.com_ubuntu_dists_hardy_universe_binary-i386_Packages) (/var/lib/dpkg/status).

arj@gavagai:~$ java --version
java version "1.5.0"
gij (GNU libgcj) version 4.2.3 (Ubuntu 4.2.3-2ubuntu6)

Copyright (C) 2007 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
arj@gavagai:~$ josm
Using /usr/bin/gij-4.1 to execute josm.
Exception in thread "main" java.awt.AWTError: Cannot load AWT toolkit: gnu.java.awt.peer.gtk.GtkToolkit

at java.awt.Toolkit.getDefaultToolkit(libgcj.so.71)
at javax.swing.plaf.basic.BasicLookAndFeel.initialize(libgcj.so.71)
at javax.swing.UIManager.setLookAndFeel(libgcj.so.71)
at javax.swing.UIManager.<clinit>(libgcj.so.71)
at java.lang.Class.initializeClass(libgcj.so.71)
at javax.swing.UIManager.getUI(libgcj.so.71)
at javax.swing.JLabel.updateUI(libgcj.so.71)
at javax.swing.JLabel.<init>(libgcj.so.71)
at javax.swing.JLabel.<init>(libgcj.so.71)
at javax.swing.DefaultListCellRenderer.<init>(libgcj.so.71)
at javax.swing.JList.init(libgcj.so.71)
at javax.swing.JList.<init>(libgcj.so.71)
at org.openstreetmap.josm.gui.preferences.ToolbarPreferences.<init>(ToolbarPreferences.java:93)
at org.openstreetmap.josm.Main.<clinit>(Main.java:114)
at java.lang.Class.initializeClass(libgcj.so.71)
at java.lang.Class.initializeClass(libgcj.so.71)

Caused by: java.lang.UnsatisfiedLinkError: libgtkpeer: libgtkpeer.so: cannot open shared object file: No such file or directory

at java.lang.Runtime._load(libgcj.so.71)
at java.lang.Runtime.loadLibrary(libgcj.so.71)
at java.lang.System.loadLibrary(libgcj.so.71)
at gnu.java.awt.peer.gtk.GtkToolkit.<clinit>(libgcj.so.71)
at java.lang.Class.initializeClass(libgcj.so.71)
at java.lang.Class.forName(libgcj.so.71)
at java.awt.Toolkit.getDefaultToolkit(libgcj.so.71)
...15 more

Attachments (0)

Change History (1)

comment:1 Changed 11 years ago by anonymous

Resolution: wontfix
Status: newclosed

Better report this bug in the ubuntu bugtracker. This is some incompatibility in the way josm is started and not in josm itself.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.