Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11608 closed defect (invalid)

manual download mode?

Reported by: malenki Owned by: nokutu
Priority: normal Milestone:
Component: Plugin mapillary Version:
Keywords: Cc:

Description

After reading that there is finally a plugin for Mapillary (thank you very much, nokutu!) I immediately went testing it.
So far so good, but soon I had problems downloading images at all.
After a lot of testing and comparing I found out that somehow this line is written into the preferences.xml avoiding further image downloads:

<tag key='mapillary.download-manually' value='true'/>

I could not find out the trigger adding it to the preferences but it happened always on my usual ~/.josm with 39 plugins and tons of old settings. (The file still contains even OSB stuff.)

When starting JOSM with a blank ~/.josm I couldn't reproduce the line being added to the preferences, but adding it manually stopped the plugin from downloading.

testet with r8520

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by nokutu

Resolution: invalid
Status: newclosed

You can find that setting in the prefferences menu. In the first tab there is a tab called mapillary.

If that value is true, you will have to press a button (File menu) that downloads all the images in the rectangle you are seeing. Otherwise, it will automatically download the images in all the areas where there is OSM data downloaded.

comment:2 Changed 4 years ago by malenki

But it is strange that this setting was in different states although I never touched it. I will keep watching it.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain nokutu.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.