Modify

Opened 7 years ago

Closed 6 years ago

#11523 closed defect (duplicate)

class with parent selector not working

Reported by: naoliv Owned by: team
Priority: normal Milestone:
Component: Core validator Version:
Keywords: mapcss Cc:

Description

Or I need to sleep better or using a class with a parent selector isn't working.
Example:

way[highway] > node { set .is_in_highway; }

node.is_in_highway < area[!highway] {
        throwWarning: tr("you should not attach the area to the highway");
}

This should match areas that share a node with highways.

JOSM

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-06-02 12:06:24
Last Changed Author: Don-vip
Revision: 8441
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-06-02 14:03:31 +0200 (Tue, 02 Jun 2015)
Last Changed Rev: 8441

Identification: JOSM/1.5 (8441 pt_BR) Linux Debian GNU/Linux unstable (sid)
Memory Usage: 487 MB / 4029 MB (241 MB allocated, but free)
Java version: 1.7.0_79, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u79-2.5.5-1
VM arguments: [-Dawt.useSystemAAFontSettings=on]
Dataset consistency test: No problems found

Plugins:
- AddrInterpolation (30892)
- Create_grid_of_ways (30892)
- FastDraw (30892)
- FixAddresses (30892)
- OpeningHoursEditor (30962)
- PicLayer (31114)
- SimplifyArea (30962)
- buildings_tools (31120)
- download_along (30892)
- editgpx (30892)
- geotools (31068)
- graphview (30892)
- jts (31002)
- measurement (30892)
- merge-overlap (30988)
- opendata (31116)
- pdfimport (30892)
- poly (31056)
- reverter (31120)
- tagging-preset-tester (31120)
- todo (29154)
- turnrestrictions (31034)
- undelete (30892)
- utilsplugin2 (31153)

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by naoliv

Complementing. This matches the shared node (but I would like to match the areas instead, like the first MapCSS):

way[highway] > node { set .is_in_highway; }

area[!highway] > node.is_in_highway {
        throwWarning: tr("you should not attach the area to the highway");
}

comment:2 Changed 6 years ago by simon04

Resolution: duplicate
Status: newclosed

Closed as duplicate of #10215.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.