Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11381 closed defect (fixed)

autolanguage does not work . english instead of system language (was: JOSM plötzlich auf Englisch)

Reported by: brogo Owned by: team
Priority: major Milestone: 15.05
Component: Core Version: latest
Keywords: regression i18n Cc: stoecker

Description

Mit JOSM 8287 ist die Spracheinstellung plötzlich von Deutsch auf Englisch umgestellt.

Attachments (0)

Change History (13)

comment:1 Changed 4 years ago by Klumbumbus

Priority: majorminor
Resolution: worksforme
Status: newclosed

Stell sie doch einfach wieder um.

comment:2 Changed 4 years ago by brogo

Wert stand auf "Standard, automatisch". Habe diesen Wert nie geändert.
Manuell auf German gesetzt. -> OK.

Zur Info: Windows 7 Prof. 64 Bit., Java 8

comment:3 Changed 4 years ago by Klumbumbus

Priority: minornormal
Resolution: worksforme
Status: closedreopened
Summary: JOSM plötzlich auf Englischautolanguage does not work . eenglish instead of sytem language (was: JOSM plötzlich auf Englisch)

comment:4 Changed 4 years ago by Klumbumbus

Revision: 8287
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: Don-vip
Last Changed Date: 2015-04-28 01:11:18 +0200 (Tue, 28 Apr 2015)
Build-Date: 2015-04-28 01:31:11
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8287

Identification: JOSM/1.5 (8287 en) Windows 7 32-Bit
Memory Usage: 247 MB / 742 MB (145 MB allocated, but free)
Java version: 1.8.0_45, Oracle Corporation, Java HotSpot(TM) Client VM
VM arguments: [-Djava.security.manager, -Djava.security.policy=file:C:\Program Files\Java\jre1.8.0_45\lib\security\javaws.policy, -DtrustProxy=true, -Djnlpx.home=<java.home>\bin, -Djnlpx.origFilenameArg=C:\Program Files\josm-latest-bla.jnlp, -Djnlpx.remove=false, -Djava.util.Arrays.useLegacyMergeSort=true, -Djnlpx.heapsize=256m,768m, -Djnlpx.splashport=57023, -Djnlpx.jvm=<java.home>\bin\javaw.exe, -Djnlpx.vmargs=LURqYXZhLnV0aWwuQXJyYXlzLnVzZUxlZ2FjeU1lcmdlU29ydD10cnVlAA==]

comment:5 Changed 4 years ago by Klumbumbus

Summary: autolanguage does not work . eenglish instead of sytem language (was: JOSM plötzlich auf Englisch)autolanguage does not work . english instead of system language (was: JOSM plötzlich auf Englisch)

comment:6 Changed 4 years ago by Don-vip

Cc: stoecker added
Keywords: regression i18n added
Milestone: 15.05
Priority: normalmajor

confirmed. Works fine with tested, not with latest ==> regression of r8282:8283?

comment:7 Changed 4 years ago by Don-vip

Messages at startup:

DEBUG: System property 'http.agent' set to 'JOSM/1.5 (8289 SVN en) Windows 7 64-Bit'. Old value was 'null'
DEBUG: System property 'user.language' set to ''. Old value was 'fr'
DEBUG: System property 'jsse.enableSNIExtension' set to 'false'. Old value was 'null'
DEBUG: System property 'http.agent' set to 'JOSM/1.5 (8289 SVN en) Windows 7 64-Bit'. Old value was 'JOSM/1.5 (8289 SVN en) Windows 7 64-Bit'
DEBUG: System property 'user.language' set to ''. Old value was ''

comment:8 Changed 4 years ago by Don-vip

Dirk, why did you remove these lines?

https://josm.openstreetmap.de/changeset/8283/josm/trunk/src/org/openstreetmap/josm/tools/I18n.java

It kills the autodetection feature. On my setup "fr_FR" is the default language, so JOSM does not load "fr" lang file anymore.

comment:9 Changed 4 years ago by stoecker

Because getJOSMLocalCode() should already change that to fr. If not, then somewhere else getJOSMLocaleCode() needs be called. Works for Linux.

comment:10 Changed 4 years ago by stoecker

I can't test here: I think in line 444 the Locale.getDefault().toString() should be a LanguageInfo.getJOSMLocaleCode().

comment:11 Changed 4 years ago by stoecker

Resolution: fixed
Status: reopenedclosed

Fixed In r8292: default language setting failed

Seems I simply did my tests wrong and now I also used wrong ticket id. :-)

comment:12 in reply to:  11 Changed 4 years ago by Don-vip

Replying to stoecker:

now I also used wrong ticket id. :-)

Easy to fix :)

comment:13 Changed 4 years ago by stoecker

In 8292/josm:

fix #11381 - default language setting failed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.