Modify

Opened 6 years ago

Closed 6 years ago

#11378 closed defect (fixed)

Visualization of area style in JOSM 8159

Reported by: irene.pucci@… Owned by: team
Priority: normal Milestone: 15.05
Component: Core mappaint Version: tested
Keywords: template_report Cc:

Description (last modified by Klumbumbus)

What steps will reproduce the problem?

  1. Create a mapcss area rule with 'fill-image'
  2. Visualize it in JOSM

What is the expected result?

The image of the rule 'fill-image' inside the area has a good visualization

What happens instead?

The image of the rule 'fill-image is too small'

Please provide any additional information below. Attach a screenshot if possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-03-30 01:30:55
Last Changed Author: stoecker
Revision: 8159
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-03-29 14:37:50 +0200 (Sun, 29 Mar 2015)
Last Changed Rev: 8159

Identification: JOSM/1.5 (8159 en) Windows 7 64-Bit
Memory Usage: 980 MB / 980 MB (578 MB allocated, but free)
Java version: 1.7.0_75, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Xrunjdwp:transport=dt_socket,address=8787,server=y,suspend=n, -Djava.util.Arrays.useLegacyMergeSort=true]
Dataset consistency test: No problems found

Plugins:
- ImportImagePlugin (${version.entry.commit.revision})
- geotools (31000)
- jts (31002)
- log4j (30892)
- opendata (UNKNOWN)
- utilsplugin2 (30892)

Last errors/warnings:
- W: Could not get presets icon Icons/phot01.png
- E: Failed to locate image 'Icons/nnnnnnn.png'
- W: Could not get presets icon Icons/nnnnnnn.png
- E: Failed to locate image 'Icons/nnnnnnn.png'
- W: Could not get presets icon Icons/nnnnnnn.png

When I try to visualize some icons inside area, their scale does not change and it is not really visible.

Visualization in JOSM 8159

In JOSM 5485 the icons are correctly visualize (look at the attached screenshot).

Visualization in JOSM 5485

The rule is:

relation[type=multipolygon][objcod=RESARE][RESTRN="3"] > way {width: 1; dashes: 6,2; color: red; opacity: 1;}
area[objcod=RESARE][RESTRN="3"] {fill-image: "Icons/REancC.png"; }

Am I doing some type of errors?

Thanks,
Irene

Attachments (2)

mapcss_josm5485.PNG (25.5 KB) - added by irene.pucci@… 6 years ago.
Visualization in JOSM 5485
mapcss_josm8159.PNG (19.6 KB) - added by irene.pucci@… 6 years ago.
Visualization in JOSM 8159

Download all attachments as: .zip

Change History (10)

Changed 6 years ago by irene.pucci@…

Attachment: mapcss_josm5485.PNG added

Visualization in JOSM 5485

Changed 6 years ago by irene.pucci@…

Attachment: mapcss_josm8159.PNG added

Visualization in JOSM 8159

comment:1 Changed 6 years ago by skyper

Description: modified (diff)

comment:2 Changed 6 years ago by Klumbumbus

Yes, I also noticed that. I think it has to do with one of the changesets in #10684.

comment:3 Changed 6 years ago by Klumbumbus

Component: Internal mappaint styleCore mappaint
Description: modified (diff)

comment:4 Changed 6 years ago by stoecker

Can you please provide a full example including style, icon and osm file?

comment:5 in reply to:  2 Changed 6 years ago by bastiK

Replying to Klumbumbus:

I think it has to do with one of the changesets in #10684.

No, it is because of automated rescaling of any images greater than 48x48px in org.openstreetmap.josm.gui.mappaint.MapImage. This is probably not a good idea for fill images, which can be expected to be larger.

comment:6 in reply to:  4 Changed 6 years ago by bastiK

Replying to stoecker:

Can you please provide a full example including style, icon and osm file?

@Irene: Not needed, thanks for reporting the problem!

comment:7 Changed 6 years ago by Don-vip

Milestone: 15.05

comment:8 Changed 6 years ago by bastiK

Resolution: fixed
Status: newclosed

In [8289] - fixed #11378 - mapcss: fill-area rescales image

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.