Modify

Opened 6 years ago

Closed 6 years ago

#11332 closed defect (invalid)

Regression turnrestrictions icons in editor

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Internal mappaint style Version:
Keywords: regression turn restriction icons Cc:

Description

JOSM 8052 introduced a regression regarding the icons which are being displayed in the editor when a turn restriction relation exists. The plugin turnrestrictions comes with the choice to display the icons in the British style (set A) or in the continental European version (set B). But since JOSM 8052 only the british version is being displayed regardless of the plug-in setting.

Attachments (2)

icon_mismatch.jpg (32.5 KB) - added by anonymous 6 years ago.
restriction.png (29.8 KB) - added by Klumbumbus 6 years ago.

Download all attachments as: .zip

Change History (3)

Changed 6 years ago by anonymous

Attachment: icon_mismatch.jpg added

comment:1 Changed 6 years ago by Klumbumbus

Component: CoreInternal mappaint style
Resolution: invalid
Status: newclosed

The setting of the plugin affects only the plugin (its dialogs) and has nothing to do with the map display. The mapdisplay changed because the icons now really display what is tagged. ("not right" is not always the same like "only straightfoward and left"). see #4927.

However you can switch the style for the mappaint in the style settings of the default style:


Changed 6 years ago by Klumbumbus

Attachment: restriction.png added

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.