Modify

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#11297 closed enhancement (fixed)

Validator should ignore artist_name for "alternative name without name" check

Reported by: hno2 Owned by: Klumbumbus
Priority: normal Milestone: 15.05
Component: Core validator Version: latest
Keywords: name, Cc:

Description

Validator should ignore artist_name for the "alternative name without name" check. A lot of artwork don't have an official name, but the artist name is known.

In my opinion old_name should also be ignored for this check since some old objects don't have an official name anymore.


Identification: JOSM/1.5 (8159 de) Mac OS X 10.10.2
Java version: 1.8.0_31, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM

Attachments (0)

Change History (3)

comment:1 in reply to:  description Changed 5 years ago by Klumbumbus

Replying to hno2:

A lot of artwork don't have an official name, but the artist name is known.

Are you sure? I think there are only a handfull of objects, where the artist by design choose to give no name. Otherwise I think the artist always gives the artwork a name. (Maybe it is sometimes not widely known.) We could skip the test if noname=yes is tagged.

In my opinion old_name should also be ignored for this check since some old objects don't have an official name anymore.

old_name is already ignore.

comment:2 Changed 4 years ago by Klumbumbus

Owner: set to Klumbumbus
Resolution: fixed
Status: newclosed

In 8436/josm:

fix #11297 - ignore artist_name and noname=yes for alternitive name without name test

comment:3 Changed 4 years ago by Klumbumbus

Milestone: 15.05

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Klumbumbus.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.