Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11202 closed defect (worksforme)

turnrestrictions plugin bug

Reported by: marcobra.ubuntu@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Open josm

What is the expected result?

no bug report

What happens instead?

report bug request

Please provide any additional information below. Attach a screenshot if possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-03-04 02:30:57
Last Changed Author: Klumbumbus
Revision: 8112
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-03-03 23:35:06 +0100 (Tue, 03 Mar 2015)
Last Changed Rev: 8112

Identification: JOSM/1.5 (8112 it) Linux Ubuntu 14.10
Memory Usage: 223 MB / 455 MB (134 MB allocated, but free)
Java version: 1.7.0_55, Oracle Corporation, Java HotSpot(TM) Server VM
Dataset consistency test: No problems found

Plugins:
- CADTools (1003)
- DxfImport (UNKNOWN)
- FastDraw (30892)
- ImportImagePlugin (30892)
- OpeningHoursEditor (30962)
- PicLayer (30962)
- SimplifyArea (30962)
- buildings_tools (30955)
- continuosDownload (1413902943)
- contourmerge (1012)
- dataimport (30892)
- ext_tools (30892)
- geotools (31000)
- importvec (30892)
- jts (31002)
- log4j (30892)
- opendata (31015)
- pdfimport (30892)
- print (30892)
- proj4j (30892)
- reverter (30990)
- scripting (30702)
- tageditor (30892)
- turnrestrictions (30962)
- undelete (30892)
- utilsplugin2 (31040)

Last errors/warnings:
- W: Ext_Tools warning: can not load file /home/ubuntu/.josm/plugins/ext_tools/tools.cfg
- W: Ext_Tools warning: can not load file /home/ubuntu/.josm/plugins/ext_tools/repo.cfg
- E: org.openstreetmap.josm.plugins.PluginException: È stato generato un errore dall'estensione turnrestrictions. Causa: java.lang.reflect.InvocationTargetException. Causa: java.lang.NoClassDefFoundError: org/openstreetmap/josm/gui/JMultilineLabel. Causa: java.lang.ClassNotFoundException: org.openstreetmap.josm.gui.JMultilineLabel

org.openstreetmap.josm.plugins.PluginException: È stato generato un errore dall'estensione turnrestrictions
	at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:34)
	at org.openstreetmap.josm.Main.setMapFrame(Main.java:506)
	at org.openstreetmap.josm.Main.createMapFrame(Main.java:759)
	at org.openstreetmap.josm.Main.addLayer(Main.java:746)
	at org.openstreetmap.josm.Main.addLayer(Main.java:731)
	at org.openstreetmap.josm.io.OsmImporter$1.run(OsmImporter.java:111)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:312)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:733)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:703)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:154)
	at java.awt.WaitDispatchSupport$2.run(WaitDispatchSupport.java:182)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:221)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.WaitDispatchSupport.enter(WaitDispatchSupport.java:219)
	at java.awt.Dialog.show(Dialog.java:1082)
	at java.awt.Component.show(Component.java:1651)
	at java.awt.Component.setVisible(Component.java:1603)
	at java.awt.Window.setVisible(Window.java:1014)
	at java.awt.Dialog.setVisible(Dialog.java:1005)
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$4.run(PleaseWaitProgressMonitor.java:172)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:312)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:733)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:703)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:30)
	... 40 more
Caused by: java.lang.NoClassDefFoundError: org/openstreetmap/josm/gui/JMultilineLabel
	at org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsInDatasetView.build(TurnRestrictionsInDatasetView.java:27)
	at org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsInDatasetView.<init>(TurnRestrictionsInDatasetView.java:47)
	at org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsListDialog.build(TurnRestrictionsListDialog.java:124)
	at org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsListDialog.<init>(TurnRestrictionsListDialog.java:152)
	at org.openstreetmap.josm.plugins.turnrestrictions.TurnRestrictionsPlugin.mapFrameInitialized(TurnRestrictionsPlugin.java:26)
	... 45 more
Caused by: java.lang.ClassNotFoundException: org.openstreetmap.josm.gui.JMultilineLabel
	at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
	at java.security.AccessController.doPrivileged(Native Method)
...<snip>...

Attachments (0)

Change History (13)

comment:1 Changed 5 years ago by Don-vip

Ticket #11174 has been marked as a duplicate of this ticket.

comment:2 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

Should be fixed in [o31047]. Please reopen if that's not the case.

comment:3 Changed 5 years ago by marcobra.ubuntu@…

update turnrestriction plugin still have ... bug

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-03-02 02:30:58
Last Changed Author: Don-vip
Revision: 8109
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-03-02 00:13:51 +0100 (Mon, 02 Mar 2015)
Last Changed Rev: 8109

Identification: JOSM/1.5 (8109 it) Linux Ubuntu 14.10
Memory Usage: 245 MB / 455 MB (116 MB allocated, but free)
Java version: 1.7.0_75, Oracle Corporation, OpenJDK Server VM
Java package: openjdk-7-jre:i386-7u75-2.5.4-1~utopic1
Dataset consistency test: No problems found

Plugins:
- CADTools (1003)
- FastDraw (30892)
- ImportImagePlugin (30892)
- OpeningHoursEditor (30962)
- PicLayer (30962)
- SimplifyArea (30962)
- buildings_tools (30955)
- continuosDownload (1413902943)
- contourmerge (1012)
- dataimport (30892)
- geotools (31000)
- importvec (30892)
- jts (31002)
- log4j (30892)
- opendata (31050)
- pdfimport (30892)
- print (30892)
- proj4j (30892)
- reverter (30990)
- scripting (30702)
- tageditor (30892)
- turnrestrictions (31034)
- undelete (30892)
- utilsplugin2 (31040)

Last errors/warnings:
- E: org.openstreetmap.josm.plugins.PluginException: È stato generato un errore dall'estensione turnrestrictions. Causa: java.lang.reflect.InvocationTargetException. Causa: java.lang.NoClassDefFoundError: org/openstreetmap/josm/gui/JMultilineLabel. Causa: java.lang.ClassNotFoundException: org.openstreetmap.josm.gui.JMultilineLabel
- E: java.lang.NullPointerException

java.lang.NullPointerException
	at org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsListDialog.showNotify(TurnRestrictionsListDialog.java:80)
	at org.openstreetmap.josm.gui.dialogs.ToggleDialog$ToggleDialogAction.actionPerformed(ToggleDialog.java:295)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2018)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2341)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.JToggleButton$ToggleButtonModel.setPressed(JToggleButton.java:308)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:376)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:833)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.menuDragMouseReleased(BasicMenuItemUI.java:943)
	at javax.swing.JMenuItem.fireMenuDragMouseReleased(JMenuItem.java:585)
	at javax.swing.JMenuItem.processMenuDragMouseEvent(JMenuItem.java:482)
	at javax.swing.JMenuItem.processMouseEvent(JMenuItem.java:428)
	at javax.swing.MenuSelectionManager.processMouseEvent(MenuSelectionManager.java:321)
	at javax.swing.plaf.basic.BasicPopupMenuUI$MouseGrabber.eventDispatched(BasicPopupMenuUI.java:859)
	at java.awt.Toolkit$SelectiveAWTEventListener.eventDispatched(Toolkit.java:2448)
	at java.awt.Toolkit$ToolkitEventMulticaster.eventDispatched(Toolkit.java:2340)
	at java.awt.Toolkit.notifyAWTEventListeners(Toolkit.java:2298)
	at java.awt.Component.dispatchEventImpl(Component.java:4768)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4492)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:740)
	at java.awt.EventQueue.access$300(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:699)
	at java.awt.EventQueue$3.run(EventQueue.java:697)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:713)
	at java.awt.EventQueue$4.run(EventQueue.java:711)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:710)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

comment:4 Changed 5 years ago by stoecker

Resolution: fixed
Status: closedreopened

comment:5 in reply to:  3 Changed 5 years ago by skyper

Replying to marcobra.ubuntu@…:

update turnrestriction plugin still have ... bug

...
- turnrestrictions (31034)
...

Should be 31047, please, update again.

comment:6 Changed 5 years ago by anonymous

FyI... Cannot get any update of plugin higher than 31034 on josm i have plugin auto update set on 1 days...

Also manually do not get any update of turnrestrictions plugin

Same issue on two different working system, on different place/networks

Thank

comment:7 Changed 5 years ago by stoecker

turnrestrictions is [o31034]. [o31047] is only the jar file checkin.

comment:8 Changed 5 years ago by baloo@…

Revision: 8139
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: Klumbumbus
Last Changed Date: 2015-03-15 00:00:47 +0100 (Sun, 15 Mar 2015)
Build-Date: 2015-03-15 02:31:56
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8139

Identification: JOSM/1.5 (8139 en) Linux Debian GNU/Linux 8.0 (jessie)
Memory Usage: 650 MB / 1643 MB (273 MB allocated, but free)
Java version: 1.8.0_31, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Djava.security.policy=file:/usr/lib/jvm/jdk-8-oracle-x64/jre/lib/security/javaws.policy, -DtrustProxy=true, -Djnlpx.home=<java.home>/bin, -Djava.security.manager, -Djnlpx.origFilenameArg=/home/baloo/.java/deployment/cache/6.0/31/583aa85f-440aca50, -Djnlpx.remove=false, -Dsun.awt.warmup=true, -Djava.util.Arrays.useLegacyMergeSort=true, -Djnlpx.splashport=33258, -Djnlp.application.href=https://josm.openstreetmap.de/download/josm-latest.jnlp, -Djnlpx.jvm=<java.home>/bin/java, -Djnlpx.vmargs=LURqYXZhLnV0aWwuQXJyYXlzLnVzZUxlZ2FjeU1lcmdlU29ydD10cnVlAC1Eam5scC5hcHBsaWNhdGlvbi5ocmVmPWh0dHBzOi8vam9zbS5vcGVuc3RyZWV0bWFwLmRlL2Rvd25sb2FkL2pvc20tbGF0ZXN0LmpubHAA]
Program arguments: [--debug]

Plugins:
- AddrInterpolation (30892)
- CADTools (1003)
- CommandLine (30892)
- ContourOverlappingMerge (1000)
- Create_grid_of_ways (30892)
- DirectDownload (30892)
- DirectUpload (30892)
- FixAddresses (30892)
- ImageryCache (30892)
- LaneConnector (UNKNOWN)
- OpeningHoursEditor (30962)
- RoadSigns (30977)
- alignways (30892)
- areaselector (1423773025)
- conflation (0.1.7)
- continuosDownload (1413902943)
- contourmerge (1012)
- download_along (30892)
- geochat (31056)
- geotools (31000)
- imagery_offset_db (31056)
- imageryadjust (30892)
- jts (31002)
- log4j (30892)
- mirrored_download (30962)
- opendata (31050)
- pdfimport (30892)
- public_transport (30892)
- reltoolbox (31056)
- reverter (30990)
- turnlanes (30892)
- turnrestrictions (31034)
- undelete (30892)
- utilsplugin2 (31040)
- waydownloader (30892)
- waypoint_search (30892)

Last errors/warnings:
- E: Failed to locate image 'road.png'
- W: Could not get presets icon road.png
- E: Failed to locate image 'ES_s22.png'
- W: Could not get presets icon ES_s22.png
- E: org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin turnrestrictions. Cause: java.lang.reflect.InvocationTargetException. Cause: java.lang.NoClassDefFoundError: org/openstreetmap/josm/gui/JMultilineLabel. Cause: java.lang.ClassNotFoundException: org.openstreetmap.josm.gui.JMultilineLabel

org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin turnrestrictions
	at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:34)
	at org.openstreetmap.josm.Main.setMapFrame(Main.java:506)
	at org.openstreetmap.josm.Main.createMapFrame(Main.java:759)
	at org.openstreetmap.josm.Main.addLayer(Main.java:746)
	at org.openstreetmap.josm.Main.addLayer(Main.java:731)
	at org.openstreetmap.josm.Main.addLayer(Main.java:718)
	at org.openstreetmap.josm.actions.AddImageryLayerAction.actionPerformed(AddImageryLayerAction.java:82)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2022)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2346)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:376)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:833)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.menuDragMouseReleased(BasicMenuItemUI.java:943)
	at javax.swing.JMenuItem.fireMenuDragMouseReleased(JMenuItem.java:586)
	at javax.swing.JMenuItem.processMenuDragMouseEvent(JMenuItem.java:483)
	at javax.swing.JMenuItem.processMouseEvent(JMenuItem.java:429)
	at javax.swing.MenuSelectionManager.processMouseEvent(MenuSelectionManager.java:329)
	at javax.swing.plaf.basic.BasicPopupMenuUI$MouseGrabber.eventDispatched(BasicPopupMenuUI.java:870)
	at java.awt.Toolkit$SelectiveAWTEventListener.eventDispatched(Toolkit.java:2425)
	at java.awt.Toolkit$ToolkitEventMulticaster.eventDispatched(Toolkit.java:2317)
	at java.awt.Toolkit.notifyAWTEventListeners(Toolkit.java:2275)
	at java.awt.Component.dispatchEventImpl(Component.java:4777)
	at java.awt.Container.dispatchEventImpl(Container.java:2292)
	at java.awt.Component.dispatchEvent(Component.java:4703)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4898)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4533)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4462)
	at java.awt.Container.dispatchEventImpl(Container.java:2278)
	at java.awt.Window.dispatchEventImpl(Window.java:2739)
	at java.awt.Component.dispatchEvent(Component.java:4703)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:751)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:702)
	at java.awt.EventQueue$3.run(EventQueue.java:696)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:75)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:86)
	at java.awt.EventQueue$4.run(EventQueue.java:724)
	at java.awt.EventQueue$4.run(EventQueue.java:722)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:75)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:721)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:483)
	at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:30)
	... 48 more
Caused by: java.lang.NoClassDefFoundError: org/openstreetmap/josm/gui/JMultilineLabel
	at org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsInDatasetView.build(TurnRestrictionsInDatasetView.java:27)
	at org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsInDatasetView.<init>(TurnRestrictionsInDatasetView.java:47)
	at org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsListDialog.build(TurnRestrictionsListDialog.java:124)
	at org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsListDialog.<init>(TurnRestrictionsListDialog.java:152)
	at org.openstreetmap.josm.plugins.turnrestrictions.TurnRestrictionsPlugin.mapFrameInitialized(TurnRestrictionsPlugin.java:26)
	... 53 more
Caused by: java.lang.ClassNotFoundException: org.openstreetmap.josm.gui.JMultilineLabel
	at java.net.URLClassLoader$1.run(URLClassLoader.java:372)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:361)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:360)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	... 58 more

comment:9 Changed 5 years ago by anonymous

Yes i confirm the bug is still here...

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-03-16 02:31:20
Last Changed Author: bastiK
Revision: 8141
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-03-15 19:19:06 +0100 (Sun, 15 Mar 2015)
Last Changed Rev: 8141

Identification: JOSM/1.5 (8141 it) Linux Ubuntu 14.04.2 LTS
Memory Usage: 399 MB / 931 MB (152 MB allocated, but free)
Java version: 1.7.0_75, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u75-2.5.4-1~trusty1
Dataset consistency test: No problems found

Plugins:
- AddrInterpolation (30892)
- CADTools (1003)
- ContourOverlappingMerge (1000)
- DxfImport (UNKNOWN)
- FastDraw (30892)
- ImportImagePlugin (30892)
- OpeningHoursEditor (30962)
- PicLayer (30962)
- Remove.redundant.points (1000)
- ShapeTools (1000)
- SimplifyArea (30962)
- alignways (30892)
- areaselector (1423773025)
- buildings_tools (30955)
- contourmerge (1012)
- dataimport (30892)
- download_along (30892)
- geotools (31000)
- jts (31002)
- log4j (30892)
- merge-overlap (30988)
- opendata (31050)
- osmarender (30892)
- pbf (31010)
- pdfimport (30892)
- plastic_laf (30892)
- print (30892)
- proj4j (30892)
- reverter (30990)
- tageditor (30892)
- tagging-preset-tester (30892)
- turnlanes (30892)
- turnrestrictions (31034)
- undelete (30892)
- utilsplugin2 (31040)

Last errors/warnings:
- E: org.openstreetmap.josm.plugins.PluginException: È stato generato un errore dall'estensione turnrestrictions. Causa: java.lang.reflect.InvocationTargetException. Causa: java.lang.NoClassDefFoundError: org/openstreetmap/josm/gui/JMultilineLabel. Causa: java.lang.ClassNotFoundException: org.openstreetmap.josm.gui.JMultilineLabel

org.openstreetmap.josm.plugins.PluginException: È stato generato un errore dall'estensione turnrestrictions
	at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:34)
	at org.openstreetmap.josm.Main.setMapFrame(Main.java:506)
	at org.openstreetmap.josm.Main.createMapFrame(Main.java:759)
	at org.openstreetmap.josm.Main.addLayer(Main.java:746)
	at org.openstreetmap.josm.Main.addLayer(Main.java:731)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$AbstractInternalTask.addNewLayerIfRequired(DownloadOsmTask.java:277)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$AbstractInternalTask.loadData(DownloadOsmTask.java:284)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$DownloadTask.finish(DownloadOsmTask.java:346)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable$1.run(PleaseWaitRunnable.java:101)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:302)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:738)
	at java.awt.EventQueue.access$300(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:699)
	at java.awt.EventQueue$3.run(EventQueue.java:697)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:708)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:154)
	at java.awt.WaitDispatchSupport$2.run(WaitDispatchSupport.java:182)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:221)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.WaitDispatchSupport.enter(WaitDispatchSupport.java:219)
	at java.awt.Dialog.show(Dialog.java:1082)
	at java.awt.Component.show(Component.java:1655)
	at java.awt.Component.setVisible(Component.java:1607)
	at java.awt.Window.setVisible(Window.java:1014)
	at java.awt.Dialog.setVisible(Dialog.java:1005)
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$4.run(PleaseWaitProgressMonitor.java:172)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:312)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:738)
	at java.awt.EventQueue.access$300(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:699)
	at java.awt.EventQueue$3.run(EventQueue.java:697)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:708)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:30)
	... 43 more
Caused by: java.lang.NoClassDefFoundError: org/openstreetmap/josm/gui/JMultilineLabel
	at org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsInDatasetView.build(TurnRestrictionsInDatasetView.java:27)
	at org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsInDatasetView.<init>(TurnRestrictionsInDatasetView.java:47)
	at org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsListDialog.build(TurnRestrictionsListDialog.java:124)
	at org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsListDialog.<init>(TurnRestrictionsListDialog.java:152)
	at org.openstreetmap.josm.plugins.turnrestrictions.TurnRestrictionsPlugin.mapFrameInitialized(TurnRestrictionsPlugin.java:26)
	... 48 more
Caused by: java.lang.ClassNotFoundException: org.openstreetmap.josm.gui.JMultilineLabel
	at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
	... 53 more

comment:10 Changed 5 years ago by anonymous

I did some testing cycles with a fresh profile on a portable installation. The problem lies in a conflict with the plugin ContourOverlappingMerge. Once I disable it, the problem disappears (i.e. turnrestrictions w/o ContourOverlappingMerge works in the latest josm version - ContourOverlappingMerge w/o turnrestrictions works, too). The problem was introduced in version 8005, version 8002 works fine with both plugins enabled.

Revision: 8005
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: Don-vip
Last Changed Date: 2015-02-03 21:53:19 +0100 (Tue, 03 Feb 2015)
Build-Date: 2015-02-04 02:34:57
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8005

Identification: JOSM/1.5 (8005 de) Windows 7 64-Bit
Memory Usage: 86 MB / 247 MB (22 MB allocated, but free)
Java version: 1.8.0_40, Oracle Corporation, Java HotSpot(TM) Client VM
VM arguments: [-Duser.home=E:\PortableApps\JavaPortableLauncher\Data\AppData]

Plugins:
- ContourOverlappingMerge (1000)
- turnrestrictions (30892)

Last errors/warnings:
- E: org.openstreetmap.josm.plugins.PluginException: Ein Fehler ist in dem Plugin turnrestrictions aufgetreten.. Ursache: java.lang.reflect.InvocationTargetException. Ursache: java.lang.NoClassDefFoundError: org/openstreetmap/josm/gui/JMultilineLabel. Ursache: java.lang.ClassNotFoundException: org.openstreetmap.josm.gui.JMultilineLabel

org.openstreetmap.josm.plugins.PluginException: Ein Fehler ist in dem Plugin turnrestrictions aufgetreten.
	at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:34)
	at org.openstreetmap.josm.Main.setMapFrame(Main.java:496)
	at org.openstreetmap.josm.Main.createMapFrame(Main.java:749)
	at org.openstreetmap.josm.Main.addLayer(Main.java:736)
	at org.openstreetmap.josm.Main.addLayer(Main.java:721)
	at org.openstreetmap.josm.Main.addLayer(Main.java:708)
	at org.openstreetmap.josm.actions.AddImageryLayerAction.actionPerformed(AddImageryLayerAction.java:82)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.AbstractButton.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:30)
	... 45 more
Caused by: java.lang.NoClassDefFoundError: org/openstreetmap/josm/gui/JMultilineLabel
	at org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsInDatasetView.build(TurnRestrictionsInDatasetView.java:27)
	at org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsInDatasetView.<init>(TurnRestrictionsInDatasetView.java:47)
	at org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsListDialog.build(TurnRestrictionsListDialog.java:124)
	at org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsListDialog.<init>(TurnRestrictionsListDialog.java:152)
	at org.openstreetmap.josm.plugins.turnrestrictions.TurnRestrictionsPlugin.mapFrameInitialized(TurnRestrictionsPlugin.java:26)
	... 50 more
Caused by: java.lang.ClassNotFoundException: org.openstreetmap.josm.gui.JMultilineLabel
	at java.net.URLClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	... 55 more

comment:11 Changed 5 years ago by anonymous

Ticket #11293 has been marked as a duplicate of this ticket.

comment:12 Changed 5 years ago by stoecker

Resolution: worksforme
Status: reopenedclosed

The recent version for JOSM 8005 is 31034. Update and or reinstall. Ticket 11293 claims to have 31034, but the texts say otherwise. I'd suggest a reinstall as well.

The class org/openstreetmap/josm/gui/JMultilineLabel has been renamed 18 months ago.

comment:13 in reply to:  10 Changed 5 years ago by stoecker

Replying to anonymous:

I did some testing cycles with a fresh profile on a portable installation. The problem lies in a conflict with the plugin ContourOverlappingMerge. Once I disable it, the problem disappears (i.e. turnrestrictions w/o ContourOverlappingMerge works in the latest josm version - ContourOverlappingMerge w/o turnrestrictions works, too). The problem was introduced in version 8005, version 8002 works fine with both plugins enabled.

https://github.com/bularcasergiu/ContourOverlappingMerge/issues/1

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.