Modify

Opened 5 years ago

Closed 5 years ago

#10884 closed defect (fixed)

Crash when I run JOSM without Internet connection

Reported by: anonymous Owned by: team
Priority: normal Milestone: 14.12
Component: Core Version:
Keywords: template_report Cc:

Description

When I run JOSM without Internet connection then it crash.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-12-25 02:35:13
Last Changed Author: Don-vip
Revision: 7881
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-12-24 15:30:06 +0100 (Wed, 24 Dec 2014)
Last Changed Rev: 7881

Identification: JOSM/1.5 (7881 pl) Linux Ubuntu 14.04.1 LTS
Memory Usage: 238 MB / 659 MB (88 MB allocated, but free)
Java version: 1.7.0_65, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u71-2.5.3-0ubuntu0.14.04.1

Plugins:
- CADTools
- OpeningHoursEditor
- PicLayer
- editgpx
- reverter

Last errors/warnings:
- E: java.net.UnknownHostException: josm.openstreetmap.de
- E: Nie udało się zlokalizować obraz 'https://d3nn82uaxijpm6.cloudfront.net/assets/website/mobile/icon-app-81cc8ba60200bed099176eb699e218ab.png'
- E: Nie udało się zlokalizować obraz 'http://wiki.openstreetmap.org/w/images/2/25/Geoportal-josm.png'
- E: java.lang.RuntimeException: java.util.concurrent.ExecutionException: java.lang.IllegalStateException: No file found for something different from a resource: https://raw.githubusercontent.com/rurseekatze/OpenRailwayMap/master/josm-presets/de.xml. Przyczyna: java.util.concurrent.ExecutionException: java.lang.IllegalStateException: No file found for something different from a resource: https://raw.githubusercontent.com/rurseekatze/OpenRailwayMap/master/josm-presets/de.xml. Przyczyna: java.lang.IllegalStateException: No file found for something different from a resource: https://raw.githubusercontent.com/rurseekatze/OpenRailwayMap/master/josm-presets/de.xml
- W: Unable to detect latest version of JOSM: josm.openstreetmap.de

java.lang.RuntimeException: java.util.concurrent.ExecutionException: java.lang.IllegalStateException: No file found for something different from a resource: https://raw.githubusercontent.com/rurseekatze/OpenRailwayMap/master/josm-presets/de.xml
	at org.openstreetmap.josm.Main.<init>(Main.java:612)
	at org.openstreetmap.josm.gui.MainApplication.<init>(MainApplication.java:86)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:427)
Caused by: java.util.concurrent.ExecutionException: java.lang.IllegalStateException: No file found for something different from a resource: https://raw.githubusercontent.com/rurseekatze/OpenRailwayMap/master/josm-presets/de.xml
	at java.util.concurrent.FutureTask.report(FutureTask.java:122)
	at java.util.concurrent.FutureTask.get(FutureTask.java:188)
	at org.openstreetmap.josm.Main.<init>(Main.java:609)
	... 2 more
Caused by: java.lang.IllegalStateException: No file found for something different from a resource: https://raw.githubusercontent.com/rurseekatze/OpenRailwayMap/master/josm-presets/de.xml
	at org.openstreetmap.josm.io.CachedFile.getInputStream(CachedFile.java:181)
	at org.openstreetmap.josm.gui.tagging.TaggingPresetReader.readAll(TaggingPresetReader.java:241)
	at org.openstreetmap.josm.gui.tagging.TaggingPresetReader.readAll(TaggingPresetReader.java:269)
	at org.openstreetmap.josm.gui.tagging.TaggingPresetReader.readFromPreferences(TaggingPresetReader.java:305)
	at org.openstreetmap.josm.gui.tagging.TaggingPresets.readFromPreferences(TaggingPresets.java:36)
	at org.openstreetmap.josm.gui.tagging.TaggingPresets.initialize(TaggingPresets.java:43)
	at org.openstreetmap.josm.Main$3.initialize(Main.java:586)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:686)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:670)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:745)

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by Don-vip

Milestone: 14.12

comment:2 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7890/josm:

fix #10884 - crash at startup (regression from r7853)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.