Modify

Opened 8 years ago

Closed 8 years ago

Last modified 4 years ago

#10839 closed defect (duplicate)

Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader (Ubuntu, 8u40)

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core imagery Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Starting JOSM (v7777 or v7798)
  2. Download OSM data
  3. Enable bing sat images

What is the expected result?

Bing sat images are shown.

What happens instead?

Exception dialog pops up.

Please provide any additional information below. Attach a screenshot if possible.

The problem also occurs in the currently latest version 7798.

Revision: 7777
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: Don-vip
Last Changed Date: 2014-12-09 18:14:49 +0100 (Tue, 09 Dec 2014)
Build-Date: 2014-12-09 17:17:36
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 7777

Identification: JOSM/1.5 (7777 en) Linux Ubuntu 14.10
Memory Usage: 372 MB / 1707 MB (209 MB allocated, but free)
Java version: 1.8.0_40-internal, Oracle Corporation, OpenJDK 64-Bit Server VM
Dataset consistency test: No problems found


Last errors/warnings:
- E: java.lang.NoClassDefFoundError: Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader
- E: java.lang.NoClassDefFoundError: Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader
- E: java.lang.NoClassDefFoundError: Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader
- E: java.lang.NoClassDefFoundError: Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader
- E: java.lang.NoClassDefFoundError: Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader

java.lang.NoClassDefFoundError: Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader
	at com.sun.imageio.plugins.jpeg.JPEGImageReaderSpi.createReaderInstance(JPEGImageReaderSpi.java:85)
	at javax.imageio.spi.ImageReaderSpi.createReaderInstance(ImageReaderSpi.java:320)
	at javax.imageio.ImageIO$ImageReaderIterator.next(ImageIO.java:529)
	at javax.imageio.ImageIO$ImageReaderIterator.next(ImageIO.java:513)
	at javax.imageio.ImageIO.read(ImageIO.java:1443)
	at javax.imageio.ImageIO.read(ImageIO.java:1352)
	at org.openstreetmap.gui.jmapviewer.Tile.loadImage(Tile.java:169)
	at org.openstreetmap.gui.jmapviewer.OsmFileCacheTileLoader$FileLoadJob.loadOrUpdateTile(OsmFileCacheTileLoader.java:239)
	at org.openstreetmap.gui.jmapviewer.OsmFileCacheTileLoader$FileLoadJob.run(OsmFileCacheTileLoader.java:175)
	at org.openstreetmap.gui.jmapviewer.JobDispatcher$JobThread.executeJobs(JobDispatcher.java:167)
	at org.openstreetmap.gui.jmapviewer.JobDispatcher$JobThread.run(JobDispatcher.java:134)

Attachments (0)

Change History (4)

comment:1 Changed 8 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #10603.
Please don't use development builds of Java 8u40, they're not finished yet, and apparently full of bugs.

comment:2 Changed 8 years ago by skyper

Component: Core image mappingJMapViewer

comment:3 Changed 4 years ago by Don-vip

Component: JMapViewerCore imagery
Summary: Missing class when starting bingNoClassDefFoundError: Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader

comment:4 Changed 4 years ago by Don-vip

Summary: NoClassDefFoundError: Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReaderCould not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader (Ubuntu, 8u40)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.