Modify

Opened 7 years ago

Closed 7 years ago

#10765 closed defect (duplicate)

sun.awt.X11.XException when clicking Help>About

Reported by: A_Pirard Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: linux mint x11 Cc:

Description (last modified by Don-vip)

See attached file (I suppose it's not true that I have to add a status report to it, do I?).
Need I say anything else?
Yes, I also got weird exceptions when clicking left panel Draw nodes (A) icon.
Intermittent, no longer occurred.
Cheers.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-10-21 19:23:06
Last Changed Author: Don-vip
Revision: 7643
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-10-21 21:19:16 +0200 (Tue, 21 Oct 2014)
Last Changed Rev: 7643

Identification: JOSM/1.5 (7643 en) Linux Mint 13 Maya
Memory Usage: 649 MB / 1267 MB (263 MB allocated, but free)
Java version: 1.7.0_25, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u25-2.3.10-1ubuntu0.12.04.2
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
- FixAddresses (30737)
- OpeningHoursEditor (30737)
- PicLayer (30762)
- RoadSigns (30788)
- download_along (30762)
- editgpx (30737)
- geotools (30762)
- importvec (30762)
- jts (30762)
- opendata (30762)
- osmarender (30738)
- reltoolbox (30762)
- reverter (30737)
- tagging-preset-tester (30736)
- turnrestrictions (30762)
- utilsplugin2 (30762)
- waydownloader (30762)

Last errors/warnings:
- W: Could not get presets icon presets/turning_circle.png
- E: java.io.FileNotFoundException: no/home/p/.josm/Traffic rules BE.xml
(No such file or directory)
- E: no/home/p/.josm/Traffic rules BE.xml
- W: Detected deprecated 'canvas{background-color}' in
'/home/p/.josm/Papou.css' which will be removed shortly. Use
'fill-color' instead.
- E: sun.awt.X11.XException: Cannot write XdndAware property

sun.awt.X11.XException: Cannot write XdndAware property
    at sun.awt.X11.XDnDDropTargetProtocol.registerDropTarget(XDnDDropTargetProtocol.java:97)
    at sun.awt.X11.XDropTargetRegistry.registerDropSite(XDropTargetRegistry.java:571)
    at sun.awt.X11.XWindowPeer.addDropTarget(XWindowPeer.java:1919)
    at sun.awt.X11.XComponentPeer.addDropTarget(XComponentPeer.java:1374)
    at java.awt.dnd.DropTarget.addNotify(DropTarget.java:509)
    at java.awt.Component.addNotify(Component.java:6913)
    at java.awt.Container.addNotify(Container.java:2758)
    at javax.swing.JComponent.addNotify(JComponent.java:4734)
    at java.awt.Container.addNotify(Container.java:2769)
    at javax.swing.JComponent.addNotify(JComponent.java:4734)
    at java.awt.Container.addNotify(Container.java:2769)
    at javax.swing.JComponent.addNotify(JComponent.java:4734)
    at java.awt.Container.addNotify(Container.java:2769)
    at javax.swing.JComponent.addNotify(JComponent.java:4734)
    at java.awt.Container.addNotify(Container.java:2769)
    at javax.swing.JComponent.addNotify(JComponent.java:4734)
    at java.awt.Container.addNotify(Container.java:2769)
    at javax.swing.JComponent.addNotify(JComponent.java:4734)
    at java.awt.Container.addNotify(Container.java:2769)
    at javax.swing.JComponent.addNotify(JComponent.java:4734)
    at java.awt.Container.addNotify(Container.java:2769)
    at javax.swing.JComponent.addNotify(JComponent.java:4734)
    at java.awt.Container.addNotify(Container.java:2769)
    at javax.swing.JComponent.addNotify(JComponent.java:4734)
    at java.awt.Container.addNotify(Container.java:2769)
    at javax.swing.JComponent.addNotify(JComponent.java:4734)
    at java.awt.Container.addNotify(Container.java:2769)
    at javax.swing.JComponent.addNotify(JComponent.java:4734)
    at javax.swing.JRootPane.addNotify(JRootPane.java:756)
    at java.awt.Container.addNotify(Container.java:2769)
    at java.awt.Window.addNotify(Window.java:770)
    at java.awt.Dialog.addNotify(Dialog.java:760)
    at java.awt.Window.pack(Window.java:807)
    at javax.swing.JOptionPane.initDialog(JOptionPane.java:987)
    at javax.swing.JOptionPane.createDialog(JOptionPane.java:968)
    at javax.swing.JOptionPane.showOptionDialog(JOptionPane.java:867)
    at javax.swing.JOptionPane.showMessageDialog(JOptionPane.java:667)
    at org.openstreetmap.josm.actions.AboutAction.actionPerformed(AboutAction.java:107)
    at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2018)
    at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2341)
    at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
    at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
    at javax.swing.AbstractButton.doClick(AbstractButton.java:376)
    at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:833)
    at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:877)
    at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
    at java.awt.Component.processMouseEvent(Component.java:6505)
    at javax.swing.JComponent.processMouseEvent(JComponent.java:3312)
    at java.awt.Component.processEvent(Component.java:6270)
    at java.awt.Container.processEvent(Container.java:2229)
    at java.awt.Component.dispatchEventImpl(Component.java:4861)
    at java.awt.Container.dispatchEventImpl(Container.java:2287)
    at java.awt.Component.dispatchEvent(Component.java:4687)
    at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
    at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4492)
    at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
    at java.awt.Container.dispatchEventImpl(Container.java:2273)
    at java.awt.Window.dispatchEventImpl(Window.java:2719)
    at java.awt.Component.dispatchEvent(Component.java:4687)
    at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:735)
    at java.awt.EventQueue.access$200(EventQueue.java:103)
    at java.awt.EventQueue$3.run(EventQueue.java:694)
    at java.awt.EventQueue$3.run(EventQueue.java:692)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
    at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
    at java.awt.EventQueue$4.run(EventQueue.java:708)
    at java.awt.EventQueue$4.run(EventQueue.java:706)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
    at java.awt.EventQueue.dispatchEvent(EventQueue.java:705)
    at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
    at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
    at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Attachments (1)

trace.txt (6.6 KB) - added by A_Pirard 7 years ago.

Download all attachments as: .zip

Change History (2)

Changed 7 years ago by A_Pirard

Attachment: trace.txt added

comment:1 Changed 7 years ago by Don-vip

Description: modified (diff)
Keywords: linux mint x11 added
Resolution: duplicate
Status: newclosed
Summary: 7643 exception when clicking Help>Aboutsun.awt.X11.XException when clicking Help>About

Closed as duplicate of #9771.
Please update to Java 8u20 or later to get rid of this bug.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.