Modify

Opened 8 years ago

Closed 8 years ago

Last modified 4 years ago

#10755 closed defect (duplicate)

Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader (openSUSE, 8u40)

Reported by: helmflorsil@… Owned by: team
Priority: normal Milestone:
Component: Core imagery Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. JOSM produce one error when I want to load this wms_endpoint:http://sdi.provincia.bz.it/geoserver/inspire/wms?service=wms&version=1.3.0&request=GetCapabilities as a background

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

Revision: 7643
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: Don-vip
Last Changed Date: 2014-10-21 21:19:16 +0200 (Tue, 21 Oct 2014)
Build-Date: 2014-10-21 19:23:06
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 7643

Identification: JOSM/1.5 (7643 de) Linux openSUSE 13.2 (Harlequin) (x86_64)
Memory Usage: 445 MB / 910 MB (189 MB allocated, but free)
Java version: 1.8.0_40, Oracle Corporation, OpenJDK 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- DirectDownload (30737)
- DirectUpload (30737)
- DxfImport (UNKNOWN)
- FastDraw (30762)
- PicLayer (30762)
- alignways (30695)
- buildings_tools (30762)
- contourmerge (1012)
- dataimport (30800)
- editgpx (30737)
- ext_tools (30738)
- geotools (30762)
- importvec (30762)
- jts (30762)
- log4j (30762)
- merge-overlap (30762)
- mirrored_download (30762)
- native_password_manager (30739)
- osmarender (30738)
- pdfimport (30737)
- plastic_laf (30762)
- reltoolbox (30762)
- tageditor (30738)
- tagging-preset-tester (30736)
- terracer (30737)
- utilsplugin2 (30762)

Last errors/warnings:
- W: Could not get presets icon Icon_npu.png
- E: Fehler beim Laden des Bildes 'Icon_uzkb.png'
- W: Could not get presets icon Icon_uzkb.png
- E: java.lang.UnsatisfiedLinkError: com.sun.imageio.plugins.jpeg.JPEGImageReader.initReaderIDs(Ljava/lang/Class;Ljava/lang/Class;Ljava/lang/Class;)V
- E: java.lang.NoClassDefFoundError: Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader

java.lang.NoClassDefFoundError: Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader
	at com.sun.imageio.plugins.jpeg.JPEGImageReaderSpi.createReaderInstance(JPEGImageReaderSpi.java:85)
	at javax.imageio.spi.ImageReaderSpi.createReaderInstance(ImageReaderSpi.java:320)
	at javax.imageio.ImageIO$ImageReaderIterator.next(ImageIO.java:529)
	at javax.imageio.ImageIO$ImageReaderIterator.next(ImageIO.java:513)
	at org.openstreetmap.josm.tools.ImageProvider.read(ImageProvider.java:1238)
	at org.openstreetmap.josm.tools.ImageProvider.read(ImageProvider.java:1140)
	at org.openstreetmap.josm.io.imagery.WMSGrabber.grab(WMSGrabber.java:292)
	at org.openstreetmap.josm.io.imagery.WMSGrabber.fetch(WMSGrabber.java:169)
	at org.openstreetmap.josm.io.imagery.WMSGrabber.attempt(WMSGrabber.java:132)
	at org.openstreetmap.josm.io.imagery.WMSGrabber.run(WMSGrabber.java:116)
	at java.lang.Thread.run(Thread.java:745)

Attachments (0)

Change History (3)

comment:1 Changed 8 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #10603.

comment:2 Changed 4 years ago by Don-vip

Component: CoreCore imagery
Summary: JOSM produce one error when I want to load this wms_endpoint:http://sdi.provincia.bz.it/geoserver/inspire/wms?service=wms&version=1.3.0&request=GetCapabilities as a backgroundNoClassDefFoundError: Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader

comment:3 Changed 4 years ago by Don-vip

Summary: NoClassDefFoundError: Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReaderCould not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader (openSUSE, 8u40)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.