Modify

Opened 3 years ago

Closed 3 years ago

#10727 closed enhancement (duplicate)

Support traffic_signals:direction

Reported by: robert.ancell@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

Traffic signals may need to have a direction marked for them [1]. JOSM doesn't seem to know of this:

  • By default, JOSM doesn't have the traffic_signals:direction tag pre-populated in the combo boxs.
  • The icons are not rendered in a way to show the direction.
  • If you reverse a way containing traffic signals JOSM doesn't prompt you to reverse the traffic_signals:direction tags.

[1] http://wiki.openstreetmap.org/wiki/Key:traffic_signals:direction

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by skyper

Once again direction=forward/backward does not work with nodes. It is a broken system as it does not work on last/first node and it relies on the direction of the parent object. No editor software supports this tagging when changing direction of the way.

You need to use proper values for direction=* e.g. cardinal directions or a relation.

See also #10260.

comment:2 Changed 3 years ago by stoecker

Resolution: duplicate
Status: newclosed

Closed as duplicate of #10260.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.