Modify

Opened 5 years ago

Closed 5 years ago

#10695 closed defect (fixed)

NPE with v7694, v7684 works

Reported by: anonymous Owned by: team
Priority: normal Milestone: 14.11
Component: Core Version:
Keywords: regression Cc:

Description

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-11-02 14:42:43
Last Changed Author: stoecker
Revision: 7694
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-11-02 11:38:51 +0100 (Sun, 02 Nov 2014)
Last Changed Rev: 7694

Identification: JOSM/1.5 (7694 de) Linux openSUSE 13.2 (Harlequin) (x86_64)
Memory Usage: 167 MB / 1820 MB (47 MB allocated, but free)
Java version: 1.7.0_71, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: java-1_7_0-openjdk:x86_64-1.7.0.71
VM arguments: [-Dsun.java2d.opengl=false]

Plugins:
- FixAddresses
- OpeningHoursEditor
- RoadSigns
- continuosDownload
- imagery_offset_db
- mirrored_download
- notes
- public_transport
- reverter
- terracer
- turnlanes
- turnrestrictions
- undelete
- utilsplugin2

Last errors/warnings:
- E: Fehler beim Laden des Bildes 'error_small.png'
- E: java.lang.RuntimeException: java.util.concurrent.ExecutionException: java.lang.NullPointerException. Ursache: java.util.concurrent.ExecutionException: java.lang.NullPointerException. Ursache: java.lang.NullPointerException

java.lang.RuntimeException: java.util.concurrent.ExecutionException: java.lang.NullPointerException
	at org.openstreetmap.josm.Main.<init>(Main.java:606)
	at org.openstreetmap.josm.gui.MainApplication.<init>(MainApplication.java:86)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:421)
Caused by: java.util.concurrent.ExecutionException: java.lang.NullPointerException
	at java.util.concurrent.FutureTask.report(FutureTask.java:122)
	at java.util.concurrent.FutureTask.get(FutureTask.java:188)
	at org.openstreetmap.josm.Main.<init>(Main.java:603)
	... 2 more
Caused by: java.lang.NullPointerException
	at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:406)
	at org.openstreetmap.josm.gui.mappaint.MapPaintStyles.getIcon(MapPaintStyles.java:105)
	at org.openstreetmap.josm.gui.mappaint.StyleSource.getSourceIcon(StyleSource.java:135)
	at org.openstreetmap.josm.gui.mappaint.StyleSource.getIcon(StyleSource.java:146)
	at org.openstreetmap.josm.gui.mappaint.MapPaintMenu$MapPaintAction.<init>(MapPaintMenu.java:36)
	at org.openstreetmap.josm.gui.mappaint.MapPaintMenu.mapPaintStylesUpdated(MapPaintMenu.java:99)
	at org.openstreetmap.josm.gui.mappaint.MapPaintStyles.fireMapPaintSylesUpdated(MapPaintStyles.java:433)
	at org.openstreetmap.josm.gui.mappaint.MapPaintStyles.readFromPreferences(MapPaintStyles.java:216)
	at org.openstreetmap.josm.gui.preferences.map.MapPaintPreference.initialize(MapPaintPreference.java:183)
	at org.openstreetmap.josm.Main$4.initialize(Main.java:588)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:644)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:628)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:745)

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by Don-vip

Keywords: regression added
Milestone: 14.11
Summary: error messages with v7694, v7684 worksNPE with v7694, v7684 works

comment:2 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7695/josm:

fix #10695 - NPE

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.