Modify

Opened 7 years ago

Closed 7 years ago

#10677 closed defect (duplicate)

josm crashed while downloading data from osm

Reported by: robin@… Owned by: kendzi
Priority: normal Milestone:
Component: Plugin kendzi3d Version:
Keywords: Cc:

Description

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-10-21 19:23:06
Last Changed Author: Don-vip
Revision: 7643
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-10-21 21:19:16 +0200 (Tue, 21 Oct 2014)
Last Changed Rev: 7643

Identification: JOSM/1.5 (7643 en_GB) Linux Ubuntu 14.04.1 LTS
Memory Usage: 125 MB / 494 MB (56 MB allocated, but free)
Java version: 1.7.0_65, Oracle Corporation, OpenJDK Client VM
Java package: openjdk-7-jre:i386-7u71-2.5.3-0ubuntu0.14.04.1
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
- kendzi3d (1.0.178)
- kendzi3d-jogl (37)
- log4j (30416)
- measurement (30416)
- routing (30416)

Last errors/warnings:
- W: java.net.SocketTimeoutException: Read timed out
- E: Id 'Bing' is not unique - used by 'Bing Sat' and 'Bing Sat'!
- E: Id 'Bing' is not unique - used by 'Bing Sat' and 'Bing Sat'!
- E: Id 'Bing' is not unique - used by 'Bing Sat' and 'Bing Sat'!
- E: java.lang.reflect.InvocationTargetException. Cause: java.lang.NoClassDefFoundError: org/openstreetmap/josm/data/osm/DataSource. Cause: java.lang.ClassNotFoundException: org.openstreetmap.josm.data.osm.DataSource

java.lang.reflect.InvocationTargetException
	at java.awt.EventQueue.invokeAndWait(EventQueue.java:1276)
	at java.awt.EventQueue.invokeAndWait(EventQueue.java:1251)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:98)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:161)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.NoClassDefFoundError: org/openstreetmap/josm/data/osm/DataSource
	at kendzi.josm.kendzi3d.jogl.RenderJOSM.centerFromDataSet(RenderJOSM.java:503)
	at kendzi.josm.kendzi3d.jogl.RenderJOSM.processDatasetEvent(RenderJOSM.java:459)
	at org.openstreetmap.josm.data.osm.event.DataSetListenerAdapter.dataChanged(DataSetListenerAdapter.java:24)
	at org.openstreetmap.josm.data.osm.event.DataChangedEvent.fire(DataChangedEvent.java:26)
	at org.openstreetmap.josm.data.osm.event.DatasetEventManager.fireEvents(DatasetEventManager.java:120)
	at org.openstreetmap.josm.data.osm.event.DatasetEventManager.processDatasetEvent(DatasetEventManager.java:135)
	at org.openstreetmap.josm.data.osm.event.DatasetEventManager.editLayerChanged(DatasetEventManager.java:111)
	at org.openstreetmap.josm.gui.MapView.fireEditLayerChanged(MapView.java:190)
	at org.openstreetmap.josm.gui.MapView.setEditLayer(MapView.java:785)
	at org.openstreetmap.josm.gui.MapView.setActiveLayer(MapView.java:812)
	at org.openstreetmap.josm.gui.MapView.setActiveLayer(MapView.java:799)
	at org.openstreetmap.josm.gui.MapView.addLayer(MapView.java:361)
	at org.openstreetmap.josm.Main.addLayer(Main.java:662)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$AbstractInternalTask.addNewLayerIfRequired(DownloadOsmTask.java:266)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$AbstractInternalTask.loadData(DownloadOsmTask.java:279)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$DownloadTask.finish(DownloadOsmTask.java:341)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable$1.run(PleaseWaitRunnable.java:101)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:302)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:733)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:703)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:154)
	at java.awt.WaitDispatchSupport$2.run(WaitDispatchSupport.java:182)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:221)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.WaitDispatchSupport.enter(WaitDispatchSupport.java:219)
	at java.awt.Dialog.show(Dialog.java:1082)
	at java.awt.Component.show(Component.java:1655)
	at java.awt.Component.setVisible(Component.java:1607)
	at java.awt.Window.setVisible(Window.java:1014)
	at java.awt.Dialog.setVisible(Dialog.java:1005)
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$4.run(PleaseWaitProgressMonitor.java:172)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:312)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:733)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:703)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)
Caused by: java.lang.ClassNotFoundException: org.openstreetmap.josm.data.osm.DataSource
	at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
	... 52 more

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by Don-vip

Component: CorePlugin kendzi3d
Owner: changed from team to kendzi
Summary: josm crashed while downloading datta from osmjosm crashed while downloading data from osm

comment:2 Changed 7 years ago by kendzi

Kendzi3d plugin is outdated!

JOSM interface was changed and plugin is required to be upgraded. More information can be found in ticket #10560

Please upgrade kendzi3d to version 1.0.180

comment:3 Changed 7 years ago by stoecker

Resolution: duplicate
Status: newclosed

Closed as duplicate of #10560.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain kendzi.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.