Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10633 closed defect (fixed)

Hotkeys don't work after minimize window

Reported by: hosteddinner@… Owned by: team
Priority: normal Milestone: 14.10
Component: Core Version:
Keywords: focus shortcut regression Cc:

Description

What steps will reproduce the problem?

  1. minimize JOSM
  2. reopen JOSM from taskbar
  3. give the main window focus by clicking in it (often the Relation Seacrh has focus)
  4. press a hotkey (e.g. "A" for Line Drawing or "B" for Building tool)

What is the expected result?
Switching to the line drawing tool

What happens instead?
Nothing (visible)

Please provide any additional information below. Attach a screenshot if
possible.

Does happen since last update.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-09-29 22:12:08
Last Changed Author: Don-vip
Revision: 7588
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-09-29 23:52:43 +0200 (Mon, 29 Sep 2014)
Last Changed Rev: 7588

Identification: JOSM/1.5 (7588 de) Windows 8 64-Bit
Memory Usage: 220 MB / 1813 MB (34 MB allocated, but free)
Java version: 1.7.0_51, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- FixAddresses (30416)
- HouseNumberTaggingTool (30416)
- OpeningHoursEditor (30609)
- buildings_tools (30485)
- measurement (30641)
- mirrored_download (30664)
- notes (v0.9.4)
- terracer (30643)

Last errors/warnings:
- E: Fehler beim Laden des Bildes ''
- W: Could not get presets icon 
- E: Fehler beim Laden des Bildes ''
- W: Could not get presets icon 
- W: Veraltetes 'canvas{background-color}' in 'http://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip' entdeckt, welches in Kürze entfernt wird. Verwenden Sie stattdessen 'fill-color'.

Attachments (0)

Change History (4)

comment:1 Changed 5 years ago by hosteddinner@…

Little correction: only minmizing alone does not has this effect, but getting something else minimized in front and turning back to JOSM.

comment:2 Changed 5 years ago by Don-vip

Keywords: focus shortcut regression added
Milestone: 14.10

comment:3 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7618/josm:

fix #10633 - fix disabled shortcuts after focusing relation filter, command line field, etc. Regression from r7539 + r7505

comment:4 Changed 5 years ago by Don-vip

Ticket #10591 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.