Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#10619 closed defect (invalid)

measurement plugin keeps crashing on loading data

Reported by: mkoniecz Owned by: team
Priority: normal Milestone:
Component: Plugin measurement Version:
Keywords: Cc:

Description

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-10-08 01:35:06
Last Changed Author: Don-vip
Revision: 7608
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-10-08 00:01:23 +0200 (Wed, 08 Oct 2014)
Last Changed Rev: 7608

Identification: JOSM/1.5 (7608 en) Linux Ubuntu 14.04.1 LTS
Memory Usage: 263 MB / 889 MB (172 MB allocated, but free)
Java version: 1.7.0_67, Oracle Corporation, Java HotSpot(TM) Server VM
Dataset consistency test: No problems found

Plugins:
- ImportImagePlugin (30416)
- OpeningHoursEditor (30609)
- PicLayer (30436)
- buildings_tools (30485)
- geotools (30569)
- jts (30416)
- log4j (30416)
- measurement (30267)
- notes (v0.9.4)
- turnrestrictions (30651)

Last errors/warnings:
- E: org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin measurement. Cause: java.lang.reflect.InvocationTargetException. Cause: java.lang.NoSuchMethodError: org.openstreetmap.josm.gui.NavigatableComponent.getSystemOfMeasurement()Lorg/openstreetmap/josm/gui/NavigatableComponent$SystemOfMeasurement;

org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin measurement
	at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:34)
	at org.openstreetmap.josm.Main.setMapFrame(Main.java:488)
	at org.openstreetmap.josm.Main.createMapFrame(Main.java:668)
	at org.openstreetmap.josm.Main.addLayer(Main.java:657)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$DownloadTask.finish(DownloadOsmTask.java:269)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable$1.run(PleaseWaitRunnable.java:102)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:302)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:733)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:703)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:154)
	at java.awt.WaitDispatchSupport$2.run(WaitDispatchSupport.java:182)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:221)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.WaitDispatchSupport.enter(WaitDispatchSupport.java:219)
	at java.awt.Dialog.show(Dialog.java:1082)
	at java.awt.Component.show(Component.java:1655)
	at java.awt.Component.setVisible(Component.java:1607)
	at java.awt.Window.setVisible(Window.java:1014)
	at java.awt.Dialog.setVisible(Dialog.java:1005)
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$4.run(PleaseWaitProgressMonitor.java:172)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:312)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:733)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:703)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:30)
	... 40 more
Caused by: java.lang.NoSuchMethodError: org.openstreetmap.josm.gui.NavigatableComponent.getSystemOfMeasurement()Lorg/openstreetmap/josm/gui/NavigatableComponent$SystemOfMeasurement;
	at org.openstreetmap.josm.plugins.measurement.MeasurementDialog.getDistText(MeasurementDialog.java:138)
	at org.openstreetmap.josm.plugins.measurement.MeasurementDialog.<init>(MeasurementDialog.java:107)
	at org.openstreetmap.josm.plugins.measurement.MeasurementPlugin.mapFrameInitialized(MeasurementPlugin.java:28)
	... 45 more

Attachments (0)

Change History (5)

comment:1 Changed 5 years ago by mkoniecz

And here is what was described as a "bug in JOSM" on disabling this plugin

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-10-08 01:35:06
Last Changed Author: Don-vip
Revision: 7608
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-10-08 00:01:23 +0200 (Wed, 08 Oct 2014)
Last Changed Rev: 7608

Identification: JOSM/1.5 (7608 en) Linux Ubuntu 14.04.1 LTS
Memory Usage: 271 MB / 889 MB (151 MB allocated, but free)
Java version: 1.7.0_67, Oracle Corporation, Java HotSpot(TM) Server VM
Dataset consistency test: No problems found

Plugins:
- ImportImagePlugin (30416)
- OpeningHoursEditor (30609)
- PicLayer (30436)
- buildings_tools (30485)
- continuosDownload (1412331234)
- geotools (30569)
- jts (30416)
- log4j (30416)
- measurement (30267)
- notes (v0.9.4)
- turnrestrictions (30651)

Last errors/warnings:
- E: org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin measurement. Cause: java.lang.reflect.InvocationTargetException. Cause: java.lang.NoSuchMethodError: org.openstreetmap.josm.gui.NavigatableComponent.getSystemOfMeasurement()Lorg/openstreetmap/josm/gui/NavigatableComponent$SystemOfMeasurement;

org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin measurement
	at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:34)
	at org.openstreetmap.josm.Main.setMapFrame(Main.java:488)
	at org.openstreetmap.josm.Main.createMapFrame(Main.java:668)
	at org.openstreetmap.josm.Main.addLayer(Main.java:657)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$DownloadTask.finish(DownloadOsmTask.java:269)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable$1.run(PleaseWaitRunnable.java:102)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:302)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:733)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:703)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:154)
	at java.awt.WaitDispatchSupport$2.run(WaitDispatchSupport.java:182)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:221)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.WaitDispatchSupport.enter(WaitDispatchSupport.java:219)
	at java.awt.Dialog.show(Dialog.java:1082)
	at java.awt.Component.show(Component.java:1655)
	at java.awt.Component.setVisible(Component.java:1607)
	at java.awt.Window.setVisible(Window.java:1014)
	at java.awt.Dialog.setVisible(Dialog.java:1005)
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$4.run(PleaseWaitProgressMonitor.java:172)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:312)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:733)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:703)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:30)
	... 40 more
Caused by: java.lang.NoSuchMethodError: org.openstreetmap.josm.gui.NavigatableComponent.getSystemOfMeasurement()Lorg/openstreetmap/josm/gui/NavigatableComponent$SystemOfMeasurement;
	at org.openstreetmap.josm.plugins.measurement.MeasurementDialog.getDistText(MeasurementDialog.java:138)
	at org.openstreetmap.josm.plugins.measurement.MeasurementDialog.<init>(MeasurementDialog.java:107)
	at org.openstreetmap.josm.plugins.measurement.MeasurementPlugin.mapFrameInitialized(MeasurementPlugin.java:28)
	... 45 more

comment:2 Changed 5 years ago by Don-vip

Resolution: invalid
Status: newclosed

Please update your plugin to latest version (30641).

comment:3 Changed 5 years ago by mkoniecz

I selected update on previous crash, plugin claimed that it updated to 30641.

comment:4 Changed 5 years ago by Don-vip

Please try again as you still have an old incompatible version.

comment:5 Changed 4 years ago by mkoniecz

I found what was causing problems: I installed josm form hilariously outdated packages maintained from Ubuntu, that I switched to manually downloaded josm-latest.jar.

But it was necessary to run

sudo apt-get remove josm josm-plugins

as explained on http://josm.openstreetmap.de/wiki/Download#Ubuntu to remove outdated plugins.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.