Modify

Opened 6 years ago

Closed 6 years ago

#10550 closed defect (fixed)

no building border for inner way in multipolygon

Reported by: mkoniecz Owned by: team
Priority: normal Milestone: 14.11
Component: Internal mappaint style Version:
Keywords: template_report multipolygon building inner Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. Create building multipolygon with inner way See https://www.openstreetmap.org/way/43805254

What is the expected result?
Inner way is rendered like outer way.

What happens instead?
Inner way is not rendered like outer way:


Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-09-23 01:33:40
Last Changed Author: Don-vip
Revision: 7580
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-09-22 23:20:16 +0200 (Mon, 22 Sep 2014)
Last Changed Rev: 7580

Identification: JOSM/1.5 (7580 en) Linux Ubuntu 14.04.1 LTS
Memory Usage: 370 MB / 889 MB (225 MB allocated, but free)
Java version: 1.7.0_65, Oracle Corporation, OpenJDK Server VM
Java package: openjdk-7-jre:i386-7u65-2.5.2-3~14.04
Dataset consistency test: No problems found

Attachments (2)

2014-09-23-220221_1366x744_scrot.png (208.8 KB) - added by mkoniecz 6 years ago.
10550_works.png (68.7 KB) - added by Don-vip 6 years ago.

Download all attachments as: .zip

Change History (13)

Changed 6 years ago by mkoniecz

comment:1 Changed 6 years ago by mkoniecz

Component: CoreInternal mappaint style

comment:2 Changed 6 years ago by mkoniecz

Description: modified (diff)

comment:3 Changed 6 years ago by Don-vip

Description: modified (diff)
Keywords: multipolygon building inner added

Changed 6 years ago by Don-vip

Attachment: 10550_works.png added

comment:4 Changed 6 years ago by Don-vip

It works for me. Did you do something special to create or download this building?


comment:5 Changed 6 years ago by mkoniecz

I edited it from building=* on outer way to building=* on multipolygon, then noticed problem. Maybe it was present before edit.

comment:6 Changed 6 years ago by stoecker

Refresh issue of styles under certain conditions? We had refresh problems in the past as well.

comment:7 Changed 6 years ago by mkoniecz

And I removed tag on outer way *before* adding it to multipolygon.

comment:8 Changed 6 years ago by Don-vip

Owner: changed from team to mkoniecz
Status: newneedinfo

Can you check if it's resolved with r7682?

comment:9 Changed 6 years ago by mkoniecz

No. https://www.openstreetmap.org/way/200358349

Remove all tags from outer way, inner way is styled for some time.

After redrawing is triggered undo all edits - inner way stays unstyled for some time.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-10-31 18:43:50
Last Changed Author: Don-vip
Revision: 7682
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-10-31 19:39:33 +0100 (Fri, 31 Oct 2014)
Last Changed Rev: 7682

Identification: JOSM/1.5 (7682 en) Linux Ubuntu 14.04.1 LTS
Memory Usage: 387 MB / 889 MB (80 MB allocated, but free)
Java version: 1.7.0_72, Oracle Corporation, Java HotSpot(TM) Server VM
Dataset consistency test: No problems found

Plugins:
- continuosDownload (1413902943)

comment:10 Changed 6 years ago by Don-vip

Milestone: 14.11
Owner: changed from mkoniecz to team
Status: needinfonew

comment:11 Changed 6 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7683/josm:

fix #10550 - fix another style cache issue of multipolygon members

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.