Modify

Opened 5 years ago

Closed 11 days ago

#10475 closed enhancement (duplicate)

if-then-else for <check>

Reported by: malcolmh Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: preset check Cc: skyper

Description (last modified by Don-vip)

The current <check> only allows one key with one of two values. Often it is required to select alternative key/value pairs, rather than alternative values for a single key. Also more than one key/value pair may be wanted. I suggest the following enhancement to <check>:

<check text="..." default="...">
  <check_on>
    <key key="..." value="..."/>
    <key ... />
  </check_on>
  <check_off>
    <key key="..." value="..."/>
    <key ... />
  </check_off>
</check>

Where only one key/value pair is required, then <check_on key="..." value="..."/> or <check_off key="..." value="..."/> would be used for either or both the then & else cases.

Attachments (0)

Change History (6)

comment:1 Changed 5 years ago by Don-vip

Description: modified (diff)
Keywords: preset added

comment:2 Changed 5 years ago by Don-vip

Description: modified (diff)

comment:3 Changed 5 years ago by skyper

Cc: skyper added

comment:4 Changed 5 years ago by malcolmh

Multiple key/value pairs would also be useful in combos and multiselects. i.e.:

<list_entry>

<key key="..." value="..."/>
<key ... />

</list_entry>

comment:5 Changed 5 years ago by anonymous

Ticket #8177 seems to be asking for much the same thing.

comment:6 Changed 11 days ago by Don-vip

Keywords: check added
Resolution: duplicate
Status: newclosed

Closed as duplicate of #8177.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.